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HVRC CREATE: Guideline Tool User Guide. 

This document contains information proprietary to IFE Digital Systems. Information contained herein 
may not be copied, reproduced, disclosed or used without the express written permission of IFE Digital 
Systems. This document may be copied for use internally at the licensed site only. 

IFE Digital Systems makes no warranties with respect to the contents or use of this document, 
including but not limited to the implied warranties of merchantability and fitness for a particular 
purpose. 

The information contained in this document is subject to change without notice. 

Java™ is a trademark of Oracle Corp. 
OpenGL® is a registered trademark of Hewlett Packard Enterprise. 
Apple®, MacOS X® and macOS® are registered trademarks of Apple, Inc. 
Microsoft® and Windows® are registered trademarks of Microsoft Corp. 

All other trademarks used within this document are the properties of their respective trademark holders.  

Comments about this document are welcome and may be sent to <create-support@ife.no>. 

 

© Halden Virtual Reality Centre, IFE Digital Systems 2002-2024. All rights reserved.
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1 Overview 

1.1 HVRC CREATE 
HVRC CREATE 4 is the fourth generation of the CREATE tool suite, and builds on the technical 
platform and functionality established during the implementation of earlier versions of the software, as 
well as valuable feedback gained from usability evaluations and research work by the development 
team. 

The CREATE control room design tools combine advanced interactive 3D technology with server-
based user, project, and file management, providing an integrated package that supports and traces the 
various stages of a human-centred design process. 

The software has been designed to support a flexible, iterative, design methodology, where a control 
room design is refined and tested many times before a final design is reached. This contrasts with 
traditional control room design methods where the design process only goes through one or two human 
factors review iterations, and where it is necessary to build a costly physical control room mock-up. 
Design iterations are tracked by the system.  

When these virtual reality tools are used, it is not necessary to wait until a physical mock-up has been 
constructed before commencing design verification and validation against human factors guidelines, so 
greater emphasis can be placed on finding an optimal design solution for safe and efficient control 
room operation. Users with a variety of technical skills can operate the software, so control room 
operators, designers, human factors specialists, engineers and managers can all participate to some 
degree in the design process. 

CREATE provides features designed to support and enhance communication between the various 
interest groups involved in a design project. Support for communication between the layout designers 
and reviewers is integrated into the system, while it is possible to extract electronic documents such as 
models, designs and reports for distribution to other interested parties. 

The CREATE tools support the management of a reusable database of 3D objects, the interactive 
construction of control room layouts, and the validation of control room layouts against guidelines. 

The CREATE tools are based on cross-platform Internet and Java technology and open standards such 
as ISO VRML, DAE/COLLADA, XML, and HTML. 

1.2 Guideline Tool 
The Guideline Tool is used to install and manage sets of guidelines that are stored on the server. 

The tool supports design and review guideline sets. Using the tool, it is possible to enter and display 
additional information that explains how the designer or reviewer should use the guideline in the 
Layout Tool (for design guidelines) or Verification Tool (for review guidelines). 

Guidelines are written in HTML using a template supplied with the system and following conventions 
specified in this documentation. 
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2 Getting Started 

2.1 System Requirements 
The minimum requirements for the HVRC CREATE Tools are: 

• Intel Core i5 (8th gen) x64 processor or similar 
• 8GB RAM 
• 64-bit Microsoft Windows 10 or Apple macOS 11 
• Discrete 3D graphics accelerator with at least 2GB memory and OpenGL 3.3 driver support  
• For Microsoft Windows: 250MB free disk space for the complete tool suite. 

For macOS: 1GB. 
• A three-button mouse (or a two-button mouse with scroll-wheel "button") 

Use the option or alt-key on your keyboard in combination with the left mouse button to simulate the 
middle mouse button if you do not have three mouse buttons. 

2.2 Installation 
Important: See System Requirements above before installing 

On Windows, the installer called “CREATE Tools Installer” installs the full set of tools, including the 
Guideline Tool. Double-click on the installer and follow the instructions. 

On macOS, simply drag the Guideline Tool (or the whole folder enclosing it) from the installation 
image into your Applications folder. 

2.3 Starting the Guideline Tool 
To run the Guideline Tool, open the CREATE directory, which was created when you installed the 
tools, and double-click on the Guideline Tool icon. 

Depending on what options you selected when running the installer, you may also be able to start the 
tool by double clicking on an icon on the Microsoft Windows desktop or by selecting it from the Start 
menu (in the "HVRC CREATE" group). 

Important: The first time you run a CREATE tool, a wizard will appear that guides you through 
configuring your connection to a CREATE Server. After the wizard has completed, you can change 
your settings via the Preferences Window (see The Preferences Window - section 6.1) and enter the 
CREATE server URL (the CREATE server's address). Ask your system administrator or project 
manager for assistance if you do not know what to enter. 

The information above assumes that you are using Microsoft Windows. On other platforms, the 
installation follows the platform conventions to provide easy access to the installed software. 

2.4 Support 
Please send questions, bug reports, or requests for new features to: create-support@ife.no 

When submitting bug reports, please include the following information: 

• A description of the result and how it differed from what you expected 
• The conditions or circumstances under which the problem occurred 
• Any other information that could be useful to isolate the problem, including the version of 

CREATE you are using, the version of the operating system of your computer, and the type of 
graphics card you are using. An overview of useful technical information is displayed in the 
tool’s About dialog, located in the Help menu, and can be copied into an email or saved to 
disk in a text file. 

mailto:create-support@ife.no
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2.5 User Identification 
Before you can use the Guideline Tool to do any work, the server administrator or your project 
manager must have assigned a login name and password to you. If you do not have a login name and 
password then contact the server administrator or your project manager for assistance. 

When the Guideline Tool starts up and needs to retrieve data from the server, it will usually request that 
you enter your login name and password. If this does not occur then you should check that the 
CREATE server address has been correctly set (see The Preferences Window – Section 6.1). If the 
server address is correct then you should verify with your system administrator or project manager that 
the host is currently operating and accessible on your network. 

You will not be able to use the Guideline Tool to do anything other than access items in the Help menu 
and specify the server address in the Preferences Window if you are not logged on to a CREATE 
server. 

Important: If you enter an incorrect username and/or password then you may have to restart the 
Guideline Tool in order to log onto the server. After a successful login, you can enable an auto-login 
feature via the Preferences Window so that you do not need to enter your username and password each 
time. 

2.6 Changing Your Password 
You can change your password via the Edit > Set Password… menu item. For security reasons, you 
should change your password regularly and use a password that is difficult for other people to guess. 

You must be logged on to a CREATE server in order to change your password. 

To change your password: 

1. Select Edit > Set Password… 

2. The Change Password dialog will appear: 

 
The Change Password Dialog 

3. Enter a new password into the Password field 

4. Enter the new password again in the Confirm Password field 

5. Click on OK to commit the change or Cancel to abort 

6. If you commit the change and the two passwords entered do not match, you will be asked to 
enter the passwords again 



Release 4.2 (rev: 03/01/2024) 7 Guideline Tool User Guide 

2.7 Overview of the User Interface 

 
The Guideline Tool User Interface 

The Guideline Tool user interface consists of a window title bar, a main menu bar, a toolbar, a 
guideline panel and a procedure panel. 

If a guideline set is loaded, the window title bar indicates which guideline set is displayed. 

The menus in the main menu bar are described in Menus (Section 5). 

The toolbar is used to browse loaded guidelines and reload the information that is currently displayed. 
If no guidelines are loaded then the browsing buttons are disabled. 

Guidelines are displayed in the guideline panel. If no guideline set is loaded, this panel displays a 
welcome page, otherwise it displays an individual guideline or guideline set index. The guideline set 
index is a list of hyperlinks that can be used to go directly to an individual guideline. 

The procedure panel is used to enter and display additional information that explains how the designer 
or reviewer should use the guideline in the Layout Tool (for design guidelines) or Verification Tool 
(for review guidelines). 

There is a split bar between the guideline and procedure panel, which can be move to adjust the relative 
sizes of the two panels. Clicking on the arrows on the split bar causes the bar to move to the top, 
bottom, or default position, depending on the bar’s initial location and which arrow is clicked on. This 
enables you to maximise the size of either the guideline panel or the procedure panel. 

Usage of the Guideline Tool is described in Managing Guideline Sets (Section 4). 
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3 Creating a New Guideline Set 
This chapter describes the file format of a guideline set. This information is useful if you intend to 
create your own guideline set. 

Creating a guideline set is not difficult but a little knowledge of HTML is useful. Individual guidelines 
are HTML files that can contain text and tables and include images. The only significant restrictions 
that you should be aware of are that individual guidelines must not contain hyperlinks. An example 
template is provided in the following sub-section (The Guideline Set File Format). 

As guidelines are created in HTML format, they can be created using a text or HTML editor. A word 
processing package such as Microsoft Word can also be used to create HTML code that can be inserted 
in guideline files using a text or HTML editor, however word processing software tends to produce sub 
optimal HTML code, so copying text and images into a HTML editor will usually give better results. 
Netscape Composer is a HTML editor that works well. Microsoft Front Page and other HTML editors 
can also be used. 

If you choose to use Microsoft Word to create HTML code then it is recommended that you download 
and use Microsoft's Office HTML Filter tool from the Microsoft website to clean up the HTML code. 
An alternative is to use the utility program Tidy from the World Wide Web Consortium at 
http://www.w3c.org/tidy/. Both Tidy and The Office HTML Filter remove Office-specific HTML code 
from the files resulting in huge file size reductions in addition to better compatibility with non-
Microsoft web browsers. 

You do not need to index your guideline set as indexing is performed by the Guideline Tool. 

3.1 The Guideline Set File Format 
A guideline set consists of a directory containing the following elements: 

• A set of HTML files and associated images for the guidelines 

o The images may be located in sub-directories 

• A set of text files that contain the (optional) procedures associated with each guideline 

The user/author does not have to create an index as the CREATE system generates an index 
automatically from the data provided). If a guideline set is installed on the server using the Guideline 
Tool and is then exported then the exported version will include a copy of the generated index that can 
be used to easily access the individual guidelines using a HTML browser. An exported guideline set 
therefore contains two files called index.txt and index.html. These are ignored by the system if the 
guideline set is reinstalled as the server rebuilds those files. 

Important note on guideline set directory naming: 

The directory name for the guideline set should be unique for your guideline set. If you attempt to 
install a new guideline set with a directory name the same as a previous one then the software will 
assume that you want to replace the original guideline set. Directory names should contain only the 
characters A-Z, a-z, 0-9, - (minus), or _ (underscore). If your directory name contains spaces then they 
will be converted automatically to underscores when the guideline set is installed. 

For example, ife_design_1_0 is an appropriate directory name for the guideline set “IFE Design 
Guidelines 1.0”. 

See also: 

Installing a guideline set 

http://www.w3c.org/tidy/
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3.1.1 The Guidelines 
A guideline is a HTML file where the first element in the document body is a header tag that contains 
text in a special format that is used to index all of the HTML files in a guideline set. 

Here is a complete example guideline template: 
   <HTML> 
   <HEAD> 
      <TITLE>#.#.# Guideline Name</TITLE> 
   </HEAD> 
   <BODY> 
      <H1>#.#.# Guideline Name</H1> 
      <!-- The HTML text and images of the guideline go here --> 
   </BODY> 
   </HTML> 
 
The first HTML header in the body of each document is read by CREATE and is used to sort the 
guidelines and identify their names so each file should include a header in the following format: 

<H1>#.#.# Guideline Name</H1> 
 

Where # is a number, and the # sequence and the guideline name are separated by a space. 

The # sequence is the chapter/section/sub-section/... (e.g. 1.0, 1.1, 1.1.1, 1.1.2,…) and is used by the 
server to index the guidelines. It should always contain at least one number (e.g. “1 Chapter Name”) 
and can include as many sub-sections as you like (e.g. “1.2.3.4.5-6 Sub-section Name”). 

You can use any character except space to separate the numbers, so #.#-# or #-#/# are both acceptable 
whereas “1 2 Section Name” would be treated as a guideline called “2 Section Name” in chapter 1. 

It is recommended (but not required) that you use the same text for the HTML file's TITLE element as 
used for the first header. 

It is often desirable to structure a guideline set. A category header file can be created to insert an 
appropriate header into the guideline index. A category header file is created using the same template 
as above, except that the following text should be inserted on the line immediately after the <H1> 
header and no guideline text should be entered (any guideline text in this file will be ignored): 

<!--CREATECATEGORY--> 
 
Guideline text below the H1 header in the body of the HTML document can contain most legal HTML 
elements, including tables, images, and additional headers, but no <A> tag hyperlinks should be used in 
the document body (see warning below). 

Important: Your HTML code body must not contain any (<A> tag) hyperlinks to other 
documents (local or on the Internet) or locations in the same document.  

The body (<BODY>…</BODY>) of the HTML file should not depend on additional files, with the 
exception of image files referenced using the image tag (<IMG>), so embedding movies, audio, 
applets, or plug-ins in HTML pages is not recommended. 

Make sure that any images (or other files referenced in the header of the document that are required for 
the document to display correctly) used by the HTML files are also stored in the guideline set directory 
together with the HTML files, and that relative (not absolute) file path references are used for such 
files. It is permissible to organise non-HTML files in sub-directories for better organisation of the 
guideline set contents. For example, images used by the guideline file ‘guidelinesetname_1-2.html’ can 
be stored in a directory called ‘guidelinesetname_1-2’ in the guideline set directory. 

File and directory names used by the HTML files and any associated files and directories can contain 
only the characters A-Z, a-z, 0-9, ‘.’ (full stop/period),‘-‘ (minus), or ‘_’ (underscore). The use of ‘.’ in 
filenames is not generally recommended except before the file extension. e.g. ‘glsetname_1-2.html’ is 
preferable to ‘glsetname_1.2.html’, although both are legal on most operating systems. Using a ‘.’ in a 
directory name is similarly not recommended. 

See also: 

Installing a guideline set 
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3.1.2 The Guideline Procedures 
Guideline procedures are usually entered using the Guideline Tool, in which case the Guideline Tool 
handles the creation and modification of procedure files transparently. 

Guideline procedures are text files with the same file name as their associated HTML guidelines, but 
with text file extensions instead of HTML file extensions. 

When creating a new guideline set for installation on the server you do not need to supply procedure 
text files unless you do not want to enter the procedures using the Guideline Tool. 

If you export a guideline set using the Guideline Tool then the procedure text files are included in the 
exported guideline set and will be included if you reinstall the set. 

To manually add a guideline procedure file to a guideline set prior to installation: 

1. Create a text file with the same name as the HTML file with the associated guideline, but 
replacing the HTML file extension (e.g. “.html” or “.htm”) with “.txt” 
e.g. if you have a guideline called ife_design_5_3.html then you should create a text file called 
ife_design_5_3.txt 

2. Enter the text of the procedure into the new text file 

3. Save the file 

To modify the procedure files of an exported guideline set prior to reinstallation, simply locate and edit 
the text files associated by name with their HTML guideline files in the guideline set directory. 

See also: 

Editing a guideline procedure 

Exporting an installed guideline set to the local file system 

Installing a guideline set 
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4 Managing Guideline Sets 
This chapter describes how to use the Guideline Tool to manage guideline sets. 

4.1 Installing a guideline set 
The Guideline Tool is used to install guideline sets prepared following the conventions described in 
Creating a New Guideline Set. Pre-packaged guideline sets are supplied with HVRC CREATE and are 
distributed as ZIP archives, where a single ZIP archive file contains a whole set of guideline data. 

If you attempt to install a guideline set with the same name as an existing set then you will be asked to 
confirm that you really want to replace the existing set, however great care should be taken if replacing 
a set that is used in any project as you may invalidate work done in the project. You will be asked to 
confirm a second time if the guideline set is used in existing projects. 

Design guidelines are for use in the Layout Tool, as a reference for the designer, whereas review 
guidelines are used in the Verification Tool to support the formal assessment of a design. Only review 
guidelines have status labels associated. 

How to install a new guideline set: 

1. Select File > New… 

2. A file dialog will appear 

3. Select a zip archive containing a pre-packaged directory set or a directory containing your 
guideline set data  

4. Click on Select to continue to the next step of the installation process or Cancel to abort  

5. A guideline set information dialog appears 

6. If you selected a zip archive containing a guideline set then the information shown is that 
which was found in the archive, however you can now modify the name or, for a review set, 
the names of the status labels before installing the set.  If your data was in a directory then you 
should ensure that the Design or Review guideline set type is correct and input guideline set 
information as appropriate before confirming 

7. If the guideline set information is confirmed then the set will be installed, otherwise no 
changes will be made to the guideline set database 

See also: 

Creating a New Guideline Set 

Modifying the contents of a guideline set 

4.2 Accessing an installed guideline set 
The guideline set selection dialog is used to access an installed guideline set. 

After selecting a guideline set the index of the set will be shown in the guideline panel. 

To access an installed guideline set: 

1. Select File > Open… 

2. Select the guideline set that you wish to access from the drop-down menu: 

 
3. Click on OK to open the guideline set or Cancel to abort 
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See also: 

 Browsing a guideline set 

4.3 Browsing a guideline set 
Once a guideline set has been opened (see Accessing an installed guideline set), you can browse the 
guidelines and associated procedures contained in it. 

When a guideline set is initially opened, the index page is shown: 

 
Note that the Reload and Info buttons (furthest to the right in the toolbar) are the only buttons that are 
enabled. The underlined guideline names are hyperlinks. 

Clicking on a hyperlink takes you directly to the linked guideline, after which the Previous and Next 
buttons in the tool bar can be used to browse individual guidelines. To go back to the index page, you 
can click on the Home button. 
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An individual guideline looks likes this: 

 
The Home, Previous, Next, and Reload buttons are all enabled. The guideline text and images are 
displayed in the guideline panel and an empty procedure associated with the guideline is shown in the 
Procedure Panel underneath it. 

To go to an individual guideline from the index page: 

1. Click on the hyperlink representing the guideline that you want to access 

To go to the index page from an individual guideline: 

1. Click on the Home button 

To go to the previous or next guideline from an individual guideline: 

1. Click on either the Previous or Next buttons 

To reload an index page or individual guideline with associate procedure: 

1. Click on the Reload button  

To view information about the currently loaded guideline set: 

1. Click on the Info button  

See also: 

Accessing an installed guideline set 

Editing a guideline procedure 
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4.4 Editing a guideline procedure 
In most cases, the procedure for testing a layout against a guideline is obvious, but in some cases it may 
be necessary to provide supplementary instructions for the users of guidelines (e.g. the users of the 
Layout and Verification Tools). This can be viewed as a kind of “on-line help” for the user. 

For each guideline, an associated procedure can be entered, edited and stored. Clicking on the right 
mouse button in the text panel reveals a pop-up menu that can be used to edit the text. The keyboard 
shortcuts in the Edit menu for Undo, Cut, Copy and Paste (see Edit Menu) can also be used. 

To edit a guideline procedure: 

1. Go to the guideline that you wish to edit the procedure of 

2. The associated procedure is displayed in the procedure panel below the guideline panel.  If a 
procedure has been entered previously then you will see the text of the procedure in the panel, 
otherwise, the text pane will be empty. 

3. Enter the text of the procedure directly into the text pane of the Procedure Panel. You can 
modify any existing text as you see fit.  

4. The text is automatically stored when you leave the guideline. Use the pop-up menu (right 
mouse button) to access a menu with undo if you wish to revert change. 

See also: 

Accessing an installed guideline set 

Browsing a guideline set 

The Guideline Procedures 
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4.5 Deleting a guideline set 
Guideline sets that are not used by any project can be deleted. 

To delete a guideline set: 

1. Open the guideline set that you wish to delete (File > Open…) 

2. Select File > Delete 

3. Confirm deletion by clicking on Yes or abort by clicking on No in the confirmation dialog that 
appears. 

 
See also: 

Accessing an installed guideline set 

4.6 Exporting an installed guideline set to the local file 
system 

You can extract a guideline set from the server. The extracted data is saved in a user-specified directory 
and can be read using any application that can import HTML files (e.g. a Web browser or a word 
processing package). 

This enables you to update the data and either install the updated the set or replace individually 
modified guidelines. 

To export an installed guideline set to the local file system: 

1. Open the guideline set that you wish to export (File > Open…) 

2. Select File > Export… 

3. Choose a directory into which you wish to save the exported directory set  

 
Note that the exported guideline set will appear in the directory that you select as a new directory with 
the directory name that was supplied when it was installed (see The Guideline Set File Format). Thus, 
if you select a local directory called “Example_Guideline_Set” then a new directory called, for 
example, “ife_guidelines” will appear in the directory “Example_Guideline_Set” if the exported 
guideline set was originally installed in a directory called “ife_guidelines”. If a directory called 
“ife_guidelines” already exists in the selected directory then it will be overwritten. 
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See also: 

Accessing an installed guideline set 

Modifying the contents of a guideline set 

4.7 Modifying the contents of a guideline set 
Warning: Modifying installed guideline sets is not recommended. 

If a guideline set has been installed and is used in existing projects then you should only modify the 
contents of a guideline set if the corrections are minor (e.g. to fix a spelling error) so as not to 
invalidate any work already done based on the guideline or guideline set. 

For more comprehensive updates of a guideline set, it is recommended that the modified guideline set 
be installed under a new name by modifying the directory name (as for step 4 below) so that it is not 
the same as the original and, also change full name in info.txt so that it is possible for users to 
distinguish between the two sets. In that case, the new guideline set will only be available for new 
projects created after the new guideline has been installed and will not therefore have any affect on 
existing projects. 

To describe task: 

1. Select File > Open… and the select the guideline set that you wish to modify in the guideline 
set selection dialog that appears 

2. Select File > Export… and save the guideline set to a local directory 

3. Make changes to the guideline set files taking care not to make changes that could affect any 
existing projects that use the guideline set (e.g. changing its type or the order of review status 
labels) 

4. Rename the exported directory (usually named “design” or “review”) that contains the 
guideline set HTML files to give it the same name as the enclosing directory that was exported 
(e.g. “ife_guidelines1”) 

5. Select File > New and install the guideline set as if it were new (the original on the server will 
be replaced) 

See also: 

Exporting an installed guideline set to the local file system 

Installing a guideline set 
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4.8 Printing the current guideline data 
The Guideline Tool supports printing of the current guideline and procedure or guideline set index to 
any printer configured on your computer. 

Always set the orientation of the paper using the page setup dialog.  

Note that the dialog windows shown by the Guideline Tool will depends on the operating systems you 
are using, so the actual dialog window on a computer running Linux will differ from the equivalent 
dialog window on a computer running Windows 2000 or XP. 

To set up the page: 

1. Select File > Page Setup… 

2. Choose the required settings and confirm or reject your changes 

To print the current guideline and procedure or index: 

1. Select File > Print… 

2. Choose the required settings 

3. To ensure correct results, do not select orientation using the print dialog 
(Use File > Page Setup… instead) 

4. Continue (typically, click on OK) or abort (typically, click on Cancel) 
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5 Menus 

5.1 File Menu 

 
The File menu provides functionality for managing and printing guideline sets. All of the available 
items in the File menu have keyboard shortcuts (shown to the right of the menu items above). 

New… is used to add a new guideline set to the installer (See Installing a 
guideline set). 

Open… is used to access installed guideline sets (See Accessing an 
installed guideline set). 

Export… is used to export a copy of the currently loaded guideline set to the 
local file system (See Exporting an installed guideline set to the 
local file system). 

Delete is used to delete the currently loaded guideline set (See Deleting a 
guideline set). 

Page Setup… is used to set the page orientation and paper size (See Printing the 
current guideline data). 

Print… is used to print the currently displayed guideline (or index) and 
procedure (See Printing the current guideline data). 

Exit is used to quit the Guideline Tool. If you choose this menu item 
then you will be requested to confirm that you want to quit. 
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5.2 Edit Menu 

 
The Edit menu provides functionality for editing text as well as access to functionality for changing 
your password and preferences. Most of the available items in the Edit menu have keyboard shortcuts 
(shown to the right of the menu items above). 

Undo is not generally available directly from the Edit menu, however 
the shortcut (control-z) can be used when editing text in the 
procedure panel. 

Cut is used to cut any selected text to the system clipboard. 

Copy is used to copy any selected text to the system clipboard. 

Paste is used to paste the text contents of the system clipboard. 

Set Password… is used to change your password (See Changing Your Password). 

Preferences… is used to open the Preferences Window (See Preferences 
Window for usage information). 

5.3 Guideline Menu 

 
The Guideline menu provides functionality for navigating within guideline sets as well as forcing a 
reload of the currently displayed data. All of the available items in the Guideline menu have keyboard 
shortcuts (shown to the right of the menu items above). See Browsing a guideline set for details. 

Home is used to go the guideline set index page. 

Previous is used to go the previous guideline in a set. This item is only 
available if you are not viewing the index page and the current 
guideline is not the first guideline in the set. 

Next is used to go the next guideline in a set. This item is only available 
if you are not viewing the index page and the current guideline is 
not the last guideline in the set. 

Reload is used to force the Guideline Tool to reload the guideline data for 
the current guideline. It can be useful if a guideline failed to load 
successfully. Serious problems loading and displaying guidelines 
may be the result of errors in the HTML code in which case you 
should consider exporting the guideline set and checking the 
HTML code for errors. 
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5.4 Help Menu 

 
The Help menu provides access to copyright information about this software and to online help. 

About HVRC CREATE… is used to display copyright information about the CREATE tool 
suite. 

About Guideline Tool… is used to display technical information about this tool. 

Check for Update is used to check if the latest version of this tool is being used. 

Guideline Tool Help is used to access the online user guide for the Guideline Tool. 
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6 Configuration  

6.1 The Preferences Window 
 

 
The Preferences Window 

The first time you use one of the CREATE tools you will normally be presented with a wizard that 
assists you in setting the configuration options that you need to get started using HVRC CREATE. 
Subsequently, you can adjust your personal configuration via the options in the Preferences Window. 

The Preferences Window can be accessed from the main menu bar's Edit > Preferences… menu item. 
The keyboard shortcut to open the Preferences Window is ctrl-comma (or command-comma). 

Changes to preferences are global and therefore affect all CREATE tools that you use, however they 
are also personal and will not affect any other users of CREATE that share a computer as long as you 
are not sharing a computer user account. 

There are four sets of preferences in the Preferences Window, the most important of which is the 
“General” set, which is used to enter the address of the CREATE server that will be used. The 
individual sets and the options they contain are described in the subsections below. 

The Preferences Window has three buttons: 

• OK is used to update the preferences and close the window 

• Apply is used to set the update the preferences but not close the window 

• Cancel is used to dismiss the window without making any changes 

Clicking Apply followed by Cancel is equivalent to clicking OK. 

A configuration file containing your preferences is created in your home directory and will be applied 
the next time you run a CREATE tool. 

Closing the window by clicking on the close box (top right of the window) is equivalent to clicking on 
the Cancel button. Hitting the escape key is also equivalent to clicking on the Cancel button. 
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6.1.1 General Preferences 

 
The General Preferences section of the Preferences Window with server create.ife.no set 

The General Preferences section of the Preference Window is used to set the CREATE server URL, to 
specify the appearance of the CREATE tools, and to toggle caching to local disk of 3D models in the 
Model Bank. 

Important information about changing the server URL: 

• In general, it is recommended that you change the server URL setting either immediately after 
starting up a tool or immediately after saving any unfinished work to the current server, to 
avoid any risk of data loss before switching to a different server. 

• If you are behind a firewall and are using a proxy server to access the internet then you should 
also refer to Proxy Preferences – section 6.1.3 if you need to access a CREATE server that is 
not on your local network (e.g. to access the demonstration server on create.ife.no). 

If some features of the tool are not working correctly and the software is reporting server access 
errors then the reason may be that the server is incorrectly configured, in which case you should 
report this to your CREATE server administrator. 

The General options are described below: 

CREATE Server URL The server URL is the Web address of the CREATE server where 
all CREATE system and project data is stored. It is shared by all 
of the tools. If you attempt to modify the server URL then you 
will be asked to confirm the change. 

Changing the server URL to a non-existent host will render the 
tools unusable until a valid host URL has been entered. Changing 
the server URL before saving any work that has been done during 
the current work session will result in any unsaved data being lost. 

 Important: See notes above regarding changing the URL. 

Auto-login If you are logged onto a CREATE Server then this option will be 
enabled. Once enabled, you can select it to indicate that you 
would like the tools to remember your user name and password 
for the current server and use it to automatically log on to the 
server at any time where you would otherwise be prompted to 
enter user name and password. The password is stored in 
encrypted form in the create preferences file for security reasons. 
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Appearance The default Appearance is that of the host operating system. The 
host operating system appearance normally gives the CREATE 
Tools a look similar to that of other applications on your 
computer. The cross-platform setting provides a consistent user 
interface look and feel regardless of whether you are running the 
software on Windows, Linux, Mac OS X, or some other operating 
system. 

Docked Catalogue and Editors This option (currently only used by the Layout Tool) causes the 
Model Bank Catalogue and Editors side panels to be detached 
from the main application window. When detached, the panels 
appear as floating windows that can be moved freely around your 
computer screen. This is especially useful if you have multiple 
displays attached to your computer as you can then move the 
Catalogue and Editor panels to a different display, giving more 
space to work with the 3D view on your main display.  

 This option takes effect the next time the Layout Tool is started. 

Language The text of the HVRC CREATE tools user interfaces can be 
displayed in English, US English, French or Norwegian. By 
default this option is set to system default, enabling the software 
to select the language automatically depending on your operating 
system language settings. However, you can also select the 
language specifically. For example, this can be useful if you are 
working on an international project where English is the project 
language, but your personal computer is otherwise configured to 
use a non-English language.  

Metric distances If you want distances to be displayed using U.S. measurement 
units then you can turn this option off, otherwise distances are 
displayed in metric units. 

Cache If Model Bank caching is enabled then frequently used models 
load faster as copies of the models are read from the local hard 
drive, rather than transferred over the network, each time the 
model is loaded. The effect of this depends on the speed of the 
network and the size of the models. The greatest benefit of using 
caching is achieved when frequently accessing models over a 
slow connection to a server. Since the model cache is stored on 
the local disk, it is important that there is sufficient disk space (a 
few megabytes is usually sufficient) and that you are not using an 
insecure computer and an insecure user account to access the 
models (from which the cached models could be copied). 

 Pressing “Empty Cache” deletes the data in your local cache, 
freeing up disk space. 

 Caveat: If you are using a computer where your home directory is 
on a server (rather than stored locally on the computer that you are 
using) then turning on the cache may actually slow down the 
loading of Model Bank data, if the network connection to the 
CREATE Server is not significantly slower than the connection to 
your home directory. We do not recommend turning on the 
cache if your home directory is on a network server. 
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6.1.2 3D View Preferences 

 
The 3D View Preferences section of the Preferences Window 

The 3D View Preferences are only applicable to the tools that display 3D graphics, and offer control 
over the way in which the 3D graphics are rendered. These options generally have no effect until the 
application has been restarted as the affect the way in which the 3D view is initialised. 

The 3D View options are described below. 

Enable texture mip-mapping Enable generation of multi-resolution textures when textured 
models are loaded. This option improves the appearance and 
performance of textures, however some older graphics cards may 
not support this feature and the loading of textured models may be 
significantly slower if this option is enabled.  

Enable implicit anti-aliasing Allow the display driver to control full-screen anti-aliasing 
settings. If you have a graphics card with support for anti-aliased 
rendering then this option enables will cause the tool to 
acknowledge your anti-aliasing set-up. This option can greatly 
improve the visual appearance of the 3D view but there may be a 
performance impact, and some older graphics cards may not 
support this feature. 

Enable stereoscopic rendering Enable initialisation of 3D views in stereo mode. This option will 
only have an effect if you have a graphics card that supports 
active stereoscopic rendering. Unless you are actually using 
stereoscopic hardware, you should not enable this option as 
stereoscopic rendering will decrease the overall performance of 
the 3D view as it requires more effort of the graphics card. 
Default off. 

Enable render lock Controls rendering execution. Try changing this if you have driver 
problems. In general, you should leave it off. This option is 
offered only because it can resolve graphics driver problems in 
some special cases. Default off. 

Optimize for space Optimize 3D geometry to use less memory at the expense of 
slower performance. Disable this if you need to squeeze out a 
little more performance. In most cases the difference is 
unperceivable so we recommend leaving it on. Default on. 
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Texture Quality If your layouts contain many high-resolution image surface 
parametric objects then you may reach a point where the 
rendering performance degrades significantly as you run out of 
memory on the GPU. You can improve performance by reducing 
the maximum quality used for texture rendering. Note that the 
images themselves are always stored at high resolution within 
CREATE so this only affects their appearance (both in the 3D 
view and when exporting 2D images). You can safely work with 
this set to Low if you want to maximise performance while 
working on a design, and increase it when you are ready to output 
high quality images. Default is High. 

6.1.3 Proxy Preferences 

 
The Proxy Preferences section of the Preferences Window 

If you are behind a firewall and are using a web proxy server to access the Internet then you will need 
to configure the CREATE tools to use a proxy server if you wish to access a CREATE server that is not 
on your local network (e.g. to access the demonstration server on create.ife.no). 

To enable proxy support, check the Use HTTP Proxy Server option, enter the server address (without 
entering http:// in front of it and without any trailing slashes) in the Proxy Server field and the port 
number in the Port field. If you leave the port field blank then the default port (80) will be used. 

To disable proxy support, uncheck the Use HTTP Proxy Server option. 

If necessary, select Proxy Server Requires Authentication and enter your network (i.e. not CREATE) 
user name and password. 

Note that changing these items while in the middle of doing work with a CREATE tool is not 
recommended. Change these settings immediately after starting up a tool or after saving any 
unfinished work to avoid any risk of data loss. 
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Example of a filled-in Proxy Preferences section of the Preferences Window 

6.1.4 Expert Preferences 

 
The Expert Preferences section of the Preferences Window 

The Expert preferences provide access to additional options, described below. 

Automatic version check Turn off the automatic daily checking for a new release of the 
HVRC CREATE Tools. If you turn this off then you will not be 
informed automatically of new updates, but can still check for 
updates manually via the Help-menu (Help > Check for 
Update). Default on. 

Restrict report image dimensions In versions of CREATE up to 4.0, snapshots of the 3D view 
added to reports in the Verification Tool were exact duplicates 
of the image in the 3D view, with the same resolution and 
aspect. From CREATE 4.0, the snapshots are taken with a 
consistent aspect to always fit neatly into a report page, with 
landscape or portrait format depending on the current 3D view 
aspect. Default on. 

Use larger font for review comments When using a non-Latin character set for entering review 
comments or procedures, some users may find the text easier to 
read if a large font is used than the system default size. Default 
off. 

Watermark exported 2D graphics If this option is enabled then “HVRC CREATE” and the name 
of the licensee is inserted at the top left on exported images. In 
the demo version of CREATE then this cannot be turned off. 
Default off. 
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Detailed technical log in About box Select to enable detailed technical logging of system behaviour 
in the log in the About box. This is useful for troubleshooting if 
you experience technical issues with the software, and you need 
to contact CREATE support for assistance. Enabling this option 
has a small negative effect on the system performance. Default 
off. 

Enable optional 3D loaders Select to enable 3D loaders, to support importing 3D models in 
glTF, LWO, OBJ, PLY, and SCENE (Ogre3D) formats. These 
are described as optional as they are not guaranteed to load all 
files in those formats correctly but are useful as they can load 
most files in those formats. Saving your work before attempting 
to import a model for the first time in one of these formats is 
recommend. Default on. 

Clip plane ratio If you experience tearing effects in the 3D view then this may be 
because your graphics processor is unable to draw surfaces that 
are close together with sufficient accuracy. Reducing this 
number may minimise that effect, although at the cost of not 
being able to view near surfaces as closely. Similarly, if you are 
not having any problems with tearing then you might want to try 
increasing this number in order to be able to move even closer to 
surfaces before they disappear from view. A ratio of 1000 is a 
good choice for most modern discrete graphics cards. Default is 
500. 

Ignore project model filter if standalone server If you are using a standalone CREATE Server (as 
opposed to a networked server), on the same machine 
that you are running the CREATE Tools on, then you 
can opt to ignore any project level model filters set for 
the Model Bank. This makes all categories and models 
visible in the Layout Tool regardless of any filters that 
have been specified using the Project Management 
Tool. If you are the only user of the server then this can 
be useful as you will see all new categories added to the 
Model Bank without having to update the project 
context using the Project Management Tool. Default is 
off. 

Disable snapshot generation Enable a partial workaround to enable CREATE 3D tools to run 
on hardware that does not fully support the 3D hardware 
minimum requirements. Default is off. 
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