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HVRC CREATE: Layout Tool User Guide. 

This document contains information proprietary to IFE Digital Systems. Information contained herein 
may not be copied, reproduced, disclosed or used without the express written permission of IFE Digital 
Systems. This document may be copied for use internally at the licensed site only. 

IFE Digital Systems makes no warranties with respect to the contents or use of this document, 
including but not limited to the implied warranties of merchantability and fitness for a particular 
purpose. 

The information contained in this document is subject to change without notice. 

Java™ is a trademark of Oracle Corp. 
OpenGL® is a registered trademark of Hewlett Packard Enterprise. 
Apple®, MacOS X® and macOS® are registered trademarks of Apple, Inc. 
Microsoft® and Windows® are registered trademarks of Microsoft Corp. 

All other trademarks used within this document are the properties of their respective trademark holders.  

Comments about this document are welcome and may be sent to <create-support@ife.no>. 
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1 Overview 

1.1 HVRC CREATE 
HVRC CREATE 4 is the fourth generation of the CREATE tool suite, and builds on the technical 
platform and functionality established during the implementation of earlier versions of the software, as 
well as valuable feedback gained from usability evaluations and research work by the development 
team. 

The CREATE control room design tools combine advanced interactive 3D technology with server-
based user, project, and file management, providing an integrated package that supports and traces the 
various stages of a human-centred design process. 

The software has been designed to support a flexible, iterative, design methodology, where a control 
room design is refined and tested many times before a final design is reached. This contrasts with 
traditional control room design methods where the design process only goes through one or two human 
factors review iterations, and where it is necessary to build a costly physical control room mock-up. 
Design iterations are tracked by the system.  

When these virtual reality tools are used, it is not necessary to wait until a physical mock-up has been 
constructed before commencing design verification and validation against human factors guidelines, so 
greater emphasis can be placed on finding an optimal design solution for safe and efficient control 
room operation. Users with a variety of technical skills can operate the software, so control room 
operators, designers, human factors specialists, engineers and managers can all participate to some 
degree in the design process. 

CREATE provides features designed to support and enhance communication between the various 
interest groups involved in a design project. Support for communication between the layout designers 
and reviewers is integrated into the system, while it is possible to extract electronic documents such as 
models, designs and reports for distribution to other interested parties. 

The CREATE tools support the management of a reusable database of 3D objects, the interactive 
construction of control room layouts, and the validation of control room layouts against guidelines. 

The CREATE tools are based on cross-platform Internet and Java technology and open standards such 
as ISO VRML, DAE/COLLADA, XML, and HTML. 

1.2 Layout Tool 
The Layout Tool is used to positions objects in a virtual room. Models are select from a Model Bank 
catalogue and are positioned interactively in the layout by dragging and dropping them into the 3D 
scene. The Layout Tools also provides functionality for modelling rooms and for creating parametric 
objects directly in the 3D view. 

Design guidelines specified by the project manager can be referred to while working. The Layout Tool 
provides 3D tools that enable the user to evaluate the layout as it is being composed. These tools 
include a set of measurement tools and a set of manikin tools. 

Control room layouts are saved to the CREATE Server. When a layout is ready for verification, it is 
"published". Reviewers using the Verification Tool can access and view published layouts. The user 
can access verification reports written by reviewers for layouts that have been published using the 
Layout Tool. 

In addition to saving and publishing layouts to the CREATE Server, the Layout Tool can also be used 
to export layouts in ISO VRML 97 or DAE/COLLADA formats to the local file system, enabling the 
user to transfer 3D data to other packages. Complete layouts with Model Bank meta-data can also be 
exported to the local file system as a Layout Package enabling transfer of layouts between Servers and 
projects. 
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2 Getting Started 

2.1 System Requirements 
The minimum requirements for the HVRC CREATE Tools are: 

• Intel Core i5 (8th gen) x64 processor or similar 
• 8GB RAM 
• 64-bit Microsoft Windows 10 or Apple macOS 11 
• Discrete 3D graphics accelerator with at least 2GB memory and OpenGL 3.3 driver support  
• For Microsoft Windows: 250MB free disk space for the complete tool suite. 

For macOS: 1GB. 
• A three-button mouse (or a two-button mouse with scroll-wheel "button") 

Use the option or alt-key on your keyboard in combination with the left mouse button to simulate the 
middle mouse button if you do not have three mouse buttons. 

2.2 Installation 
Important: See System Requirements above before installing. 

On Windows, the installer called “CREATE Tools Installer” installs the full set of tools, including the 
Layout Tool. Double-click on the installer and follow the instructions. 

On macOS, simply drag the Layout Tool (or the whole folder enclosing it) from the installation 

2.3 Starting the Layout Tool 
To run the Layout Tool, open the CREATE directory, which was created when you installed the tools, 
and double-click on the Layout Tool icon. 

Depending on what options you selected when running the installer, you may also be able to start the 
tool by double clicking on an icon on the Microsoft Windows desktop or by selecting it from the Start 
menu (in the "HVRC CREATE" group). 

Important: The first time you run a CREATE tool, a wizard will appear that guides you through 
configuring your connection to a CREATE Server. After the wizard has completed, you can change 
your settings via the Preferences Window (see The Preferences Window). Ask your system 
administrator or project manager for assistance if you do not know what to enter. 

The information above assumes that you are using Microsoft Windows. On other platforms, the 
installation follows the platform conventions to provide easy access to the installed software. 

2.4 Support 
Please send questions, bug reports, or requests for new features to: create-support@ife.no 

When submitting bug reports, please include the following information: 

• A description of the result and how it differed from what you expected 
• The conditions or circumstances under which the problem occurred 
• Any other information that could be useful to isolate the problem, including the version of 

CREATE you are using, the version of the operating system of your computer, and the type of 
graphics card you are using. An overview of useful technical information is displayed in the 
tool’s About dialog, located in the Help menu, and can be copied into an email or saved to 
disk in a text file. 

mailto:create-support@ife.no
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2.5 User Identification 
Before you can use the Layout Tool to do any work, the server administrator or your project manager 
must have assigned a login name and password to you. If you do not have a login name and password 
then contact the server administrator or your project manager for assistance. 

When the Layout Tool starts up and needs to retrieve data from the server, it will usually request that 
you enter your login name and password. If this does not occur, then you should check that the 
CREATE server address has been correctly set (see The Preferences Window). If the server address is 
correct, then you should verify with your system administrator or project manager that the host is 
currently operating and accessible on your network. 

You will not be able to use the Layout Tool to do anything other than access items in the Help menu 
and specify the server address in the Preferences Window if you are not logged on to a CREATE 
server. 

Important: If you enter an incorrect username and/or password then you may have to restart the 
Layout Tool in order to log onto the server. After a successful login, you can enable an auto-login 
feature via the Preferences Window so that you do not need to enter your username and password each 
time. 

2.6 Changing Your Password 
You can change your password via the Edit > Set Password… menu item. For security reasons, you 
should change your password regularly and use a password that is difficult for other people to guess. 

You must be logged on to a CREATE server in order to change your password. 

To change your password: 

1. Select Edit > Set Password… 

2. The Change Password dialog will appear: 

 
The Change Password Dialog 

3. Enter a new password into the Password field 

4. Enter the new password again in the Confirm Password field 

5. Click on OK to commit the change or Cancel to abort 



Release 4.2 (rev: 03/01/2024) 10 Layout Tool User Guide 

2.7 Overview of the User Interface 
 

 
The Layout Tool User Interface 

 

The primary user interface of the Layout Tool consists of a large window with the main features of the 
Tool easily accessible.  

At the top of the window is the Layout Tools main menu bar (see Menus). 

To the left is the Model Bank catalogue. The upper part shows an overview of the categories of objects 
accessible for the current project. The lower panel shows icons representing the objects in the currently 
selected category. 

The panel in the middle consists of the 3D scene in which layouts are displayed and two toolbars. The 
upper toolbar holds mainly toolsets for working with layouts while the lower toolbar provides support 
for navigation in the 3D scene. 

Pre-modelled objects are added to a scene by dragging icons representing models from the Model Bank 
catalogue into the 3D scene. It is also possible to create new objects and shapes within the Layout Tool 
by adding objects of various types to the scene from the Objects menu. These can include geometric 
primitives, such as boxes and spheres, or more complex objects defined by parameters that can be 
configured, such as staircases. Walls, with openings for doors or windows can be added as parametric 
objects too. Wall groups are managed sets of wall objects that can also have a floor and ceiling (i.e. 
rooms) that can also be added to the scene as parametric object. 

The upper right side of the user interface contains the Object Overview, a hierarchical overview of the 
objects currently loaded into the scene. The contents of the Object Overview are editable and you can 
manipulate the objects in the scene tree via a popup-menu. Below it is the Selected Object panel. Here 
the position and rotation of the currently selected object is displayed. It can be used to accurately set an 
object’s position and orientation by entering values. It also supports setting object-level snap intervals 
for the object’s positions and location, and locking of the object’s position and rotation. The Attributes 
tab provides access to the parameters of parametric objects, created within the Layout Tool itself. The 
Tags tab provides access to the tagging functionality that enables association of meta-data with the 
selected object. 



Release 4.2 (rev: 03/01/2024) 11 Layout Tool User Guide 

3 Managing Layouts 
Every designer assigned to a project can create new layouts, modify unpublished layouts, publish 
layouts and save layouts under new names. Layouts are published (frozen) when they are ready to be 
formally reviewed by a reviewer using the Verification Tool. 

3.1 Working with Layouts 
You can create new layouts using the Layout Tool, and publish layouts when they are ready to be 
reviewed, for any project to which you have been assigned permissions to assume a designer role by 
the project manager. You can communicate with reviewers by adding comments to the layout you are 
working on or viewing. 

You will usually work on a layout until you consider it to be completed, and then publish it for review. 
After it has been reviewed, you can read the reviewer’s report and comments and create a new version 
of the layout that takes the results of the review into account. This iterative process continues until the 
project manager decides that the goals of the project have been met. During this process, you can 
communicate with reviewers, and other designers assigned to the project, by adding notes to the layout 
you are working on (or viewing), or by sending messages via the built-in messaging system. 

You can use all Model Bank models that the project manager has made available to a project, and can 
also browse design guidelines, if any have been assigned to the project. 

You work with a design by dragging models from a view of the Model Bank into a 3D representation 
of the room layout. These objects can be arranged as required in the layout and the result can then be 
saved. The Layout Tool provides a variety of powerful functions to support the easy arrangement of 
objects in a room and to informally verify the results. 

The Layout Tool also offers some basic modelling features, enabling you to model rooms and other 
basic objects from within the Layout Tool itself. The rooms in which you place your objects can be 
pre-built in a 3D modelling or CAD tool and added to your layout via the Model Bank, or made in the 
Layout Tool. Even if you use a pre-built room, you can add architectural elements such as additional 
walls from within the Layout Tool. 

Layout Tool can associate meta data with the objects placed in the Layout. This meta data is used by 
the Verification Tool to perform automated testing to verify the room in accordance with guidelines. 
The association of meta data is done by assigning Tags to the 3D objects, where the tags describe 
certain properties and aspects of the objects, as well as their context in relation to the room. 

To verify the results, you have access to the same testing tools that the reviewer uses in order to 
informally check distances, sight lines, and other details related to the layout. This would typically be 
done with reference to the design guidelines, and can be done at any time.  

You can export a 2D plan view of any layout as an image or the entire 3D layout in VRML format. 
These can be distributed to other people who are not CREATE users that have an interest in the design. 

There may be several designers working on alternative layouts simultaneously or modifying the same 
layout at different times within the context of a project. The layouts, therefore, belong to the project 
environment and not to the individual designers. This means that any designer assigned to a project can 
modify any unpublished layout belonging to the project.  

You can communicate with other designers, reviewers, and the project manager using a messaging 
system built into the Layout Tool. 

3.2 Creating a New Layout 
In order to work with 3D models using the Layout Tool, you need to create a new layout. There may be 
several designers working on alternative layouts simultaneously or modifying the same layout at 
different times within the context of a project. The layouts, therefore, belong to the project environment 
and not to the individual designers. This means that any designer assigned to a project can modify any 
unpublished layout belonging to the project.  

To create a New Layout: 

1. Select File > New… or use the shortcut keys command-N 
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2. If a login window appears, enter your user name and password for accessing the CREATE 
server. If you are successfully logged in then the Project Browser will appear: 

 
    Project Browser with a project selected. 

3. Using the tree on the left side of the Project Browser, select the project for which you wish to 
create a new layout. Information about projects can be viewed by selecting them, and appears 
on the right side of the Project Browser. Only projects that you are permitted to access are 
show, so if no projects are available to you then you the list may be empty. 

4. Press OK to create a new layout and start working, or Cancel to close the Project Browser 
without creating a new layout. 

5. If you press OK then a Room Wizard will appear, enabling you to generate a room or start 
working with an empty environment. 

Please note that all existing work will be lost if it is not saved before a new layout is created. 

3.3 Opening an Existing Layout 
Opening an existing layout is done in much the same way as creating a new context, except that when 
you open the Project Browser and browse the project tree, it is possible to select individual layouts 
within projects. 

To open an existing layout: 

1. Select File > Open… or use the shortcut keys command-O 

2. If a login window appears, enter your user name and password for accessing the CREATE 
server. If you are successfully logged in then the Project Browser will appear: 
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Project Browser with a layout selected. 

3. Using the tree on the left side of the Project Browser, select the layout that you wish to open. 
You may need to click on one of the handles next to the project name to see all of the layouts 
associated with a project, in order to find the layout that you intend to work with. Information 
about projects or layouts can be viewed by selecting them, and appears on the right side of the 
Project Browser. 

4. Press OK to open the layout and start working, or Cancel to close the Project Browser without 
opening a layout. The Revision… option lets you choose which version of the layout to open. 
This will be covered in more detail later, see Accessing earlier revisions of a layout. 

If the layout is currently opened by another user, it is marked as locked and you will not be able to save 
new revisions for this layout (see Locking). 

Note that if you attempt to open the project itself (as you would do to create a new layout via File > 
New), then a new layout is created. 

Please note that all existing work will be lost if it is not saved before a new layout is created. 

3.4 Viewing information about a project or layout 
You can view basic information about projects and layouts that you have access to using the Project 
Browser as described in Opening an existing Layout. Select the item you want to view information 
about, but press Cancel to dismiss the Project Browser rather than OK to open a different layout or 
create a new one. The information provided includes details about the name of the project, name of the 
version, who the designer is and when the design was last modified. 

For a layout that has already been opened, more detailed information is available via the Window 
menu, including who originally created the layout, who created the revision that is open, and the name 
of the layout it was based on (if the layout was created using “Save As” to save an existing layout 
under a new name). 

To view basic information about a project or layout: 

1. Open the Project Browser using File > Open… or use the shortcut keys command-O 

2. Select the project or layout you want to view information about 

3. Information, including a snapshot for layouts, appears on the right-hand side of the Project 
Browser window. 

4. Press Cancel when you have finished browsing (or OK if you want to open a selected layout 
or create a new one). 

Note that if you press on OK in the Project Browser then any unsaved work may be lost. 
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To view detailed information about a layout already opened in the Layout Tool: 

1. Select Window > Layout Info 

3.5 Viewing information about the current project 
Information about the project that the layout you are working on belongs to is available to you and can 
be viewed and saved to file. 

The information available includes the name of the project, the name of the project manager, the date 
that the project was created as well as an overview of project team members and their roles.  

To view information about the project that the layout you are reviewing belongs to: 

1. Select the Window > Project Details 

2. The Project Details window appears: 

 
Project Details 

3. Press Save… to save a copy of the details to disk in HTML format or Dismiss to close the 
window. 

3.6 Saving a layout  
Each time you save a layout, a new revision is created, making it possible to retrieve earlier versions of 
a specific layout if necessary. You do not, therefore, need to save a layout with a new name each time 
you save in order to archive previous versions of a design in progress. See Working with versions of a 
layout. 

Please note that if a layout has been published or if the layout is being edited by another user at the 
same time, then modifications can only be saved by giving the layout a new name. See Saving a layout 
with a new name. 

All content that has been added to the layout from the users local machine, such as image files or 
project models will be uploaded to the server the first time the user saves the layout (after adding the 
content to the layout). This may impact the save time, as the content will have to be sent to the server, 
which may take longer than usual depending on the file sizes and the connection speed. 

If you are working on an entirely new layout then you must save it with a new name the first time that 
it is save. 

To save a layout: 

1. Select File > Save or use the shortcut keys command-S 

3.7 Saving a layout with a new name 
Each time you save a layout, a new revision is created, making it possible to retrieve earlier versions of 
a specific layout if necessary. You do not, therefore, need to save a layout with a new name each time 
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you save in order to archive previous versions of a design in progress. See Accessing earlier revisions 
of a layout. 

However, it is often useful, or necessary, to save a modified layout with an entirely new name in order 
to distinguish it from the original. This might be because you want to work on alternative layouts rather 
than a single design, or because a layout has been published for review, in which case you must save it 
as a new alternative layout with a new name. New layouts also need to be saved with new names. 

To save a layout as a new name: 

1. Select File > Save as...  or use the shortcut keys command-shift-S 

2. A confirmation request shows to ask if you are sure. Press Yes if you are sure that you want to 
save the layout as a new version, or No to abort. 

 
Dialogue box for entering a new layout name 

3. Enter a new layout name, and press the OK button to save the layout, or Cancel to abort the 
operation. 

3.8 Accessing earlier revisions of a layout 
The CREATE server archives all revisions made to a layout each time a layout is saved. This makes it 
possible to view previous versions of a layout and trace its history. This also makes it possible for you 
to revert to an earlier revision if you make a serious mistake and want to continue working on an earlier 
version rather than continue with the current one. 

To view information about layout revisions or to open an earlier revision of a layout: 

1. Select File > Revisions... 

2. The Layout Revision Browser dialog will appear: 

 
The Layout Revision Browser 
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3. In the Revision Browser, you can view the different revisions, designer, time, date and year 
for all the versions of the current layout. 

4. To open an older layout, select one of the earlier revisions and press the Open button. If an 
earlier version is opened and subsequently modified, this it will become the latest revision of 
the layout when it is saved, unless you save it with a new name. 

5. Pressing the Close button dismisses the dialog, while pressing the Report… button generates a 
report in HTML format. 

It is also possible to open an earlier revision directly from the Project Browser. This enables you to 
load an earlier revision without first opening the newest version of the layout.  

To open an earlier revision directly from the Project Browser: 

1. Follow the instructions in Opening an Existing Layout up to the point where you selected the 
layout using the tree on the left side. 

2. Press Revision… to open the revision dialog for the layout (instead of Ok). 
3. This opens the Revision Browser. Refer to the instructions above on how to use the Revision 

Browser. 

3.9 Generating a version history report for a layout 
The Layout Revision Browser provides functionality for exporting a report containing the revision 
history of a layout. 

To generate a layout version history report: 

1. Select File > Revisions... 

2. The Layout Revision Browser dialog will appear. 

3. Press the Report… button and enter a filename in the Save dialog that appears. 

4. Press the Close button to dismiss the Layout Revision Browser. 

3.10 Publishing a layout 
A layout is published (frozen) when it is ready for formal review. Once a model has been published, it 
cannot be overwritten using File > Save or File > Publish…, however a published model can be 
opened, modified, and saved under a new name using File > Save as… 

Once a layout has been published, all reviewers assigned to the project will be able to access it using 
the Verification Tool. 

To publish a layout to the server: 

1. Select File > Publish... 

3.11 Exporting a layout to ISO VRML97 format 
In addition to saving and publishing models to the CREATE server, the Layout Tool can also export a 
copy of a layout to the local file system in ISO VRML97 format 

When a layout is exported to the local file system, a number of files are created in the directory the 
layout is exported to. It is therefore normally advisable to export a model into a new directory. 

The exported data consists of a main layout file and a set of directories containing the supporting files 
referenced by the mail file. You can load the model into any 3D software that can import VRML97 
files. 

To export a Layout to the local file system: 

1. Select File > Export VRML... 

2. A file chooser dialog will appear. 

3. Select the directory into which the layout should be exported in the file chooser dialog that 
appears, and enter a name for the layout VRML file (which should normally end with .wrl) 

4. Press OK to export the layout, or Cancel to abort the operation. 
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3.12 Exporting a layout to COLLADA format 
In addition to saving and publishing models to the CREATE server, the Layout Tool can also export a 
copy of a layout to the local file system in COLLDA format 

When a layout is exported to the local file system, a number of files are created in the directory the 
layout is exported to. It is therefore normally advisable to export a model into a new directory. 

The exported data consists of a main layout file and a set of directories containing the supporting files 
referenced by the mail file. You can load the model into any 3D software that can import COLLADA 
files. 

To export a Layout to the local file system: 

5. Select File > Export COLLADA... 

6. A file chooser dialog will appear. 

7. Select the directory into which the layout should be exported in the file chooser dialog that 
appears, and enter a name for the layout COLLADA file (which should normally end with 
.dae) 

8. Press OK to export the layout, or Cancel to abort the operation. 

3.13 Exporting a layout package 
Should you need to transfer a layout between two projects, or even two different CREATE servers, it is 
possible to export the layout as a layout package. An exported layout package is a single file that 
contains the layout, model data, and any other data or documents referred to by the layout. 

To export a Layout Package to the local file system: 

1. Select File > Export Layout... 

2. A file chooser dialog will appear. 

3. Select the directory into which the layout package should be exported in the file chooser 
dialog that appears, and enter a name for the layout package file (which should end with .lp) 

4. Press OK to export the layout package, or Cancel to abort the operation. 

3.14 Importing a layout package 
A layout package is a single file that contains the layout, model data, and any other data or documents 
referred to by the layout. A package is created using the Export Layout… function, and can be 
imported used the corresponding Import Layout… function. A layout package has a filename ending 
with .lp. 

When importing a layout package, Models and documents that already exist, and do not differ, on the 
target server will not be added to the database or the project. 

If there are models and documents with the same name and version identification, but where the files 
are not the same, then a dialog offering the possibility to select between using the data from package or 
using the existing model or document in the target server.  

 
The dialog for choosing which model or document to use 
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To import a Layout Package from the local file system: 

1. Select File > Import Layout... 

2. A file project browser dialog will appear. 

3. Select the project in which the layout package should be imported and the press the OK 
button, or Cancel to abort the operation. 

4. Once a project has been selected, a file chooser dialog will appear. 

5. Select the layout package file to import and then press the Open button, or press Cancel to 
abort the operation. 

6. If conflicting models or documents are found, a dialog will appear, prompting you to indicate 
whether the data already existing on the current CREATE Server should be used or whether a 
new version of the data should be created using data from the layout package. For 
convenience, the Apply To All button can be used to toggle all of the choices on or off. Press 
the OK button when you have made your selection, or Cancel to abort the import layout 
operation. 

7. The imported layout will load as a new layout in the selected project. You now need to save 
the layout in order to fully complete the import operation. 

3.15 Communicating with other project team members 

 
The Project Messages window with Project level active 

The Project Messages functionality provides a simple way of communicating. Messages can be read by 
Project Management Tool, Layout Tool and Verification Tool users. All messages are logged by the 
system and stored as part of the project data. 

• Project level messages can be read by everyone in the project team. This would typically be 
used by the project manager to provide information to everyone. 

• Layout level messages can be read by designers and reviewers while working with a specific 
layout. For example, a reviewer can write comments to the layout designer here, and the 
designer can reply. 

• Review level messages can only be seen by reviewers of a layout and is useful if there is more 
than one reviewer that needs to communicate with each other. This option is not available in 
the Layout Tool. 

To communicate with other project team members: 

1. Select Window > Project Messages to display the project message window. 

2. Select the level you want to discuss on by pressing a tab in the top of the window. 

3. Write your message. 

4. Press Submit to enter the comment. 
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5. If you would like a local copy of the messages in HTML format, press Save to save the 
messages to file. 

6. Press Refresh to reload the messages and view any new messages that may have been entered 
by other team members. 

3.16 Browsing Design Guidelines 
The Guideline Browser provides access to design guidelines, if guidelines are available for the project 
you are working on. These guidelines would normally explain issues that you need to take into account, 
and may include explanatory procedures that explain how to check that a guideline has been met. 

You can access individual guidelines by clicking on the hypertext links on the index page in the 
Guideline Browser. 

Once you are viewing an individual guideline, you can use the toolbar above the Guideline Panel to 
return to the index, browse between guidelines, and reload a guideline or index.  

Note that only the Reload button in the toolbar is active while you are viewing the index page. 

To browse design guidelines: 

1. Open the design guidelines, Select Tools > Design Guidelines 

To go to an individual guideline from the index page: 

1. Click on the hyperlink representing the guideline that you want to access in the Guideline 
Browser. 

To go to the index page from an individual guideline: 

1. Click on the Home button in the Guideline Browser 

To go to the previous or next guideline from an individual guideline: 

1. Click on either the Previous or Next buttons in the Guideline Browser 

To reload an index page or individual guideline with associate procedure: 

1. Click on the Reload button in the Guideline Browser. 

3.17 Reviewer Reports 
Reports can be created that contain guideline and review text with associated snapshots. 

Reports are generated depending on the status of the guidelines in the review context. When you 
request a report, a Report Specification window is shown in which you can select between a set of 
different styles for the report. 

If you are not using Microsoft Windows then the View Report option in the Report Specification 
window is replaced with a Save Report option. You can save the report as HTML to your local disk and 
then view it using a Web browser. 

You can print your report via your Web browser. 

To view or save reports by reviewers: 

1. Select Tools > Reviewer Report… 

2. If any review contexts exist for the current layout then a Review Context Selector dialog 
window will appear: 
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The Review Context Selector 

3. Select one of the reviewers, and press the OK button, or Cancel to abort. 

4. The Report specification window appears: 

 
The Report Specification window used to generate a report 

5. The Report Style contains a dropdown with a list of different styles that change what the 
report contains, and how the data is presented. The text displayed below describes the 
currently selected style. 

6. Press View Report (Microsoft Windows Only) or Save. 

7. If you select View Report then the report will be displayed in your default web browser. 

If you select Save then a file dialog will appear requesting that you enter a name for the report. 
Enter a name and press save to store a copy of the report on your local disk. 

3.18 Locking 
When a layout is saved for the first time the layout is marked as locked. The layout will be unlocked if 
the layout is closed, either by opening another layout or if the Layout Tool is closed.  

The layout will also be marked as locked when reopened if not already marked as locked by another 
user. 

When the layout is locked, only the user that made the lock will be able to save modifications to the 
current layout.  

This means that if you open a layout while another user is editing it, you will not be able to save your 
modifications. You can still save your work by giving the layout a new name. See Saving a layout with 
a new name. The user who is currently locking the layout is shown in the window title bar. 
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If you would like the layout to be available for saving by another user opening the layout, you can 
release the lock by selecting File > Release Lock… You will not be able to save your modifications to 
this layout. 



Release 4.2 (rev: 03/01/2024) 22 Layout Tool User Guide 

4 Working with a Virtual Layout 

4.1 Overview of the 3D view user interface 

 
The 3D view with toolbars and a room layout loaded 

The screenshot above shows the 3D view part of the Layout Tool user interface, with upper and lower 
toolbars and a virtual layout. The upper toolbar contains a selection of tools that are useful for editing 
and testing the model and retrieving information about it. 

The tool sets available include: 

• Edit Tools – which are provided for editing and organising the objects in the 3D scene. 
See Using the Edit Tools for more details. 

• Manikin Tools – which are used to place virtual humans in the layout to test lines of 
sight, reach, human access, and so forth. There is normally a variety of manikins 
available from the server that can be used to test the layout, including standing and 
sitting manikins of various heights. See Using the Manikins Tools for more details. 

• Measurement Tools – which enable you to make multiple measurements in the layout to 
check distances and angles, but also to visualise areas of readability for labels and areas 
within a specific point can be seen. See Using the Measurement Tools for more details. 

The lower toolbar contains navigation controls (on the left) and access to the room configuration 
function (on the right). See Interaction and Navigation in a virtual layout and Layout Printing, Snapshot 
and Room Configuration for details. 

4.2  Interaction and Navigation in a virtual layout 
There are primarily two different categories of modes that affect how you interact with the virtual 
layout; these are Interaction modes and Navigation modes. The interaction modes change how you 
interact with the 3D objects in the layout, while the navigation modes change how you navigate the 
camera around in the layout (i.e. moving around). 
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The different navigation modes are Orbit, Fly, and Pan.  

The different interaction modes are Pick and Rotate. 

The navigation toolbar contains buttons for the most commonly used functions and provide useful 
information when working in the virtual layout. The toolbar contains four buttons (from the left): Pick, 
Rotate, Navigation mode (currently: Orbit), and Seek. This gives you quick access to changing 
between the two interaction modes and the navigation mode. It is also useful for keeping track of which 
mode is active. The navigation mode button changes icon depending on which navigation mode is 
active. To quickly switch between various navigation modes there are keyboard shortcuts, which will 
be covered in the following sections. Lastly the seek button allows the camera to quickly move to a 
location that the user selects in the 3D scene. 

 
The main Navigation Controls in the 3D View lower toolbar 

The Camera menu contains additional functionality used when navigating the camera in the 3D view, 
these will be covered in the following sections. 

4.2.1 Navigation Modes  
The three different navigation types are Orbit, Fly and Pan. You can switch between these types by 
accessing the Camera menu, and selecting the desired mode. The currently active mode is indicated 
both in the Camera menu and in the navigation controls in the lower toolbar. In the lower toolbar the 
navigation icon will change depending on which mode is active.  

 
Orbit is the currently active navigation mode (second from the right)  

The active navigation mode can be changed through shortcut keys, these are only available in the 3D 
view. Orbit is activated with 'W' and Fly with 'E'. 

 
Navigation type can be changed through the Camera menu 

4.2.2 Using the Orbit Navigation 
The orbit navigation mode moves the camera in relation to a point in space, also referred to as the pivot 
point. This is the default navigation type used in the 3D tools in the HVRC CREATE suite.  

Orbit mode can be activated by pressing the shortcut key 'W' in the 3D view or through the menu 
Camera > Orbit. 
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Orbit mode is active 

If you have a three-button mouse, the buttons are mapped as follows: 

• Left button: rotate  

 
Mouse cursor changes to orbit icon  

• Right button: pan 

 
Mouse cursor changes to pan icon  

• Middle button (or left & right button): zoom 

 
Mouse cursor changes to zoom icon  

When rotating the camera with the left mouse button you change the position and orientation of the 
camera in relation to the pivot point. The pivot point will stay stationary and the camera will rotate 
(orbit) around the point by changing the horizontal and vertical rotation of the camera.  

The direction the camera is moved when either rotating or panning is inverted, meaning that when i.e. 
dragging left, the camera will rotate to the right and vice versa.  

Panning will move the camera without changing its orientation. As the camera moves, the pivot point 
moves with the camera, maintaining the same distance and orientation from the camera.  

Zooming will move the camera closer or further from the pivot point. The pivot point will stay 
stationary while zooming. 

The distance that the camera is actually moved when either panning or zooming is relative to how far 
the camera is from the pivot point. The closer the camera is to the pivot point, the smaller is the 
distance that the camera is moved. The camera is prevented from moving past the pivot point, so the 
zooming distance will approach zero the closer the camera is to the point. 

If the ctrl key is pressed while zooming, both the camera and the pivot point can be moved back and 
forth maintaining the same distance between the camera and the pivot point. 

The pivot point can be shown in the 3D view temporarily while navigating. The point is visualised as 
three coloured lines that intersect at the point, where each lines corresponds to an axis (x, y, and z). To 
toggle the visibility of the pivot point select View > Show Camera Pivot Point (Orbit). 

 
Pivot point visualisation, red, green, blue corresponds to x, y, z axis 

4.2.3 Using the Fly Navigation 
The fly navigation mode features free camera movement, enabling the camera to turn and tilt freely 
while moving. This gives full control over the movement. 

Fly mode can be activated by pressing the shortcut key 'E' in the 3D view or through the menu Camera 
> Fly. 
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Fly mode is active 

If you have a three-button mouse, the buttons are mapped as follows: 

• Left button: fly  

 
Mouse cursor changes to fly icon 

• Right button: pan 

 
Mouse cursor changes to pan icon  

• Middle button: tilt 

 
Mouse cursor changes to tilt icon  

Holding down the left button will fly the camera. This will move the camera forwards or backwards 
depending on the way you drag the mouse from the point you clicked. The camera will move in the 
direction the camera is currently facing. Moving the mouse to either side will also turn the camera 
towards that direction. Note that the turning is reversed when moving backwards. 

Pressing the tilt button will tilt, or rotate, the camera in the direction you drag the mouse. This enables 
you to change the direction you are looking, and also the direction you will fly towards. 

Panning will move the camera without changing its orientation. The camera will move in the direction 
the mouse is dragged. 

The speed of the camera when using fly can be changed through Camera > Travel Speed… 

4.2.4 Using the Pan Navigation 
The pan navigation mode differs from the two other modes in that it does not allow you to change the 
orientation of the camera manually. This makes it a more specialized mode that you typically only want 
to use in some specific cases. Pan mode allows moving the camera location in any direction while 
maintaining the cameras current orientation, this effectively means that you can only pan and zoom. 

A typical use case of the pan mode would be to align the camera with an axis, i.e. the y-axis, giving 
you a top-down view. Combining this with an orthographic view projection (see Changing Perspective 
Projection) will give a nice overview of the 3D scene. Typically when navigating like this you do not 
want to orient the camera, but rather want it to stay fixed. This navigation mode is tailored for this, 
preventing the user from making accidental changes to the camera orientation.  

Although the mode itself does not offer any interactive way to change the cameras orientation, it is 
possible to use other tools to orient the camera. For example the Align Tool (see Aligning camera to 
selection) can be used to i.e. align the camera with a surface, such as a computer monitor.  

Pan mode can be activated the menu Camera > Pan. 

 
Pan mode is active 

If you have a three-button mouse, the buttons are mapped as follows: 

• Left button: pan  

 
Mouse cursor changes to pan icon  

• Right button: pan 
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Mouse cursor changes to pan icon  

• Middle button (or left & right button): zoom 

 
Mouse cursor changes to zoom icon  

Panning will move the camera without changing its orientation. The camera will move in the direction 
the mouse is dragged. The direction the camera is moved when panning is inverted, meaning that when 
i.e. dragging left, the camera will move to the right and vice versa. 

Zoom will move the camera forwards or backwards without changing its orientation.  

4.2.5 Using the Pick Mode 
The Pick mode is used to select and interact with objects in the 3D scene. 

Pick mode can be activated by pressing the shortcut key 'Q' in the 3D view or the Pick button in the 
toolbar. 

 
Pick mode is active 

The pick mode is automatically activated when using some of the tools or interactions in the 
application, such as dragging an object into the scene (see Adding an object to the scene) or creating a 
measurement (see Using the Measurement Tools).  

4.2.6 Using the Rotate Mode 
The Rotate mode is used to rotate objects in the 3D scene.  

To rotate an object: 

1. Activate the rotate mode by either pressing the Rotate button in the navigation toolbar, 
selecting Rotate in the Object menu or by pressing the shortcut key 'R'. Note that the picking 
button will also be marked as active when in Rotate mode, this is to indicate that selection of 
objects, which is a feature of the Pick mode is also active. 

2. When selecting an object with the mouse, the selected object will be rotated when moving the 
mouse while holding down the left mouse button. 

 
Rotate mode is active 

4.2.7 Temporary switching between Interaction and Navigation 
Mode 

It is possible to temporarily switch between the current active mode and the previously used mode, 
allowing you to perform some actions using the other mode, before then first mode is resumed. This is 
useful when you only need to quickly switch to another mode to do a quick action, such as when you 
are i.e. manipulating objects in the scene, and you need to reposition the camera for a better viewing 
angle, before you continue operating on the objects. 

Note that this switching is only allowed between the last used interaction mode (pick or rotation) and 
the last used navigation mode (orbit, fly, or pan). 

The shortcut key 'shift' is used for this. For as long as the key is pressed, the previous mode will be 
active. When the key is released, the other mode will be reactivated. 

4.2.8 Viewpoints 
When viewing the 3D scene the camera is attached to a viewpoint. As the camera, and thus the 
viewpoint is moved around in the scene its position and orientation is modified. This is stored in the 
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currently active viewpoint. By changing viewpoints you can quickly switch between different locations 
in the scene, and you are also able to store locations that you might wish to jump back to at a later time. 

There are always seven predefined viewpoints available, these are referred to as System Viewpoints. 
These are automatically created when a new layout is created, and are positioned at various predefined 
locations commonly used when working with a layout. The positions adapt to the dimensions of the 3D 
scene.  

System Viewpoints: 

• Top – view from above (looking down) 

• Front – view from front 

• Left – view from left side 

• Right – view from right side 

• Back – view from rear 

• Bottom – view from below (looking up) 

• Explore – view from front, tilted 

It is also possible to create your own viewpoints, called Custom Viewpoints. There is no real 
difference between the system and the custom viewpoints, except that the system viewpoints are 
locked, meaning they cannot be renamed or deleted.  

Add a custom viewpoint: 

1. Optional: Navigate the camera to the position and orientation you want it positioned 
2. Select Camera > Manage Viewpoints > Add Viewpoint… 

3. Enter a suitable name in the dialog and press Ok or Cancel to abort 

 
4. The viewpoint has now been created. 

 
The new viewpoint will automatically inherit the current position and orientation that the 
camera has at the time it is created. 
 
Note that the viewpoint you created will not be selected automatically. To select the viewpoint 
access it through the menu Camera > Viewpoints > MyViewpoint_0 (replace with the name 
you chose for the viewpoint) 

Remove a custom viewpoint: 

1. Select Camera > Manage Viewpoints > Remove Viewpoint 
2. This will show a list of all the custom viewpoints 
3. Select the viewpoint you wish to remove in the list: 

 
4. A confirmation prompt will be shown. Press Yes to remove it or No to cancel. Note that you 

cannot undo this removal. 

Select viewpoint: 
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1. Select Camera > Viewpoints 

 
2. Choose the viewpoint you want to select. The currently selected viewpoint is marked in the 

list. 
Note that the system viewpoints are always listed first. The shortcut keys command-[1-7] will 
select the associated viewpoint. There is no associated shortcut available for custom 
viewpoints. 

3. When a viewpoint has been selected the camera will automatically be moved to the location 
and orientation specified by the newly selected viewpoint. 

Reset current viewpoint: 

It is possible to reset the viewpoint back to its original position and orientation.  

1. Select Camera > Reset Current Viewpoint 

For the system viewpoints this will set the viewpoints back to the correctly fitted location calculated 
based on the size of the 3D scene and which viewpoint it is (i.e. top is different from front). The custom 
viewpoints have no relation to the size of the 3D scene, and will thus be reset to the position and 
orientation they had initially, which will either be what they had when the layout was loaded, or if it 
was newly created it will be the location it had then. 

Quickly switch to next viewpoint: 

It is possible to quickly select the next viewpoint in the list of viewpoints. This is done by either 
selecting Camera > Next Viewpoint or using the shortcut key command-alt-2. This cycles through all 
the viewpoints, including custom viewpoints. 

Quickly switch to previous viewpoint: 

It is possible to quickly select the previous viewpoint in the list of viewpoints. This is done by either 
selecting Camera > Previous Viewpoint or using the shortcut key command-alt-1. This cycles through 
all the viewpoints, including custom viewpoints. 

4.2.9 Using Straighten 
The Straighten feature is used to level the user view relative to the ground when moving around in the 
Explore navigation mode. It resets any tilt movement that might have been made. 

To straighten your view: 

1. Press the Straighten menu entry in the Camera menu, or use the shortcut key 'spacebar' when 
in the 3D view. 

4.2.10 Using the Seek Button 
The Seek button is used to move the view closer to a point clicked on in the scene. After activating 
Seek, you can click on the scene for the view to move automatically towards that point. This can be 
useful for quickly moving around a 3D scene. The mouse cursor will change as long as Seek is active. 

 
The Seek Button 

To use Seek navigation to move the camera towards a point in the scene: 
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1. To active Seek either press the Seek Button in the navigation toolbar, or select Seek in the 
Camera menu, or press the shortcut key 'T' in the 3D view. 

2. The mouse cursor will change to the same icon as the Seek button. This will remain active 
until step 3. is completed or Seek is cancelled by either pressing the button again, or pressing 
the 'escape' key. 

3. Click on a surface in the 3D view 

4. The view will move rapidly towards the point clicked, stopping immediately in front of the 
point 

4.2.11 Using the Virtual Compass 
The virtual compass indicates the cameras position and orientation in the virtual layout in relation to 
the direction of the X, Y, and Z axis. This can be useful to help you maintain your bearings while 
moving around. 

If the camera is placed on the floor and the camera is looking straight ahead, then the x-axis is towards 
the right, y-axis is upwards, and z-axis is towards you. 

To use the compass: 

1. Select View > Show Compass 

2. A virtual compass will appear in the upper right corner of the 3D view: 

 
3. Press the menu entry again to turn the 3D compass off 

The virtual compass is interactive. If you place your mouse above any of the elements that compose the 
compass you will see that they change colour indicating that the current element is interactive. Clicking 
on any of the cones will transition the camera to the position and orientation represented by the 
compass. The box can be pressed to switch between the different projection modes, Perspective and 
Orthographic (see Changing Perspective Projection). 

4.2.12 Setting the Background Colour 
The background colour of the 3D view can be configured to a colour that provides an appropriate 
background to the layout in use. 

To toggle between a plain white background and a user-defined background for the 3D view: 

1. Select View > Show Background 

To change the background colour of the 3D view: 

1. Select View > Set Background Colour… 

2. A colour chooser dialog will appear 

3. Select a colour and press OK or Cancel to abort 

4.2.13 Using the Visual Grid 
A user-configurable visual grid is available that can be useful as an aid to judging distances. See also 
Snap to Grid for more information on practical use of the grid. 

To toggle the visual grid: 

1. Select View > Show Grid or press the shortcut key 'G' in the 3D View 

To configure the visual grid: 
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1. Select View > Grid Options… 

2. A dialog will appear in which you can adjust the grid spacing and colour 

Press OK to accept the changes or cancel to dismiss the dialog 

4.2.14 Changing Perspective Projection 
The default 3D projection in the 3D view is perspective projection. This is similar to what the human 
eye perceives when viewing the real world, where objects in the distance appear smaller than objects 
close by. Alternatively perspective projection can be turned off, in which case orthographic 
projection will be used instead. Orthographic projection will ignore the distance between the eye and 
the objects, effectively rendering all objects at the same scale. 

To toggle perspective project: 

1. Select Camera > Perspective  

This will turn perspective projection on or off 

4.2.15 Changing the Field of View 
The field of view defines how much of the 3D scene is observable from the 3D view. Increasing the 
field of view will let you see more of the 3D scene, but objects may appear smaller. If the field of view 
value is set too high the image can look distorted. Generally values between 60 and 90 are 
recommended, depending on how large the monitor is, and how far away from the monitor the user is 
seated. 

To change the field of view: 

1. Select Camera > Field of View… 
2. A dialog will appear in which you can set the field of view 

Press OK to apply the new value or Cancel to abort 
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4.3 The Model Bank 
The Model Bank Catalog provides access to the 3D models available to the current project, as specified 
by the project manager using the Project Management Tool.  

Models are arranged in a hierarchy of categories. 

Each category can contain sub-categories and/or a set of models.  

Categories have a generic folder icon or an icon with a folder and a room, indicating that the category 
contains room models. 

 
The Model Bank Catalogue 

To browse model bank categories: 

1. Click on a category name to reveal its contents (if any) in the lower panel of the Catalog. 

2. If the category contains sub-categories, a handle is shown to the left of the category name. By 
clicking on this handle, you can reveal or hide subcategories, which can be accessed in the 
same manner. 

4.3.1 Viewing Model Bank details about an object 
In addition to the models themselves, the Model Bank often contains additional useful information 
about the items in it. Model details for an object include a snapshot, its name, dimensions, comments, 
and associated tags. 
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Note that in addition to the method described below, Model Bank details can also be accessed via the 
Object Overview popup menu for an object that has already been added to a scene. 

To view Model Bank details about an object: 

1. Locate the icon of the object of interest in the Model Bank Catalogue 

2. Either Click on the icon, without moving the mouse while clicking (i.e. Click on the icon, but 
do not drag it) or right-click on the icon to access a popup menu and select Model Details 
from the menu. 

3. The Model Details window will appear with information about the object. 

 
Model Details for a room objects in the Room category 

4.3.2 Customising the icon view 
It is possible to choose between small or large model and catalogue icons and to choose whether to 
display an item’s name on the model icon. 

To choose small Icons: 

1. View > Small Catalog Icons 

To choose large icons: 

1. View > Large Catalog Icons 

To display an item’s name on the model icon: 

1. View > Catalog Icon Labels 
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4.4 Adding a room to the scene 
When starting work on a new layout, the first step is typically to either 

• Insert a room from the Model Bank  
or 

• Create a new room using the Layout Tool 

By room we really mean an arbitrarily complex structure with walls, floors and ceilings, so your room 
could be the entire floor of a building or even a whole building. A layout can contain more than one 
room. 

Typically a room is the shell of a storey of a building — the architectural constraint within which your 
layout will be created. 

Pre-built rooms can be added to a layout by dragging the room icon representing the required model 
from the Model Bank Catalogue into the 3D scene. If a pre-built room is dropped onto a Ground object 
then the Ground is replaced by the pre-built room, otherwise it is inserted into the layout as an 
additional structure, which you can position as you wish. If you want a Ground and a pre-built room, 
then you should draw a foundation (e.g. a flattened parametric Box) for the room on the Ground and 
the place the pre-built room on top of that (locking the position of both afterwards to prevent 
accidentally moving them). 

There are three ways of creating a room shell using the Layout Tool 

• Use the Room Wizard to configure a predefined room layout 
• Use the Room Wizard to configure a predefined room layout and then modify the result by 

splitting and pushing walls 
• Choose an empty room from the Room Wizard and build a room, wall by wall, using wall 

objects 

The easiest way to create a new room is by using the room wizard that appears when a new layout is 
started. The wizard creates the basic shell of a room, which you can later modify to include the details 
that you need. The room shell created by the wizard comprises of a Wall Group containing a set of 
Wall elements. A Wall Group is an ordered group of Wall elements, where neighbouring Wall elements 
share corners, and can share an enclosed ceiling and floor. A Wall Group typically represents a room or 
storey in a building. 

Once you have loaded or created a room shell, you can partition it further by splitting wall, and adding 
architectural objects to a scene, such as Wall Groups and Walls from the Objects menu. The same 
architectural objects can also be used to create additional rooms from the ground up. 

It is strongly recommended that you turn on the Snap to Grid functionality when drawing or modifying 
Wall elements or Wall Groups. In addition to snapping wall corners to the global grid, this also 
enables a snap features specific to the wall editor that makes modifying rooms easier. 

To add a pre-modelled room to a scene: 

1. Browse the Model Bank categories to locate a room. Room categories are always listed at the 
top of the Model Bank category list and have icons indicating that they contain rooms. In 
some cases, the rooms may be located in a sub-category of one of the categories near the top 
of the list. 

2. Click on the icon representing the room that you want to add to the scene and hold the left 
mouse button down 

3. Drag the icon over the 3D view. The cursor will change to indicate that the icon is being 
dragged 

 
A room icon being dragged from the Model Bank Catalog into a scene 

4. Release the mouse button over the ground, or some other location where you would like to 
place the room into the scene 
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5. If you drop a Model Bank object directly onto a Ground object then the Ground will be 
replaced by the new room, otherwise the new room will be added to the scene, like a normal 
Model Bank object that you can position (it is recommended that you then lock the position to 
prevent accidentally moving it). 

To replace a pre-modelled room with another pre-modelled room: 

1. Select the room object in the Object Overview 
2. Right-click to reveal the popup menu and select Remove from the menu or select Edit > 

Remove 
3. The existing room will be replaced by a Ground object 
4. Add a different pre-modelled room to the scene, dropping it on the Ground 
5. The Ground will then be replaced by the new pre-modelled room. 

To create a room using architectural parametric objects: 

1. Consider turning on snap-to-grid and setting an appropriate grid distance to make it easier to 
draw walls accurately 

2. Select the Objects > Architectural > Wall Group menu item 
3. Click inside the 3D scene (e.g. on the ground or the floor of an existing room) to start drawing 

a wall 
4. A marker handle will be displayed indicating the start location for the first Wall element in the 

new Wall Group 
5. Each time you click the mouse a new wall will be drawn from the last marker to the location 

you click on, and a new marker will appear. You can continue to click at new locations in the 
scene to add as many new Wall elements as you like to the Wall Group 

6. To create an open Wall Group, double-click to specify the location of the last marker. 
Alternatively, create an enclosed Wall Group, where the last and first points meet to create an 
enclosed space, by clicking on the first marker handle 

7. Click on the Attributes tab in the Selected Object pane to reveal the attributes table for the 
selected Wall Group object. You can add a floor or ceiling, change the wall height or 
thickness, or adjust wall colour, by adjusting the objects parameters. Door and window 
openings can be added to Wall elements similarly, by modifying the attributes of individually 
selected Walls. 

8. To add additional internal walls, repeat this procedure to add additional Wall Groups or, in a 
similar manner, insert single Wall objects.  

4.4.1 Using the Room Wizard 
The Room Wizard is displayed when you create a new layout by selecting New from the File menu. 
The wizard has two forms that can be navigated between by pressing Previous and Next buttons. In the 
first form, you can select an empty room or a preconfigured room shape, and in the second form, you 
can enter parameters to configure the chosen room shape. 

An “Empty Room” is simply a Ground object. You can select an empty room shape from the Room 
Wizard if you wish to start with a completely empty scene. If you hit Cancel when the Room Wizard is 
shown, a default empty room is created. 

Even if the room you intend to build is relatively complex, you can save time by selecting a room with 
approximately the same shape as the one that you intend to model. Once the basic room has been 
created, you can modify it by splitting and moving walls. 

The Room Configuration Options form is illustrated with a picture showing the parameters a, b, and c, 
which may be available for configuration depending on the room shape chosen. Note that the 
dimensions of the room and the a, b, and c parameters represent the inner dimensions, so a room that is 
10 x 10 m is the same size from within the room regardless of how thick the walls are. The wall height 
is also from the floor to the ceiling, regardless of how thick the floor or ceiling is. 

The Ground object and the Floor element of a room are different entities: 

• The Ground is the surface on which a room (Wall Group) is placed 
• The Floor (and Ceiling) is an element that belongs to a room. It is enclosed by Wall elements 

managed by the Wall Group that define its shape 
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• The position of the ground is fixed, but you can move a Wall Group (with its Floor) around, 
although you may need to unlock the position. It is a good idea to lock the position and 
rotation of a room to prevent it from accidentally being selected and moved around the scene 

The Room Configuration Options form also enables you to specify that the ground should be a 
percentage larger than the bounds of the room. 

To use the Room Wizard to create a new room: 

1. Select File > New… to create a new layout 
2. The Room Wizard will appear automatically. If you hit Cancel (or press 'escape') then a 

default sized empty room is created and the wizard is dismissed. 
3. Select the room shape or empty room if you want to start with a flat ground: 

 
4. Press the Next button to see the room configuration options: 

 
5. Set the room configuration options. You can use the Previous and Next buttons to switch 

between forms until you are satisfied with your choices 
6. Press the Finish button to generate the specified room and dismiss the wizard 
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4.5 Modifying the ceiling, floor and walls of a room 
Rooms comprising of Wall Groups and Wall elements can be modified. To modify a Wall or a Wall 
Group right click on any of the walls in the 3D view and select Edit. This will enter wall-editing mode. 
Once in the editing mode, you can perform a number of room modification actions quickly and easily. 
Spherical handles indicate the wall element ends when a Wall or Wall Group is in editing mode. 

 
A Wall Group in wall-editing mode, with the top-most Wall element in the scene selected and the 
spherical wall-end handles indicating the edges between Wall elements in the all Group. 

If you select an object other than the markers or a wall then the Layout Tool will exit wall-editing 
mode and the markers will disappear.  

Until you exit the wall-editing mode, you can drag then handles to move the ends of walls and select 
wall elements and push and pull them to move them in or out. Pushing or pulling a Wall is often 
quicker than moving the handles at each end of a wall. The upper sphere handles lets you adjust the 
height of all the walls in the wall group. Within a wall group all walls share the same height. If you 
need different heights for the walls you need to create additional wall groups, or a single wall. 

While in the wall-editing mode, you can split a Wall element by right clicking on it and selecting Split 
Wall. A new handle will be created at the split. If you split a Wall that is not in a Wall Group then the 
result of the split will be a new Wall Group with two Wall elements. 

As for creating new rooms, it is easiest to edit a Wall Group or Wall if you first turn on the Layout 
Tools snap to grid function. 

Wall Groups have optional ceiling and floors and you can modify the colours of the floor, ceiling, or 
individual wall elements by modifying the appropriate attributes of the selected object.  You can also 
add openings for doors or windows to Wall elements by modifying the attributes of a Wall element. 
Modifying the size and position of the opening is done interactively while when in the wall-editing 
mode. If a Wall element has an opening then additional handles are drawn when it or the Wall Group it 
belongs to is in edit mode. 

It is strongly recommended that you turn on the Snap to Grid functionality when drawing or modifying 
Wall elements or Wall Groups. In addition to snapping wall corners to the global grid, this also 
enables a snap features specific to the wall editor that makes modifying rooms easier. 

When selecting any of the walls in a wall group in the 3D view the selection will always default to the 
wall group. If you want to select a single wall right click on the wall in the 3D view and select Select 
Wall. 
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Wall Group and Wall element attributes 

To select a single wall: 

1. Right click on the wall in the 3D view 
2. Select Select Wall in the popup menu 

Alternatively you can select the wall in the Object Overview. 

To get selection back to the wall group either click on one of the other walls in the wall group or 
right click on the same wall and select Select Wall Group. 

To move or resize a wall: 

1. Right click on a Wall or Wall Group in the scene and select Edit to enter the editing mode 

2. Wall handles will appear indicating that the wall is in edit mode 

3. Select a Wall element and drag it to move it in/out or select a handle and drag it to move the 
end of a Wall element 

4. To exit the wall-editing mode, click on the floor or ground to deselect the wall element or wall 
group 

To split a wall: 

1. Right click on a Wall or Wall Group in the scene and select Edit to enter the editing mode 

2. Wall handles will appear indicating that the wall is in edit mode 

3. Right click on a wall where you would like a split to be made. Select Split Wall from the 
popup menu. A single wall object will be converted into a Wall Group with two Wall 
elements, if it is not already part of a Wall Group. 

4. A new handle will appear at the split point 

5. Repeat the operation to add additional handles 

6. To exit the wall editing mode, click on the floor or ground to deselect the Wall element or 
Wall Group 

To add a door or window opening to a wall: 

1. Select a Wall element directly in the Object Overview, or the 3D view while in the wall 
editing mode 

2. Click on the Attributes tab of the Selected Object panel to reveal the attributes table for the 
selected object 

3. Click on the value for Type and select Wall With Door or Wall With Window from the drop-
down menu that appears 

4. You can modify the size and position of the opening by interactively dragging one of the blue 
spheres or by entering values for fields in the attributes panel. 

5. In some case you may need to split a Wall element to add more openings 
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To edit a wall with a door or window: 

1. Select the wall you wish to edit as described above 
2. Right click on the wall (once selected) and select Edit Wall 
3. The wall and the hole will now be editable, you can modify the position of the opening by 

dragging the sphere handles 
Note that this will also enable editing of the rest of the wall group 

4. To exit the wall editing mode, click on the floor or ground to deselect the Wall element or 
Wall Group 

To add a floor and ceiling to an existing Wall Group: 

1. Select a Wall Group object 

2. Click on the Attributes tab in the Selected Object pane to reveal the attributes table for the 
selected object 

3. Turn on the ceiling or floor by modifying the appropriate attributes shown in the Attributes 
panel 

4. Click on the floor or ground to deselect the wall element and exit the object editing mode 

5. If you need to change the thickness of the floor or ceiling then that attribute can be modified 
by selecting the Floor or Ceiling object and adjusting the Thickness attribute of that object in 
the Attributes table 

To change the colour of an existing parametric wall, floor, or ceiling: 

1. Select a Ceiling, Floor, or Wall element directly in the Scene Overview, or a Wall element in 
the 3D view while in the wall editing mode, or Select a Wall Group 

2. Click on the Attributes tab in the Selected Object pane to reveal the attributes table for the 
selected object 

3. Adjust the attribute that you wish to modify in the Attributes table by clicking on the value 
and selecting a new colour from the dialog that appears. If you change the Wall Group colour 
then you set the colour for all of the Wall elements that it contains, whereas changing the 
colour of a Wall element, Floor or Ceiling changes the colour for just that element. 

4. Note that changing the colour of a Wall applies the same colour to both sides of the wall. If 
you need to colour one side a different colour then you can use thin primitive objects to cover 
the side of the wall and then set those primitives to the required colour. For example, for a 
plain rectangular wall with no openings, you can use a thin Box to wallpaper a wall. 

4.6 Adding an object to the scene 
Ready-made models are added to a scene by simply dragging a model icon from the Model Bank 
Catalogue into the 3D view and dropping the model where you wish to place it. 

3D models that are located on the local machine can also be added to the scene; these are referred to as 
project models and are described in greater detail in section 4.12. 

Entirely new geometry can also be created within the Layout Tool by selecting a parametric object 
from the Objects menu and then drawing in the scene. While ready-made models cannot be altered, 
beyond positioning and rotating them, parametric objects created within the Layout Tool can be 
modified. In addition to basic geometry that can be edited interactively, some parametric objects have 
attributes that can be set to customise the appearance or shape of the object. 

To add an object to the scene: 

1. Browse the Model Bank categories to locate an object you would like to add to the scene. 

2. Click on the icon representing the object that you want to add to the model (and hold the left 
mouse button down for the next step).  

3. Drag the icon into the room (and hold the left mouse button down for the next step). 

4. A box with the same dimensions as the object you are adding is displayed and follows the 
mouse cursor as you drag your mouse, to indicate where the new object will appear. Move the 
cursor to position the object. 
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An object in the process of being introduced to a scene 

5. Release the mouse to create the object at the chosen location. 

 
An object that has just been added to a scene 

6. The object is added to the scene and automatically selected. 

Updating the model version for objects in the Layout: 

If a newer version of a model has been added to the Model Bank you can update the version used in the 
Layout to the latest version found. The Edit > Models contains a sub menu that has several different 
ways to update the model version for objects in the current layout. These are: 

• Update Model for Selected Object: This will update the model version for only the selected 
object 

• Update Models for All of Selected Object Type: This will update the model version for all 
objects in the layout that are using the same model object as only the currently selected object 

• Update Models for Selection: This will update the model version for all objects currently 
selected 

• Update Models for All Types from Selection: This will update the model version for all 
objects in the layout that are using the same model object as the ones currently selected 

• Update Models for All: This will update the model version for all objects in the layout with 
no limitations 

To create an entirely new object within the Layout Tool: 

1. Select an object type from a sub-menu in the Object menu (e.g. Object >Primitive > Cone) 

2. Click in the layout to start drawing the object and then EITHER drag the new object to the 
required size before releasing the mouse button, if the object is rectangular or volumetric, OR, 
if the object is a kind of line rather than a volume (such as a Line object or a Wall), the first 
click starts the line and subsequent clicks add a line segment, with a double-click completing 
the line for its last point. 

3. You can interactively modify the object by right clicking on it and selecting Edit from the 
popup menu. This will turn on edit mode for the object, where there are blue sphere handles 
that can interactively be dragged to modify the object. To finish editing deselect the object. 
See Editing parametric objects for more information. 
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4. From the Object Attributes panel (in the Selected Object pane), you can adjust additional 
parameters related to the object manually (e.g. adjust the height of a cone or the width of a 
cube, set a colour, or enable an option). 

4.7 Selecting objects 
Most actions that can be performed on objects require that you select an object on which the action will 
be performed. 

Clicking on the floor of a room deselects all selected objects. Alternatively the shortcut key 'escape' 
will achieve the same effect. 

If you are not in multiple selection mode (see Multiple Selection), then selecting a new object will 
cause previously selected objects to lose their selection. 

To select an object in the scene: 

1. Make sure the Picking mode is active (or hold down the shortcut key 'shift' for the duration of 
the selection operation to temporarily toggle picking mode, if the Picking mode is not 
selected) 

2. Move the mouse cursor over the object you would like to select. 

3. Press the left mouse button to select the object. 

4. An outline box will appear around the selected object to indicate that it is selected: 

 
A selected object 

To view dimensions of selected object: 

1. Select View > Show Selection Dimensions 

2. Selected objects will now display the dimensions: 

 
Dimensions shown for the selected object 

4.8 Positioning objects 
To position an object in the scene: 

1. Select the Picking Button if not already selected. 

2. Select the object that you want to position (see Selecting objects), but do not release the left 
mouse button. 

3. Drag the mouse to move the object to a new location. The object will follow your mouse. 
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4. Release the mouse button to drop the object. 

4.9 Rotating objects 
To rotate an object in the scene: 

1. Activate the rotate mode by either pressing the Rotate button in the navigation toolbar, 
selecting Rotate in the Object menu or by pressing the shortcut key 'R'. 

2. Select the object you want to rotate (see Selecting objects) – but do not release the left mouse 
button if you are using the alt-key modifier. 

3. Drag the mouse to the left or right to rotate the object. The selected object will be rotated 
around its Y-axis. 

4. Release the mouse button to complete the rotation. 

4.10 Showing the dimensions for selected objects 
To show the dimensions for objects selected in the layout: 

1. Select View > Show Selection Dimensions 

2. Select object(s) (see Selecting objects) 

3. Dimensions of the outline box will show on the outline box 

4.11 Accurate positioning of objects 
It is possible to accurately position objects in the scene using the Selected Object panel. 

There are two different ways of accurately positioning objects: Relative to the objects parent (relative 
positioning) or relative to the origin of the scene (absolute positioning). 

To accurately position an object:  

1. Select the object 

2. The objects position and rotation will be shown in the Selected Object panel in the Relative or 
Absolute tabs: 

 
The Selected Object Panel showing the objects relative position and orientation in a scene. 

3. Select the Relative or Absolute tab depending on which method you want to use to adjust the 
objects position and orientation. 

4. Enter new values as desired.  

5. Values are updated when you hit the 'enter' key on your keyboard after entering them. If the 
object is within view in the 3D view then you will see the changes you make reflected in the 
3D view. 
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4.12 Adding 3D models from the local machine (as Project 
Models) 

3D models that are stored on the local machine can be added directly to the layout without adding them 
to the server using the Model Bank Tool. This gives the user an easy way to quickly test various 
models without having to first upload them to the server using the Model Bank Tool. 

These models are referred to as Project Models, and as the name indicates, these models are specific to 
the project that the current layout belongs to and will only be available within that project. 

Please note that this feature is not intended as the default way of adding new models to the layout, it is 
only provided as an easy and quick solution for testing various 3D models for i.e. compatibility or as a 
placeholder.  

To add a local 3D model as a project model in the scene: 

1. Drag the 3D model from the local machine and release it on the image surface object. The file 
can either be the directory that the model is located in, a zip-archive containing the model or 
the model file directly. The supported model formats are COLLADA (dae), KMZ and VRML 
(wrl). Additional model formats (OBJ, LWO, PLY, SCENE (Ogre3D)) can be enabled by 
selecting “Enable experimental 3D loaders” in the Expert Preferences dialog. 

 
Drag 3D models from the local machine into the scene 

2. If the dropped 3D model is a valid type it will be loaded directly as an object in the scene. 
Note that the loading may take some time depending on the complexity of the model. The last 
used settings in the model import dialog from the Model Bank Tool are applied to the model. 
If there are problems with the loaded model, such as visual artefacts, incorrect scale, 
orientation etc. it is necessary to open the model in a 3D modelling tool and make 
adjustments. 

 
Local 3D model loaded as a project model in the scene 
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3. The project model behaves the same as any other object in the scene. If you wish to have 
multiple instances of the same object in the scene either duplicate or copy/paste the object. 
Alternatively drag the same model from the local machine into the scene again. 

4.13 Editing parametric objects 
Objects, including wall segments that have been created via the Objects menu are parametric, meaning 
that they are defined by parameters that you can either edit interactively or adjust via the Object 
Attributes pane. 

Parametric objects may have their own representative icons in the Object Overview, whereas Model 
Bank objects (which cannot be edited) are represented as brown sphere icons. 

To edit a parametric object interactively: 

1. Right-click on a parametric object and select Edit from the popup menu 

2. Click on one of the objects editing handles and drag the handle to interactively modify the 
objects geometry. Note that some parametric objects may not support interactive editing, in 
which case no handles will be shown when you select Edit on the object. 

 
Parametric box in editing mode 

3. Click on the ground or floor to exit the object editing mode (some objects may also exit the 
object editing mode automatically if you move them) 

To edit a parametric object’s attributes directly: 

4. Select a parametric object 

5. Select the Attributes tab in the Selected Object pane 

6. Modify the values that you wish to change in the attributes table. If the value needs to be typed 
in rather than selected from a menu or dialog then hit 'enter' key after modifying the value, 
otherwise it will not be set. 
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Parametric box attributes 

7. Changes are reflected in the scene immediately after a value is modified 

4.13.1 Editing Image Surfaces 
Add local image to an Image Surface object: 

8. Drag an image from the local machine and release it on the image surface object. 

 
Drag image files from the local machine 

9. If the dropped image is a valid type it will be applied directly to the object. Supported image 
formats are JPEG, PNG and GIF. 

 
Image applied to image surface object 

Note that the image file will be uploaded to the server when the layout is saved. 
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Image surfaces support images with alpha channel. The alpha channel can be turned on/off by selecting 
the Transparent property in the Attributes panel. 

4.14 Showing scene as Wireframe 
The objects in the 3D scene can be shown as wireframe, where only the edges and connecting lines of 
the models are shown. 

To toggle wireframe: 

1. Select View > Show Wireframe 

4.15 Layout Printing, Snapshot and Room Configuration 

4.15.1 Printing the Virtual Layout 
The virtual layout can be printed directly to a printer at the maximum resolution of your screen, filling 
the entire page. The resulting printout may show more or less than you actually see in the 3D view, 
depending on the orientation of the paper as it creates a full-page image based on the location and 
direction of the view rather than the screen image itself. 

This differs from printing screenshots that screenshots are printed exactly as taken (an exact copy of the 
3D view), so this function will normally result in a higher-resolution image and will give more pleasing 
results when printing to large sheets of paper as the whole page is filled with the image. 

Always set the orientation of the paper using the page setup dialog.  

Note that the dialog windows shown by the Layout Tool will depend on the operating systems you are 
using, so the actual dialog window on a computer running Mac OSX will differ from the equivalent 
dialog window on a computer running Windows. 

To set up the page: 

1. Select File > Page Setup… 

2. Choose the required settings and confirm or reject your changes. 

To print the virtual layout: 

1. Select File > Print… or use the shortcut keys command-P 

2. Choose the required settings. To ensure correct results, do not select orientation using the print 
dialog (Use File > Page Setup… instead) 

3. Continue (typically, click on OK) or abort (typically, click on Cancel) 

4.15.2 Creating a Snapshot of the Virtual Layout 
Screenshots can be created by selecting File > Export 2D Graphic from the File menu.  

To create a snapshot: 

1. Select File > Export 2D Graphic from the File menu.  

2. This will prompt you with the following dialog. 
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The Snapshot button in the centre 

3. Select the appropriate options for the image to save. 

Screen: This will export the image using the resolution of the current screen. 

Current: This will export the image using the current size of the 3D view on the screen at 
the moment the dialog was opened. 

Other: This lets you export the image using a custom resolution. 

Format can be set to either JPEG or PNG. 

4. Press Save or Cancel to abort. Upon pressing save you will be prompted to choose a filename 
and a location to save the image. 

4.15.3 Controlling visibility of parts of the virtual room 
Note that this feature is provided to give access to elements of pre-modelled rooms imported from the 
Model Bank only. For rooms modelled within the Layout Tool using the Room Wizard or Wall groups, 
you can use the functionality for hiding and showing objects (see Toggling the visibility of objects). 

While working with a layout you may find that parts of the room obscure your view and that it would 
be convenient to temporarily hide them. For example, it is very often useful to temporarily hide the 
ceiling of a room in order to get a good overview of the layout and work with it from above. 

Toggling the visibility of parts of the room is done using the Room Configuration window. Note that 
this is purely a visual aid for controlling visibility so no changes are actually made to the room model 
itself that would affect other users or modify the design. 

What you can toggle depends on how the room model itself has been created. In some cases, you may 
not be able to toggle anything, whereas in others there may be many parts that can be toggled. In any 
case, this functionality only toggles parts of the room model and not the contents, which remain in 
place. 

To hide/show parts of the room: 

1. Press the Room Configuration button 

 
The Room Configuration Button to the far right on the Navigation Toolbar 

2. The Room Configuration window will appear: 
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Room Configuration window 

3. Toggle the visibility of parts of the room by selecting or deselecting the checkbox next to the 
named room part. In most cases rooms are organised hierarchically, in which case a handle is 
shown to the left of the check box. Clicking on the handle reveals/hides the next level of the 
room hierarchy. 

4.16 Generating an Inventory Report 
It is possible to generate a report with all the loaded models in a layout. This report can later be printed 
on paper or stored in html format. 

To generate an inventory report: 

1. Select Tools > Inventory Report 

2. A dialog with different options for what to include in the report will appear:  

 
If the position option is not selected then a column with the number of elements will be 
included to inform of the number of items of the same object that are added to the layout. 

3. Select the options that are wanted to include in the report. 

4. The Layout tool will now start to generate the report 

5. The report will appear and can then be viewed, saved or printed. 
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An inventory report 

4.16.1 Saving an Inventory Report to the local file system 
An inventory report and the images it uses can be exported to your local file system in HTML format. 

To save an inventory report to the local file system: 

1. Generate a report as described in Generating an Inventory Report 

2. Click on the Save… button 

3. A file dialog will appear, choose the desired location on the disk to put the report 

4.17 Tagging objects with Meta Data 
It is possible to associate meta data to 3D objects in the layout by assigning them Tags. A tag describes 
certain properties and aspects of the objects, as well as their context in relation to the room. These tags 
are used by the Verification Tool to perform automated testing to verify if objects in the layout are in 
accordance with guidelines.  

The tags that are available in Layout Tool consist of model tags that are associated directly with the 
model object from the Model Bank Tool. These tags are general tags that describe properties or type of 
the object, such as a chair or a desk. These tags are automatically assigned to any model that is added to 
the 3D scene. The other type of tags is context specific tags. The context tags contain tags that are 
specific to the layout you are working on. These typically describe domain specific knowledge or 
specific information in regards to the room or requirements. The context tags are specified in the 
Review Guidelines that are set for the Project. 

The available model tags are: 
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• chair – Any type of chair where a person can be seated 

• control – Any type of control 

• desk – Any type of desk 

• display – Display describes any surface that display information, such as a sign 

• input-device – Input devices such as a keyboard, mouse, keypad etc. 

• monitor – Monitor is an electronic visual display 

• sitting – Users will be sitting when using this equipment 

• standing – Users will be standing when using this equipment 

 

• ignore-tags - If this Tag is added to an object the objects tags will be ignored 

• z-is-up – Use this Tag for objects that are modelled with their natural up-axis along the z-axis 

Model tags should generally be assigned to the model objects directly in the Model Bank Tool. 
This is because they should remain the same for all layouts, and therefore if set once in the Model 
Bank Tool you do not have to add the tags to the object each time you add it to a layout. You do 
however have the ability to override the tags from the Model Bank locally, meaning for a specific 
object in the layout you can change the model tags for that object. This is however only locally, 
and only affects that single object.  

The ignore-tags tag is a special tag that is contradictory to the previous statement, in that it is in 
the list of model tags, but is only intended to be used in the local layout, to actively hide objects 
from automated tests.  

The associated tags for an object are managed through the Tags tab in the Selected Object panel: 
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Overview of the tagging functionality in the Tags tab of the Selected Object panel 

Holding the mouse over a tag in the user interface will display a more detailed explanation of the use of 
the tag. In the user interface there is no distinction between the model tags and the context tags. 

To add a tag to an object in the Selected Object Panel: 

1. Select the object 

2. Open the Tags tab in the Selected Objects panel 

3. Open the Add Tag dialog by pressing the “+” button in the  

4. Select the tag you want to add 

5. Close the dialog 

To add a tag to an object in the 3D view, Object Overview or menu: 

1. Select the object 

2. Right click on the object either in the 3D view or in the Object Overview or select Edit > Tags 
> Add Tag to Selection in the menu 

3. Select Add Tag and choose the desired tag from the sub menu 

To remove tag(s) from an object 

1. Select the object 

2. Open the Tags tab in the Selected Objects panel 

3. Select the tags to remove in the tag list 

4. Press the “-“ button to remove the tags 
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Updating tags for objects in the Layout: 

If you need to update the tags of objects in the Layout you have built to reflect changes done to the 
Model Bank this is possible. The Edit > Tags contains a sub menu that has several different ways to 
update the tags for objects in the current layout. These are: 

• Sync Tags for Selected Object: This will update the tags for only the selected object 

• Sync Tags for All of Selected Object Type: This will update the tags for all objects in the 
layout that are using the same model object as only the currently selected object 

• Sync Tags for Selection: This will update the tags for all objects currently selected 

• Sync Tags for All Types from Selection: This will update the tags for all objects in the 
layout that are using the same model object as the ones currently selected 

• Sync Tags for All: This will update the tags for all objects in the layout with no limitations 
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5 Using the Edit Tools 
The Edit Tools toolset is located above the 3D scene panel and provides functionality useful for editing 
and organising the contents of a layout. 

 
       1           2        3        4        5           6           7           8            9 

The Edit Tools toolset 

The buttons in the Edit Tools toolset have the following functions: 

1. Delete the currently selected objects from the scene 
2. Group selected objects 
3. Ungroup (split up into individual objects) a selected group 
4. Associates objects to each other to a parent-child association 
5. Disassociate the selected object from its parent in a parent-child association 
6. Align or distribute selected objects in the scene 
7. Toggle the snap-to-grid function 
8. Toggle the visibility of snap points 
9. Centre the view on the selected object 

5.1 Multiple Selection 
It is possible to select several objects simultaneously in order to perform actions on each object in the 
selection, such as moving them around together or duplicating them. Multiple-selection is also 
necessary in order to create groups. Multiple selection works for both the 3D view and the Object 
Overview. 

 
Multiple selection in action 

When multiple selection is on and you select objects, the previous selection is not lost. The selected 
objects will remain selected even when you release the command key.  

To remove an object from the multiple selected objects, simply select the object you wish to remove 
from the selection with multiple selection enabled.  
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If you select either the room or the floor of a parametric room the entire selection will be cleared. 
Similarly if you select a new object without the multiple selection key pressed, this will clear the 
currently multiple selected objects and only select that object. 

To toggle multiple selection mode: 

1. Press and hold the command key to enable multiple selection (CTRL on Windows) 

2. You can now select several objects in the scene by clicking on objects in the scene (see 
Selecting objects on selection of object). 

3. Release the command key to disable multiple selection  

5.2 Popup menu in 3D view 
Right clicking in the 3D view shows a popup menu at the mouse cursor with available actions that can 
be performed on the current selection. Most of the items in the menu are accessible either via the Menu, 
or the Edit Tools toolset, but provide a quicker way to access common commands from inside the 3D 
view.  

The popup menu dynamically adjusts the menu items depending on which objects are selected. This 
means that i.e. parametric objects will have some options available that a regular model object does not 
because they are not applicable. 

  
The 3D view popup menu is shown for a multiple selection (left) and for a parametric pyramid (right). 

5.3 Grouping objects together 
Selected objects can be grouped together so that they can be manipulated as a single object. 

You can click on any object in a group via the 3D view to select the group object if the group selection 
policy is set to highest. 

When a group is created, all of its member objects are rigidly linked to an object that represents the 
group, but has no visual representation of its own. 

There are three different ways of performing a group operation in the Layout Tool: 

1. Select the objects in the scene and press the Group Button in the Edit Tools toolset. 

2. Select the objects in the scene and use the shortcut keys command-G 

3. Select the objects in the scene and right click on any of the objects and choose Group from the 
popup or choose Edit > Group from the menu 

4. Select the objects in the scene tree and then select Group from the Object Overview popup 
menu (typically right-click in the Object Overview). 

When objects are grouped, an icon in will appear in the Scene-tree will appear above the grouped 
objects and give a visual representation of groups. 
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Visual representation of a group containing four objects 

5.3.1 Ungrouping grouped objects 
By “ungrouping”, we mean splitting a group of objects into individual objects (or groups of objects). 

There are three different ways of splitting a group into individual objects: 

1. Select the group in the scene and press the Ungroup button in the Edit Tools toolset 

2. Select the objects in the scene and use the shortcut keys command-U or command-shift-G 

3. Select the objects in the scene and right click on any of the objects and choose Ungroup from 
the popup or choose Edit > Ungroup from the menu 

4. Select the objects in the Scene Overview and then select the Ungroup menu item in the Object 
Overview popup menu (typically right-click in the Object Overview) 

5.4 Selection Policies 
The Selection Policy specifies what should happen when an object in a group is clicked on to select it.  

There are two different selection policies: highest (select the group itself) or lowest (select the object in 
the group). 

To switch between group selection policies, select desired policy from the sub-menu items under Edit > 
Selection Policy. You can also press the shortcut key 'Z' when in the 3D view to toggle selection 
policies. 

5.4.1 Selection Policy Highest: 
When this policy is used, the topmost node in the group hierarchy is selected. That means that all the 
nodes in the group are manipulated as a single object.  

This policy is default in the Layout Tool. 

To set the selection policy to highest: 

1. Select Edit > Selection Policy > Highest 

5.4.2 Selection Policy Lowest: 
When selection policy lowest is used, the group is opened so it is possible to access the individual 
objects contained in the group without ungrouping the group. 

Using the Group Selection lowest maintains the integrity of the group. 

To set the selection policy to lowest: 

1. Select Edit > Selection Policy > Lowest 

5.5 Rotation Policies 
The rotation policy specifies the behaviour when rotating multiple objects using multiple selection. The 
rotation of multiple objects can either be with one object as pivot point for the others, or each object 
can be rotated individually. 

To change rotation policy: 

1. Select from sub-menu items under Edit > Rotation Policy 
2. Select desired rotation policy 
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5.6 Toggling the visibility of objects 
In some cases it is desirable to hide objects in a layout instead of deleting them. For example to gain 
easier access to part of a scene that is being worked on or to store partial alternative layout 
configurations in a single layout file until a decision is made on which to keep. Objects that are hidden 
remain in the layout scene structure and are saved with the layout, enabling hidden objects to be 
revealed in future, however hidden objects are not listed in the room inventory report and are not 
exported to VRML or a published layout when it is displayed in the Verification Tool. 

Hiding and revealing objects are done via the Edit menu, the right-click pop-up menu in the Scene 
Overview panel, or by hitting the shortcut key 'H'. 

To hide a selected object or group of objects: 

1. Select the objects that are to be hidden in the scene overview or the 3D view 

2. Press the hide shortcut key 'H', or select Edit > Hide to hide the objects or select Hide from the 
pop-up menu after right-clicking in the scene or scene overview to select the Hide option 

3. The hidden objects are shown greyed out in the scene overview 

To reveal a hidden object or group of objects: 

1. Select the objects that are hidden in the scene overview (shown greyed out in the scene 
overview) 

2. Press the hide shortcut key 'H', or select Edit > Hide to hide the objects or select Hide from the 
pop-up menu after right-clicking in the scene or scene overview to select the Hide option 

5.7 Creating relationships between objects 
There are two different ways to define parent-child relationships between objects, either by using a 
weak or strong link. 

When linking objects together the child can be moved independently of the parent, but if you move the 
parent the child will move with it. 

A weak link is performed when object is put on to another object. The objects are automatically 
associated with a parent child relationship. When a weak link is performed the child will automatically 
be detached from its former parent when it is moved on to another object. 

When a strong link is performed, the objects are more tightly connected to each other. The child 
belongs to the parent no matter where the child is located in the scene. This feature can be useful for 
instance if we place a dustbin under a table and link it to the table. If we then move the table, the 
dustbin will move with it. This would not have been possible using a weak link.  

There are three ways of create a strong link between objects in the Layout Tool. Each of the three 
methods must follow the same procedure:  

1. The children must be selected first  

2. The Layout needs to be told that the selected objects should be linked.  

3. The parent must be selected. 

There are three alternative ways of creating a link: 

1. Select the children to be linked. Then press the shortcut keys command-L in the 3D view. 
Then select the object that should be parent to the selected objects. 

2. Select the children to be linked. Then press the Link button. Then select the object that should 
be the parent to the selected objects. 

3. Select the children to be linked. Then right click in the 3D view and select Link from the 
popup menu. Then select the object that should be the parent to the selected objects. 

4. Select the children to be linked. Then select Edit > Link from the menu. Then select the object 
that is wanted to be the parent. 
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5. Select the child objects in the Object Overview. Then select Link from the Object Overview 
popup menu. Complete the linking of objects, by selecting the parent in the scene or in the 
Scene Overview. 

5.7.1 Removing relationships between objects 
Unlinking is the process of removing a parent-child dependency. 

There are three alternative ways of unlinking a child object from its parent. 

1. Select linked object(s) then press the unlink shortcut key command-shift-L 

2. Select linked object(s) then press the Unlink button 

3. Select linked object(s) then right click on any of the objects in the 3D view and select Unlink 

4. Select linked object(s) then select Edit > Unlink 

5. Select linked object(s) in the Scene Overview then select Unlink from the Scene Overview 
popup menu 

5.8 Undoing changes 
It is possible to undo changes in the layout tool if an unwanted operation is performed.  

The text of the Edit > Undo menu item depends on the actions you perform. For example, if you move 
an object then the Undo text will change to Undo Move to reflect the last action you performed. 

To undo a change: 

1. Select Edit > Undo action or use the shortcut keys command-Z 

5.8.1 Redoing undone changes 
When an Edit > Undo command has been performed, the Edit > Redo menu item is enabled.  

Selecting Redo reverses the undo command.  

To redo an undone change:  

1. Select the Edit > Redo or use the shortcut keys command-Y or command-shift-Z 

5.9 Aligning selected objects to each other 
To align several selected objects with each other, two or more objects must be selected. 

1. Select two or more objects 

2. Press the Align/Distribute button or select Edit > Align from the menu 

 
The Align/Distribute Button. 

3. The Position Objects dialog appears. The dialog’s Align tab offers to align along the X, Y, or 
Z axis. If the Min value is chosen the selected objects will be positioned using the lowest 
value for the selected axis. If Max is chosen the highest value will be used. By selecting any of 
the options a visual illustration of the command will be shown. 
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The Position Objects dialog with the Align tab active 

4. Press the Align button to perform the select action, or close the Position Objects dialog to 
abort.  

5.10 Distributing selected objects along an axis 
To distribute several objects relative to each other, two or more objects must be selected. 

1. Select three or more objects. 

2. Press the Align/Distribute button or select Edit > Distribute from the menu 

 
The Align/Distribute Button. 

3. The Position Objects dialog will appear. The dialog’s Distribute tab offers three different 
distribution options, these are to either distribute along the X, Y, or Z axis. By selecting one of 
the options a visual illustration of the command is shown. 
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The Position Objects dialog with the Distribute tab active 

4. Press the Distribute button to perform the select action, or close the Position Objects dialog to 
abort. 

5.11 Copying and Pasting selected objects 
Selected objects can be copied and pasted into the current layout or into a layout in any project on the 
same CREATE server. 

To copy and paste objects within current layout: 

1. Select the objects that should be copied 

2. Select Edit > Copy or use the shortcut keys command-C 

3. Select Edit > Paste or use the shortcut keys command-V 

4. The selected objects will be pasted 

To copy and paste objects into another layout: 

1. Select the objects that should be copied 

2. Select Edit > Copy or use the shortcut keys command-C 

3. Select File > Open 

4. Select layout 

5. Select File > Paste or use the shortcut keys command-V 

6. The selected objects will be pasted 

The pasted objects initially appear in the same position in the layout as the original and are 
automatically selected to facilitate positioning. 

5.12 Duplicating selected objects 
Selected objects can be duplicated via the Edit menu or the Scene Overview popup menu. 

To duplicate objects using the Edit menu: 

1. Select the objects that should be duplicated 

2. Select Edit > Duplicate or use the shortcut keys command-D 
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3. The selected items will be duplicated. 

To duplicate objects using the Scene Overview: 

1. Select the objects to be duplicated. 

2. Select Duplicate from the Scene Overview pop-up menu. 

3. The selected objects will be duplicated. 

Duplicated objects initially appear in the same position in the layout as the original and are 
automatically selected to facilitate positioning. 

5.13 Deleting objects 
Deleting an object deletes the selected object and associated/linked children. For example, deleting a 
table with objects on it will result in the objects also being removed from the layout. If you do not want 
to delete associated/linked objects then you should use the Remove” function instead. 

To delete objects from a scene: 

1. Select the object(s) that you want to remove. 

2. Perform one of the following alternative operations to delete the selected objects: 

• Press the 'delete' key on the keyboard. 

• Press the Delete button in the Edit Tools toolset. 

• Right click on the object in the 3D view and select Delete from the popup menu 

• Select Edit > Delete 

• Select Delete from the Object Overview popup menu. 

5.14 Removing objects without deleting associated children 
As an alternative to the Delete function, the Remove function can be used to remove an object (or 
group) from a layout without deleting any associated/linked children. Any children that the removed 
object had will remain in the scene but be reassigned to the parent of the removed object. Thus, in the 
case of removing a group-object, the effect is the same as Ungroup. This function is especially useful if 
you want to use an Image Surface object temporarily to display a 2D plan on which you drop various 
3D objects. When you have finished using the Image Surface, you can remove it, and all of the objects 
that you dropped onto it will remain in place and belong to the object on which the Image Surface was 
originally placed (e.g. the floor). 

To remove an object from the layout without removing any associated children: 

1. Select the object(s) that you want to remove 

2. Perform one of the following alternative operations to remove the selected objects: 

• Right click on the object in the 3D view and select Remove from the popup menu 

• Select Edit > Remove 

• Select Remove from the Object Overview popup menu. 

5.15 Aligning camera to selection 
The Align to Selection function positions the camera so that it is placed perpendicular to the selection. 
This is especially useful when used in combination with the zoom to selection function if you want to 
fit and align a 2D surface, such as a control panel, to your view. 

To align the camera perpendicular to the current selection: 

1. Select Camera > Align to Selection, or use the shortcut keys command-alt-F 
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5.16 Centring camera on selection 
The current camera view of the 3D layout can be centred on the current selection. This is very useful 
for aligning the view with objects selected by name, in the Object Overview, or directly in the 3D view. 

If no objects are selected then the camera will centre on the room. 

To reposition the camera at the centre of the current selection: 

1. Press the Pan to Selection button in the Edit Tools toolset or select Camera > Pan to Selection, 
or use the shortcut keys command-shift-F 

 
      The Pan to Selection button 

5.17 Zooming camera to selection 
The Zoom to Selection function adjusts the view to fit the current selection into it. 

If nothing is selected then the room itself will be fitted into the view. 

To zoom the camera to fit the current selection into the current view: 

1. Select Camera > Zoom to Selection, or use the shortcut keys command-F or simply press 'F' in 
the 3D view  

5.18 Working with the Object Overview 
The Object Overview contains a scene tree that provides an overview of how objects are related to each 
other. The tree can also be used to perform actions on selected objects. 

 
The Scene overview  

Many of the features that are available when working directly with the scene in the 3D view are also 
available when working with the scene tree. When working with the Scene Overview, the same 
principles are used as when working directly in the 3D view, i.e. you should first select one or more 
objects and then performs an action on them. 

Items can be selected in the Scene Overview by clicking on them. 

The Scene Overview has an associated pop-up menu than can normally be accessed by right-clicking 
on a selected item in the scene tree. This menu provides convenient shortcuts to a number of commonly 
used actions. 
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The Scene overview popup menu  

The following actions are possible to perform via the scene tree: 

• Deletion of objects 

• Removal of objects 

• Linking of objects  

• Unlinking of objects 

• Grouping of objects 

• Ungrouping groups 

• Renaming objects 

• Duplicating objects 

• Toggling visibility while editing 

• Adding annotations 

• Editing annotations 

• Adding tags 

• Retrieving information about the selected model from the Model Bank 

5.19 Renaming objects 
Objects are automatically given names when you add them to a layout however you will often want to 
give items in the layout scene names that you have chosen yourself to make it easier for you to identify 
objects. 

To give an object a new name: 

1. Select an object in the scene, or in the scene tree. 

2. Access the 3D view popup menu or the scene tree popup menu by right clicking on the object 

3. Select Rename... 

4. Enter a new name for the selected object in the Object Rename dialog that appears 

 
The object rename input dialog 
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5. If the name is invalid or already taken by another object a notification is shown, and the user is 
prompted to enter another valid name. 

6. Press OK to set the new name or Cancel to abort.  

5.20 Snap to Grid 
When enabled, the global snap-to-grid function causes objects that are moved to automatically align 
with a global grid. This can make the positioning of objects easier in many cases. 

Adjustment of the grid by changing i.e. the spacing or colour is covered in Using the Visual Grid. 

To toggle snap-to-grid: 

1. Press the Snap to Grid button in the Edit Tools toolset, or select Edit > Snap To Grid in the 
menu or use the shortcut key 'C' when in the 3D view 

 
The Global Grid Toggle button 

To toggle the visibility of the grid: 

1. Select View > Show Grid from the menu or use the shortcut key 'G' when in the 3D view 
 
The visualisation of the grid will follow the selection as it is moved in the scene. This means 
that if the object is dragged onto another surface, the grid will align itself to that surface and 
adapt its visual size. 

There are three different grid types: 

1. Global grid is a universal grid that is shared amongst all objects in the Layout. By default this 
is the grid that will be active if snap-to-grid is enabled. This grid will be available for all 
objects, and the spacing will remain the same regardless of the size of the objects being moved 
and which surface the object is being dragged on. This type is quick and easy to use, but if you 
frequently need to adjust the grid size depending on which objects you are operating on, or 
because of the size of objects being moved, you should consider using one of the other two. 

 
The global grid used for positioning the desks on the floor 

2. Local grid gives you the ability to specify a grid that will be local to the object it is associated 
with, and will override the global grid. This enables you to specify more suited grid spacing 
for i.e. the desk, were you often place smaller objects that require more precise positioning, 
than what you typically need when placing the actual desks on the floor. By specifying local 
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grids you do not need to change the grid spacing when operating on the different objects as 
you do with the global grid. Note that the local grid is only used for objects being placed on 
the specific object the local grid was added to. There can only be one local grid associated 
with an object, but there is no limit to how many objects can have their own local grid. 

 
A local grid used for positioning objects on the desk 

3. Object grid differs from the local grid in that it modifies the grid spacing only for that object, 
regardless of what surface or object it is moved on. This enables you to further customize the 
spacing if there is a specific object that needs custom grid spacing, and you do not want to 
change any of the existing grid spacing’s (global or local grids). This type can also be 
customized so that it is always set to adapt to the size of the object being moved. See 
Automatically adapt Object Grid Distance. 

 
An object grid is used for specific grid spacing for the object being moved 

5.20.1 Configuring the Global Grid 
It is possible to configure the distance between grid rows and columns and change the colour of the 
global grid. 

The colour and grid distance values are stored with the layout, and the settings are restored each time a 
layout is opened. 

To access the Global Grid Options dialog: 

1. Select View > Grid Options… 



Release 4.2 (rev: 03/01/2024) 64 Layout Tool User Guide 

2. The Global Grid Options will appear. 

3. Make changes (see below for instructions). 

4. Click OK to apply the changes and close the dialog, or Cancel to ignore the changes.  

 
The Global Grid Options window 

To change the grid distance: 

1. Access the Global Grid Options window. 

2. Enter a new grid distance value (in metres). You can use the up/down buttons next to the value 
to increase/decrease it incrementally. 

To change grid colour: 

1. Access the Global Grid Options window. 

2. Press the Set Colour... button. 

3. A colour chooser will appear: 

 
The global grid colour chooser. 

4. Select a new colour. 

5. Press the OK button to set the grid colour, or Cancel to ignore the colour change. 

5.20.2 Configuring the Local Grid 
The local grid can be configured similarly to the global grid.  

To add local grid to an object: 

1. Select the object either in the 3D view or in the Object Overview 
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2. Access the Selected Object Panel  

3. Select the Snap Options tab 

 
A local grid used for positioning objects on the desk 

4. Toggle local grid on/off as shown in the picture 
5. If the local grid is enabled the configuration button will be enabled 
6. Pressing the configuration button will open up a dialog that enables configuration of the local 

grid. See Configuring the Global Grid for more information on how to configure the grid. 

5.20.3 Configuring the Object Grid 
To add object grid to an object: 

1. Select the object either in the 3D view or in the object overview 

2. Access the Selected Object Panel  

3. Select the Snap Options tab 

 
A local grid used for positioning objects on the desk 

4. The object grid is enabled by changing the value of Position Interval to anything other than 
0.0. This value is equivalent with the Grid Distance that is set for the global and local grid 
through the grid configuration dialog. 

To remove object grid from an object: 

1. Select the object either in the 3D view or in the object overview 
2. Access the Selected Object Panel 
3. Set the Position Interval to 0.0, this will remove the object grid from the object 
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5.20.4 Automatically adapt Object Grid Distance 
The object grid can be set to be automatically enabled and adapted for objects. If enabled this will 
enable object grid by default for all objects, and will adapt the grid distance to the dimensions of the 
object.  

If enabled the position interval of objects is automatically set to the largest of the X and Z dimensions 
of the object when it is added to the scene. Once an object has been added to a scene, you are free to 
manually change the automatically assigned position interval via the Snap Options panel. 

To toggle the auto snap feature: 

1. Select Edit > Snap Policy > Auto Set Object Snap Intervals 

5.20.5 Ignore Object Grid Distance 
It is possible to set the snap policy to temporarily ignore the object grid distances that have been set. 
This gives an easy way to suppress any object grids specified for any object, enabling the object to 
follow either the global or local grid temporarily. 

To toggle global ignore of object grid 

1. Select Edit > Snap Policy > Ignore Object Snap Intervals 

5.20.6 Object Rotation Snap Options 
If snap-to-grid is enabled rotation of objects will utilize a snapping function as well. By default the 
rotation value of the object will be rounded to closest rotation interval value when the object has been 
rotated. For example, a rotation interval of 45 degrees will cause an object to snap to 0, 45, 90, 135, 
180, etc. degrees when interactively rotated. 

 
The Snap Options panel, with position and rotation intervals set to 0. 

5.21 Snap points 
Some model bank objects may have snap points defined.  Snap points are typically used for modular 
furniture, for example, to define where modules should fit together. 

To toggle visibility of snap points in the layout: 

1. Press the Snap Points Visibility button in the Edit Tools toolset 

 
The Snap Points Visibility Toggle button 

To add an object with snap points to the scene and align it with another object with snap points: 

1. Add the object to the scene: 
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2. Drag the object close to the object that you want to snap it to, roughly in the location you want 

to place it relative to the existing object. If you have snap boxes visible make sure that the 
boxes intersect: 

 
3. Release the object and it will align itself with the other object, if the snap points of the too 

objects intersect: 

 

5.22 Locking an object’s location and orientation 
It is possible to lock and unlock an object’s position and rotation to prevent accidentally moving object 
in the 3D view.  

This can be done with the toggle buttons on the Selected Object panel. 
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The positioning and rotation locking mechanism   

Locked objects can still be moved or rotated by entering exact position, location values in the Selected 
Object panel. 

To toggle locking an object’s position to prevent it from being moved: 

1. Select the object for which you wish to lock the position. 

2. Select the Lock Position checkbox. 

3. Alternatively the shortcut key 'A' can be used in the 3D view to toggle position lock  

To toggle locking an object’s rotation to prevent it from being rotated: 

1. Select the object for which you wish to lock the rotation. 

2. Select the Lock Rotation checkbox. 

3. Alternatively the shortcut key 'S' can be used in the 3D view to toggle rotation lock 
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6 Annotations 
The designer can add annotations for specific objects in the scene or for the virtual layout. This enables 
the layout designer to associate information to specific virtual objects in the scene or the layout in 
general. These annotations are also available for the reviewer using Verification Tool, so they can be 
used to communicate information to the reviewer. 

6.1 Annotation User Interface Overview 
Selecting Window > Annotation Manager opens the Annotation Manager window.  

This window consists of two parts: 

1. The panel to the left holds a list of all current annotations for the current layout. 

2. The panel to the right holds all user interface elements necessary to edit a specific annotation.  

At the bottom right there is a button that navigates the view to the current selected target. This can aid 
the user to make sure that an annotation is added to the correct virtual object in the layout. 

 

6.2 Adding and removing annotations  
To create and edit an annotation: 

1. Open the annotation manager by selecting Window > Annotation Manager 

2. To create an annotation, press the “+” button to at the bottom left in the Annotation Manager 
window. An empty annotation is created and ready to be edited. If an object is selected in the 
scene, the currently created annotation is associated with the selected object, if no object is 
selected; the annotation is associated to the layout in general. 

 
3. Note that is possible to edit and modify the annotation directly in the table to the left, or to use 

the specific user interface elements to the right in the window. 
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To remove an annotation: 

1. Open the annotation manager by selecting Window > Annotation Manager 

2. Select the annotation that should be deleted 

3. Press the “-“ button  

 

6.3 Associating a target to an annotation 
It is possible to associate an annotation to a specific object in the virtual layout. By default there is no 
target for an annotation and it belongs to the virtual layout in general. 

To associate an annotation to an object in the virtual layout: 

1. Add annotations as described in Adding and removing annotations 

2. Select an object in the scene 

3. Press the Set Target button in the Annotation Manager, the annotation is now associated to the 
selected object  

To directly associate an annotation to an object in the virtual layout 

1. Select an object in the scene or scene-tree 

2. Right-click either in the 3D view or in the Object Overview and select Add Annotation. 

 
3. A window that only contains the edit panel part of the Annotation Manager window appears 

with the selected object set as a target.  
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Annotation editing panel 

 

6.4 Editing annotations 
There are two ways to edit an annotation, either directly through the Annotation Manager, as described 
in Adding and removing annotations or through the more convenient popup menu available in the 3D 
view and Object Overview. 

To edit an annotation through the popup menu 

1. Select an object in the scene or scene-tree 

2. Right-click either in the 3D view or in the Object Overview and select the sub-menu Edit 
Annotations, this will show a list of the annotations associated with the selected object 

 
3. Select the annotation to edit 

4. A window that only contains the edit panel part of the Annotation Manager window appears 
with the selected annotation.  
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Annotation editing panel 

6.4.1 Navigating to an annotation target 
When working with annotations, it is possible for the designer to navigate the view to a specific 
annotation target. Selecting the go to annotation target button can do this. 

To move the view to a specific annotation: 

7. Open the annotation window by selecting Window > Annotation Manager, or open 
the specific annotation for edit through the popup menu described in Editing 
annotations 

8. Press the Go to Target button at the bottom right in the edit panel: 

 
9. The view is moved to the annotation target 

6.5 Set annotation target 
The Set Target button is used to set or change the target for an annotation. It is used to associate an 
annotation with a specific 3D object in the scene. When the button is pressed, the annotation is 
associated with the last selected 3D object in the scene. If no target is selected, the annotation will be 
associated to the layout. 

 
                        Set Target Button 

6.6 Show Annotations 
It is possible to visualise all the currently added annotations in the scene. When showing annotations 
the title of the annotations is visualised as 3D text in the scene. If the visualised annotation has an 
associated target, there is a connecting line between the text and the target. 
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Visualisation of an annotation 

To show/hide annotations: 

1. Select View > Show Annotations 
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Using the Manikins Tools 

The Manikin Tools enable you position virtual humans in the layout to test lines of sight, reach, access, 
and so forth. There is normally a variety of manikins available from the server that can be used to test 
the layout, including standing and sitting manikins of various heights. 

 
The Manikin Tool toolset 

The Manikin Tools toolset consists of Add Manikin and Remove Manikin buttons to the left, the 
Manikin Selector controls in the middle and the Manikin Control Buttons to the right. 

The Manikin Control Buttons provide access to Go To, Reach, Reach Distance, View, View Cone, and 
View Cone Options functions. 

6.7 Inserting a manikin into a Virtual Layout 
The first step when working with a manikin is to add it to the virtual layout. Manikins can be added to a 
layout by pressing the Add Manikin Button, located to the far left of the Manikins Tool toolset. 

Once a manikin has been added to the layout, the Manikin Selector and the Manikin Control Buttons 
(Reach, View and View Cone Buttons) are activated in the Manikin Tool toolset. 

To add a manikin to the virtual layout: 

1. Press the Add Manikin button in the Manikin toolbar 

2. The Manikin Chooser window appears: 

 
The Manikin Chooser window 

3. Select the manikin you want to use from the drop-down menu. A thumbnail image of the 
selected manikin is shown below the menu as well as some information about the manikin. 

4. Press OK to add the manikin to the virtual layout, or Cancel to abort the operation 

5. The Manikin Chooser window will close. 

6. With the left mouse button, click the location in the layout where you want the manikin to be 
positioned 

7. Repeat this procedure to add more manikins to the layout 

6.8 Selecting a manikin in a layout 
If the virtual layout contains more the one manikin, you can select the manikin that you want to use 
using the Manikin Selector in the Manikin Tools toolset. The Manikin Selector consists of a drop-down 
menu that lists all manikins in the layout and previous and next buttons that can be used to cycle 
between manikins. 

The current manikin is always indicated by a red cone that points down at its head. 
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To select a manikin using the Manikin Selector drop-down menu: 

1. Click on the Manikin Selector drop-down menu with the left mouse button 

2. Select the manikin that you want to select from the manikins listed in the menu by clicking on 
it with the left mouse button 

3. The selected manikin will have a red cone over its head to indicate that it is selected: 

 
A selected manikin (one of several manikins in the layout) with the Manikin Selector menu shown  

To select a manikin using the Manikin Selector cycle buttons: 

1. Press the Previous or Next buttons on either side of the drop-down menu in the Manikin 
Selector to select the previous or next manikin in the list 

2. The Manikin Selector menu is updated to show the name of the selected manikin and the 
selected manikin is highlighted 

To select a manikin using the 3D view or Object Overview: 

1. Select the manikin in the scene or in the scene-tree 

 
The Manikin Chooser window 

2. The Manikin Selector menu is updated to show the name of the selected manikin and the 
selected manikin is highlighted 

6.9 Positioning a manikin 
Manikins can be freely positioned in the virtual layout. You can change both the location and direction 
of a manikin. 

Manikins are always located in an upright position. 

To position the current manikin: 
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1. Use the left mouse button to click on the location that you want to move the manikin to. For 
standing manikins, this is the location of the bottom of their feet, whereas for sitting manikins 
it is normally the point you want the manikin to sit on. This can vary depending on how the 
manikin has been designed. 

2. To change the direction that the manikin’s body faces in, switch to rotation mode and rotate by 
dragging the mouse. See Rotating objects  

6.10 Visualising a manikin’s field of view and line of sight 
The View Cone function enables you to display a view cone for a manikin, indicating the field of view 
and line of sight. A transparent white cone depicts the field of view and a green line indicates the direct 
line of sight. If the line of sight is broken by an object or surface then it turns red from the point at 
which the line of sight is broken. 

A View Cone Properties window can be accessed that enables you to fine-tune the view cone to suit 
your requirements. 

Each manikin you add to a layout has an independent set of view cone properties, so adjustments that 
you make to a manikin’s view cone affect that manikin only.  

 
The Manikin Control Buttons — View Cone Button selected 

To see a manikin’s view cone: 

1. Select a manikin 

2. Press the View Cone Button in the Manikin Tools toolset to turn on the view cone 
visualisation 

3. Press the View Cone Button again to turn off the view cone visualisation 

 
A manikin with view cone visualisation turned on 

To modify the view cone settings: 

1. Select a manikin and turn on its view cone 

2. Press the View Cone Options button next to the View Cone Button in the Manikin Tools 
toolset 

3. The View Cone Properties dialog window will appear: 
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The View Cone Properties dialog window 

4. Adjust the values as indicated in the diagrams by either directly entering a value or using the 
increment/decrement buttons. The buttons adjust the value by 5-degree intervals 

5. Press Dismiss/OK to close the dialog window 

6.11 Viewing a manikin’s reach envelope 
The reach envelope visualisation function enables you to see the reach envelope for a manikin. It 
indicates the maximum distance a manikin can reach. 

 
The Manikin Control Buttons – Reach Button selected 

To see a manikin’s reach envelope: 

1. Select a manikin 

2. Press the Reach Button in the Manikin Tools toolset to turn on the reach envelope 
visualisation 

3. The button to the right of the Reach button is the Reach Distance button, which toggles a 
visualisation that depicts the actual distance of the manikins reach in units. This is only 
enabled when the reach envelope has been toggled on. 

4. Press the Reach Button again to turn off the reach envelope visualisation 
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The selected manikin with reach envelope visualisation turned on 

6.12 Seeing through a manikin’s eyes  
It is often useful to be able to see the virtual layout through the eyes of the manikin. By selecting the 
manikin view function from the Manikin Control buttons, you can switch your view location so it 
follows the direction line of sight (as configured using the view cone properties – See Visualising a 
manikin’s field of view and line of sight) from the location of the manikin’s eyes. 

 
The Manikin Control Buttons – View Button selected 

To see the layout through a manikin’s eyes: 

1. Select a manikin 

2. Press the View Button in the Manikin Tools toolset to switch view location 

3. To turn the manikin while looking through its eyes, click and hold either the left or right 
mouse button down, while moving the mouse cursor in the direction the manikin should turn. 
The further you drag the mouse to either side from the point you originally clicked in the 3D 
view, the faster the manikin will turn. Release the mouse button, or move the mouse cursor to 
the point you first clicked to stop the manikin from rotating. 

4. Press the View Button again to revert to your previous view location 

6.13 Removing a manikin from a Virtual Layout 
When a manikin is no longer needed, it can be removed from the layout by selecting it and pressing the 
Remove Manikin Button, located to the far left of the Manikins Tool toolset, next to the Add Manikin 
Button. Manikins can also be removed using the same method for deleting or removing other objects. 
See Deleting objects 

Removing manikin from virtual layout: 

1. Select the manikin to be removed  
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2. Press the Remove Manikin Button in the Manikin Tools toolset or use one of the delete 
methods described in Deleting objects 
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7 Using the Measurement Tools 
The Measurement Tools enable you to verify the virtual layout against standards and guidelines where 
measurements of various kinds need to be taken. 

The Measurement Tools toolset includes a Distance, Perpendicular Distance, Angle, Label Size, View 
Angle and Volume tools. 

Only one measurement tool can be active at any time, but multiple measurements can be displayed 
simultaneously for each tool. 

Selecting a tool enables it and will also switch the navigation mode to picking. Deselecting a tool turns 
it off and disables interaction with any existing measurements of that tool type. 

When a tool is selected, “+” and “–“ buttons can be used to add and remove measurements. A drop-
down menu with previous and next buttons enables you to select a measurement to adjust it if you are 
working with more than one measurement. If a measurement has been completed (e.g. a distance has 
been measured) then the active measurement is highlighted to help you identify which measurement is 
active when more than one measurement has been created. 

When you add a measurement, picking is enabled and you can perform the measurement by clicking in 
the model. See the sections about the individual measurement tools for exact details on the mouse 
interaction possibilities available for each tool. 

When working with measurements you will typically be in picking mode. If you need to move to a new 
position before continuing or adapting measurements, a quick way to switch between navigation modes 
can be to use the shortcut key 'shift'. This enables you to temporarily toggle between movement and 
picking.  

Note that all measurements are in relation to surfaces in the model, including manikins added to it. You 
cannot measure the distance between, say, the ground and an arbitrary location in the air. 

The button to the far left in the measurement toolbar will remove all measurements of all types placed 
by the user. Note that this is not undoable. 

 
The Measurement Tool toolset with Distance, Perpendicular Distance, Angle, Label Size, View Angle, 
and Volume tool buttons. The button to the far left removes all measurements that have been created. 

7.1 Measuring Distances 
The Distance Tool and the Perpendicular Distance Tool in the Measurement Tool toolset are used to 
measure the distance between two surfaces. The Distance Tool displays the distance between two 
arbitrary points, while the Perpendicular Distance Tool displays the perpendicular distance from a point 
on a surface to the first surface hit. The Perpendicular Distance Tool is useful for measuring the 
distance between the floor and the bottom of a desktop or between two facing walls, for example. 

 
The Measurement Tool toolset with Distance Tool enabled 

 

 
The Measurement Tool toolset with Perpendicular Distance Tool enabled 
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To measure arbitrary distances between surfaces: 

1. Activate the Distance Tool in the Measurement Toolset by pressing the Distance Tool button 

2. Use the left mouse button to click in the virtual layout on the point from which you wish to 
measure 

3. Use the left mouse button to click again in the virtual layout at the point to which you want to 
measure from the previously clicked point 

4. A measurement in the form of an elastic ruler will appear showing the distance in metres 
between the two points: 

 
The Distance Tool ruler with distance shown 

5. To adjust the ruler, pick and drag at a new location with the left mouse button. The closest 
measurement point will then move to the new point updating the ruler. The end of the ruler 
will follow the surface that the mouse is pointing at as you drag. 

6. To move the ruler to a new location, repeat from step 2 (temporarily deselect the pick button, 
or hold down the 'shift' key, to navigate, if necessary) 

7. To add a new measurement, press the plus button in the measurement toolbar and proceed 
from point 2 as before to work with the new measurement. 

8. You can add as many measurements as you like. Use the drop-down menu to select the 
measurement you want to work with or use the previous and next buttons to cycle through 
measurements. The currently active measurement will be highlighted. 

9. To remove a measurement, press the minus button while the measurement is active. 

To measure perpendicular distance from a point on a surface to the first surface hit: 

1. Activate the Perpendicular Distance Tool in the Measurement Toolset by pressing the 
Perpendicular Distance Tool button 

2. Use the left mouse button to click in the virtual layout on the point from which you wish to 
measure 

10. The perpendicular distance from the point clicked to the first surface hit is shown, similar to a 
distance measurement created using the Distance Tool. If nothing appears then there may be 
no surfaces between the point and the out boundary of the layout, so click elsewhere to try 
again. The distance in meters is shown: 
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The Perpendicular Distance Tool ruler with distance shown 

3. To add a new measurement, press the plus button in the measurement toolbar and proceed 
from point 2 as before to work with the new measurement. 

4. You can add as many measurements as you like. Use the drop-down menu to select the 
measurement you want to work with or use the previous and next buttons to cycle through 
measurements. The currently active measurement will be highlighted. 

5. To remove a measurement, press the minus button while the measurement is active. 

7.2 Measuring angles 
The Angle Tool is used to measure angles between locations and is similar to the Distance Tool to 
operate except that there are three points rather than two to take into account.  

Once three locations have been selected, a visualisation of the angle between the points, and a label 
indicating the size of the angle, is displayed. The points can then be adjusted at will. 

 
The Measurement Tool toolset with Angle Tool enabled 

To measure the angle between three points: 

1. Activate the Angle Tool in the Measurement Toolset by pressing the Angle Tool button 

2. Use the left mouse button to click on three locations in the model. The first location should be 
the first end point, the second is the point at which the angle should be measured, and third 
location is the final end point. 

3. A visual representation of the angle between the first and last points at the second point will 
appear with the size of the angle shown in a label. 

4. To move one of the points in the measurement pick a new point in the virtual layout with the 
left mouse button. The closest measurement point will then move to the new point. 

5. Repeat from step 2 to measure a different angle (temporarily deselect the pick button, or hold 
down the 'shift' key, to navigate, if necessary) 

6. To add a new measurement, press the plus button in the measurement toolbar and proceed 
from point 2 as before to work with the new ruler. 

7. You can add as many measurements as you like. Use the drop-down menu to select the 
measurement you want to work with or use the previous and next buttons to cycle through 
measurements. The currently active measurement will be highlighted. 

8. To remove a measurement, press the minus button while the measurement is active. 
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An angle measured using the Angle Tool. 

7.3 Visualising legible distance and area for text labels 
The Label Size Tool enables you to measure the distance within which text labels in a room are legible. 
This measurement tools indicates the height of the text, which you measure, and the distance from the 
measurement point within which the text is legible. This distance is visualised as a sphere that encloses 
the legibility area. While this sphere can help you to test whether text is large enough to be read at a 
certain distance, it does not indicate visibility. You can check visibility by navigating in the model, 
using the manikin tools, and/or using the View Angle Tool. 

 
The Measurement Tool toolset with Label Size Tool enabled 

To visualise the maximum distance within text of a measured height is legible: 

1. Activate the Label Size Tool in the Measurement Toolset by pressing the Label Size Tool 
button 

2. Click on the lowest point of the character of text in a label with the left mouse 

3. Click on the highest point of the character of text in the label with the left mouse button 

 
The Label Size Tool in action – the user has clicked at the bottom and top of the first digit in the 

label 

4. A rectangular area will appear highlighting the space between the two points, and a sphere 
appears indicating the area within which text of the height measured is normally legible. You 
may need to move away from the location where you made the measurement in order to see 
the sphere: 
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A Label Size Tool measurement showing the area (a 5.1m radius from the text) within which a 

label with text of height 23.75mm can be read. Note that the sphere indicates distance and not the 
visibility 

5.  The character height is displayed together with the maximum reading distance for this 
character. 

6. To adjust the height, click and drag with the left button near the end of the label you wish to 
adjust 

7. To move the measurement entirely, pick two new points using the left mouse button 

8. To add a new measurement, press the plus button in the measurement toolbar and proceed 
from point 2 as before to work with the new measurement. 

9. You can add as many measurements as you like. Use the drop-down menu to select the 
measurement you want to work with or use the previous and next buttons to cycle through 
measurements. The currently active measurement will be highlighted. 

10. To remove a measurement, press the minus button while the measurement is active. 

7.4 Visualising the area within which a location can be seen 
The View Angle Tool enables you to determine whether a location in a layout can be seen, providing a 
visual representation of the viewing angle for the location you select. This is particularly relevant for 
checking the extent of the area in which it is possible to see a sign (text label) or indicator and is 
typically used in combination with the manikin tools and/or in addition to the Label Size Tool. 

 
The Measurement Tool toolset with View Angle Tool enabled 

To visualise the viewing area for a location: 

1. Activate the View Angle Tool in the Measurement Toolset by pressing the View Angle Tool 
button 

2. Use the left mouse button to click in the virtual layout at the point from which you wish to 
measure 

3. A visualisation cone appears for the selected point. You may need to navigate to a new 
position in order to get a better view of the extent of the visualisation (temporarily deselect the 
pick button, or hold down the 'shift' key, to navigate, if necessary): 
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A View Angle Tool measurement seen from above 

4. To move the measurement point, pick a new point in the virtual layout with the left mouse 
button. 

5. To add a new measurement, press the plus button in the measurement toolbar and proceed 
from point 2 as before to work with the new measurement. 

6. You can add as many measurements as you like. Use the drop-down menu to select the 
measurement you want to work with or use the previous and next buttons to cycle through 
measurements. The currently active measurement will be highlighted. 

7. You can configure the viewing angle by clicking on the Viewing Angle Options button that 
appears next to the tools selector when this tool is active. 

8. To remove a measurement, press the minus button while the measurement is active. 

7.5 Measuring rectangular volumes 
The Rectangular Volume Tool enables you to measure volumes and distances.  

Once three locations have been selected, a visualisation of the angle between the points, and a label 
indicating the size of the angle, is displayed. The points can then be adjusted at will. 

 
The Measurement Tool toolset with Rectangular Volume Tool enabled 

To measure the rectangular volume: 

1. Activate the Rectangular Volume Tool in the Measurement Toolset by pressing the Volume 
Tool button 

2. Use the left mouse button to click on two locations in the model. These two points represents 
the lower and upper points in the volume, excluding height. Alternatively the mouse can be 
pressed and dragged, showing a visual rectangle as you drag the mouse, where the first point 
pressed, and the point when the mouse is released represents the lower and upper points of the 
volume. The height is always initialized default to 1 meter. 

3. A visual representation of the rectangular volume will be shown. The visualisation consists of 
a rectangular box representing the volume, with the distances for each axis’ depicted.  

4. There are three spheres in the lower corners that can be dragged to resize either the width or 
the depth of the volume.  
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5. There is one sphere on the top of the volume that can be dragged to increase or decrease the 
height of the volume. 

6. To move the volume around in the Layout press anywhere on the volume visualisation (except 
the sphere) and simply drag the volume around. 

7. To rotate the volume switch to rotate mode (see Rotating objects), and drag anywhere on the 
volume to rotate. 

8. To add a new measurement, press the plus button in the measurement toolbar and proceed 
from point 2 as before to work with the new volume. 

9. You can add as many measurements as you like. Use the drop-down menu to select the 
measurement you want to work with or use the previous and next buttons to cycle through 
measurements. The currently active measurement will be highlighted. 

10. To remove a measurement, press the minus button while the measurement is active. 

 
A volume measured using the Rectangular Volume Tool. 
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8 Plan View 
A plan view of the Layout can be created using different styles. The types can be customized by 
changing both the projection and the position and orientation of the view, as well as other properties 
that dictate how the 3D objects in the layout are drawn. 

 
Plan view of a room in a layout 

To display a plan view of a layout: 

1. Position the camera at a viewpoint with an overview of the whole 3D scene, or the parts you 
wish a view of. There are two ways to do this: 

a. Select one of the system viewpoints, i.e. Top (see Viewpoints) and select Camera > 
Reset Current Viewpoint. Optionally adjust position by zooming in/out if necessary. 

b. Manually position the camera at the location 

Pan mode navigation is very suited for navigating when taking a plan view, because it 
prevents you from accidently changing the orientation of the camera (see Using the Pan 
Navigation). 

2. Optional: Turn off perspective projection by deselecting Camera > Perspective (see Changing 
Perspective Projection) 

3. Optional: A special rendering of the parametric wall groups can be turned on, that will show 
the distances of each wall as well as visualising the outline of the walls. Note this is intended 
for viewing the wall group top-down, meaning when viewed i.e. in front it will not look 
correct. To enable this: 

a. Select the Ground object in the Object Overview. 
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b. Enable selection dimensions by selecting View > Show Selection Dimensions 

c. Parametric wall groups will now be rendered specially 

 
d. To remove the effect either turn of selection dimensions or deselect the Ground 

object 

4. Optional: Turn on wireframe mode to only visualise the edges of the 3D objects by selecting 
View > Show Wireframe (see Showing scene as Wireframe) 

5. Optional: Turn on the distance grid by selecting View > Show Grid (see Using the Visual 
Grid) 

6. To save the plan view see Creating a snapshot of the Virtual Layout 

7. If you wish to use the same camera position so that you can take similar snapshots of the 
layout during future iterations it can be a good idea to save the current location of the camera 
in a custom viewpoint (see Viewpoints for instructions). This enables you to reuse the exact 
same camera positioning later 

8. When you are finished just reverse the features optional steps you performed 
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9 Menus 

9.1 File Menu 

 
The File menu provides functionality for opening and saving layouts. The most used menu items have 
keyboard shortcuts (shown to the right of the menu items above). 

New... Creates a new Layout (see Creating a New Layout) 

Open… Opens an existing layout (see Opening an Existing Layout) 

Save Saves the layout the designer is currently working with (see 
Saving a layout) 

Save as... Saves the layout with a new layout name (see Saving a layout 
with a new name). 

Revert... Revert any changes made since the layout was last saved or 
opened 

Release Lock… Make the current layout saveable for the next user opening it (see 
Locking) 

Publish... Enables this layout for verification (see Publishing a Layout) 

Revisions... Enabling viewing of different versions for this layout (see 
Accessing earlier revisions of a layout) 

Import Layout… Imports a layout package from the local file system (see Importing 
a layout package) 

Export COLLADA... Exports the current layout to the local file system (see Exporting a 
layout to COLLADA format) 

Export ISO VRML... Exports the current layout to the local file system (see Exporting a 
Layout to ISO VRML97 format) 

Export Layout… Exports a layout package to the local file system (see Exporting a 
Layout) 

Export 2D Graphic… Exports a screen shot of the 3D view from the current viewpoint 
(see Creating a Snapshot of the Virtual Layout)  
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Page Setup… Is used to set the page orientation and paper size (see Printing the 
Virtual Layout)  

Print… is used to print the currently displayed layout (see Printing the 
Virtual Layout) 

Exit is used to quit the Layout Tool. If you choose this menu item then 
you will be requested to confirm that you want to quit. 
If you are using Mac OS X then a Quit menu item is located in the 
application menu ("Layout Tool"). 

9.2 Edit Menu 

 
The edit menu consists of tools for helping editing the layout scene, and for setting password and 
preferences. 

Undo is used to undo the last action (see Undoing changes) 

Redo is used to redo the last action (see Redoing undone changes) 

Copy is used to copy the selected object(s) (see Copying and Pasting 
selected objects) 

Paste is used to paste the copied object(s) (see Copying and Pasting 
selected objects) 

Duplicate is used to duplicate the selected object(s) (see Duplicating 
selected objects) 

Delete is used to delete the selected object(s), including associated/linked 
children, from the layout (see Deleting objects) 

Remove is used to remove the selected object(s) from the layout (see 
Removing objects without deleting associated children). 

Rotation Policy is used to select the rotation policy when operating on multiple 
objects (see Rotation Policies) 
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Selection Policy is used to select the group selection policy (see Selection Policies) 

Hide is used to toggle the visibility of objects (see Toggling the 
visibility of objects) 

Group is used to group objects together (see Grouping objects together 
(grouping)) 

Ungroup  is used to split a group into single objects (see Ungrouping 
grouped objects) 

Link is used to link objects together in a parent-child relationship (see 
Creating relationships between objects) 

Unlink is used to break the parent-child dependency (see Removing 
relationships between objects) 

Align… is used to align the currently selected objects. A dialog box is 
shown in which the align options can be configured (see Aligning 
selected objects to each other) 

Distribute… is used to evenly distribute the currently selected objects. A dialog 
box is shown in which the distribution options can be configured 
(see Distributing selected objects along an axis) 

Snap to Grid is used to enable the snap to grid function (see Snap to Grid) 

Snap Policy Ignore Object Snap Intervals enforces the global grid settings, 
overriding any object-level snap settings (see Ignore Object Grid 
Distance), while Auto Set Object Snap Intervals automatically 
sets a local snap distance setting when an object is introduced to 
the scene (see Automatically adapt Object Grid Distance) 

Models is used to update models to the latest version found in the Model 
Bank for the selected objects (see Adding an object to the scene) 

Tags is used to add tags, or synchronize tags with the Model Bank for 
the selected objects (see Tagging objects with Meta Data) 

Set Password... is used to change the password (see Changing Your Password) 

Preferences… is used to configure HVRC CREATE (see Preferences Window) 
If you are using Mac OS X then this menu item is located in the 
application menu ("Layout Tool"). 
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9.3 View Menu 

 
The View menu is used to modify User interface elements or bring up information from the user or 
layout.  

Refresh Catalog is used to refresh the Model Bank view (in case changes have 
been made to the project configuration on the server and new 
categories have become available) 

Small Catalog Icons                           is used when small model bank model icons is wanted (see 
Customising the icon view) 

Large Catalog Icons                           is used when large model bank model icons is wanted (see 
Customising the icon view) 

Catalog Icon Labels is used when it is wanted to draw the model name as text on top of 
model bank model icon (see Customising the icon view) 

Show Editors is used to show/hide the right side editor panels 

Show Wireframe is used to show wireframe rendering of the layout (see Showing 
scene as Wireframe) 

Selection Dimensions is used to show/hide the dimensions of the selected object (see 
Selecting objects) 

Show Background is used to toggle between a user-defined background colour for 
the 3D view and a plain white background (see Setting the 
Background Colour) 

Set Background Colour… is used to set the user-defined background colour for the 3D view 
(see Setting the Background Colour)  

Show Grid is used to toggle a visual grid (see Using the Visual Grid) 

Grid Options… is used to configure the visual grid (see Configuring the Global 
Grid) 

Show Annotations is used to show/hide the visualisation of the annotations (see 
Show Annotations) 

Show Snap-boxes is used to show/hide the visualisation of the snap-boxes (see Snap 
points) 

Show Compass is used to show/hide the virtual compass (see Using the Virtual 
Compass) 
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Show Camera Pivot Point (Orbit) is used to show/hide the pivot point when using orbit mode (see 
Using the Orbit Navigation) 

Default Lighting is used to enable/disable default lighting in the 3D scene. Turn 
this off if your scene is lit by objects from the Model Bank or by 
lights in the room itself 

9.4 Camera Menu 

 
The Camera menu consists of features for aiding navigation as well as management of viewpoints and 
other camera related properties such as perspective projection and field of view. 

Zoom To Selection  is used to fit the view to the currently selected objects (see 
Zooming camera to selection) 

Pan To Selection is used to centre the camera over the currently selected objects 
(see Centring camera on selection). 

Align to Selection is used to align the camera to the current selected objects (see 
Aligning camera to selection). 

Viewpoints is used to select which viewpoint should be active (see 
Viewpoints) 

Next Viewpoint is used to switch to the next viewpoint in the viewpoint list (see 
Viewpoints) 

Previous Viewpoint is used to switch to the previous viewpoint in the viewpoint list 
(see Viewpoints) 

Manage Viewpoints is used to add new viewpoints or remove any user created 
viewpoints (see Viewpoints) 

Reset Current Viewpoint is used to reset the current viewpoint back to the position and 
orientation it had when the layout was opened (see Viewpoints) 

Perspective is used to change perspective projection of the camera between 
perspective and orthographic (see Changing Perspective 
Projection) 

Fly is used to select Fly mode (see Using the Fly Navigation) 

Orbit is used to select Orbit mode (see Using the Orbit Navigation) 

Pan is used to select Pan mode (see Using the Pan Navigation) 
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Travel Speed… is used to change the movement speed when using Fly mode (see 
Using the Fly Navigation) 

Straighten is used to level the camera relative to the ground (see Using 
Straighten) 

Seek is used to move the view closer to a point clicked on in the scene 
(see Using the Seek Button) 

Field of View… is used to change the field of view of the camera (see Changing 
the Field of View) 

9.5 Objects Menu 

 
The Objects menu contains controls for working with objects and controls for adding objects to the 3D 
scene. The available sets of objects that can be created depend on the Layout Tool configuration used 
and any additional plug-ins that might be installed. The sets for the default configuration are included 
in the list below. 

Select is used to toggle selection of object using the mouse. If enabled 
then you can click on objects to select them in the 3D scene (see 
Using the Pick Mode) 

Rotate is used to specify that when dragging (with the mouse) the current 
selection, selected object(s) should rotate (see Using the Rotate 
Mode) 

Translate is used to specify that when dragging (with the mouse) the current 
selection, selected object(s) should move 

Primitives > [object list] is used to create primitive parametric objects such as cubes, cones, 
spheres 

Equipment > [object list] is used to add parametric objects that represent configurable 
components such as labels and panels 

Architectural > [objects list] is used to create architectural objects such as walls and windows 

9.6 Tools Menu 

 
The Tools menu is used to access features that support working with a scene but do not change the 
scene itself. 

Inventory Report is used to create an inventory report for all objects loaded in scene 
(see Generating an Inventory Report) 

Reviewer Report is used to view a reviewer report (see Viewing Reviewer Reports) 
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Design Guidelines is used to access Design Guidelines (see Browsing Design 
Guidelines) 

9.7 Window Menu 

 
The Window menu provides access to layout and project windows. 

Layout Info is used to view information about the currently displayed layout 
(see Viewing information about a project or layout) 

Project Details is used to view project information (see Viewing information 
about the project) 

Project Messages is used to communicate back and forth in the project or design 
(see Communicating with other project team members) 

Annotation Manager is used to edit or add annotations for this layout (see Annotations) 

9.8 Help Menu 

 

The Help menu provides access to copyright information about this software and to online help. 

About HVRC CREATE… is used to display copyright information about the CREATE tool 
suite 

About Layout Tool… Display technical information about this tool. This also provides 
access to the log file. 
If you are using Mac OS X then this menu item is located in the 
application menu ("Layout Tool") 

Check for Update is used to check if the latest version of this tool is being used 

Layout Tool Help is used to access the online user guide for the Layout Tool 
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10 Configuration  

10.1 The Preferences Window 
 

 
The Preferences Window 

The first time you use one of the CREATE tools you will normally be presented with a wizard that 
assists you in setting the configuration options that you need to get started using HVRC CREATE. 
Subsequently, you can adjust your personal configuration via the options in the Preferences Window. 

The Preferences Window can be accessed from the main menu bar's Edit > Preferences… menu item. 
The keyboard shortcut to open the Preferences Window is ctrl-comma (or command-comma). 

Changes to preferences are global and therefore affect all CREATE tools that you use, however they 
are also personal and will not affect any other users of CREATE that share a computer as long as you 
are not sharing a computer user account. 

There are four sets of preferences in the Preferences Window, the most important of which is the 
“General” set, which is used to enter the address of the CREATE server that will be used. The 
individual sets and the options they contain are described in the subsections below. 

The Preferences Window has three buttons: 

• OK is used to update the preferences and close the window 

• Apply is used to set the update the preferences but not close the window 

• Cancel is used to dismiss the window without making any changes 

Clicking Apply followed by Cancel is equivalent to clicking OK. 

A configuration file containing your preferences is created in your home directory and will be applied 
the next time you run a CREATE tool. 

Closing the window by clicking on the close box (top right of the window) is equivalent to clicking on 
the Cancel button. Hitting the escape key is also equivalent to clicking on the Cancel button. 
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10.1.1 General Preferences 

 
The General Preferences section of the Preferences Window with server create.ife.no set 

The General Preferences section of the Preference Window is used to set the CREATE server URL, to 
specify the appearance of the CREATE tools, and to toggle caching to local disk of 3D models in the 
Model Bank. 

Important information about changing the server URL: 

• In general, it is recommended that you change the server URL setting either immediately after 
starting up a tool or immediately after saving any unfinished work to the current server, to 
avoid any risk of data loss before switching to a different server. 

• If you are behind a firewall and are using a proxy server to access the internet then you should 
also refer to Proxy Preferences – section 10.1.3 if you need to access a CREATE server that is 
not on your local network (e.g. to access the demonstration server on create.ife.no). 

If some features of the tool are not working correctly and the software is reporting server access 
errors then the reason may be that the server is incorrectly configured, in which case you should 
report this to your CREATE server administrator. 

The General options are described below: 

CREATE Server URL The server URL is the Web address of the CREATE server where 
all CREATE system and project data is stored. It is shared by all 
of the tools. If you attempt to modify the server URL then you 
will be asked to confirm the change. 

Changing the server URL to a non-existent host will render the 
tools unusable until a valid host URL has been entered. Changing 
the server URL before saving any work that has been done during 
the current work session will result in any unsaved data being lost. 

 Important: See notes above regarding changing the URL. 

Auto-login If you are logged onto a CREATE Server then this option will be 
enabled. Once enabled, you can select it to indicate that you 
would like the tools to remember your user name and password 
for the current server and use it to automatically log on to the 
server at any time where you would otherwise be prompted to 
enter user name and password. The password is stored in 
encrypted form in the create preferences file for security reasons. 
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Appearance The default Appearance is that of the host operating system. The 
host operating system appearance normally gives the CREATE 
Tools a look similar to that of other applications on your 
computer. The cross-platform setting provides a consistent user 
interface look and feel regardless of whether you are running the 
software on Windows, Linux, Mac OS X, or some other operating 
system. 

Docked Catalogue and Editors This option (currently only used by the Layout Tool) causes the 
Model Bank Catalogue and Editors side panels to be detached 
from the main application window. When detached, the panels 
appear as floating windows that can be moved freely around your 
computer screen. This is especially useful if you have multiple 
displays attached to your computer as you can then move the 
Catalogue and Editor panels to a different display, giving more 
space to work with the 3D view on your main display.  

 This option takes effect the next time the Layout Tool is started. 

Language The text of the HVRC CREATE tools user interfaces can be 
displayed in English, US English, French or Norwegian. By 
default this option is set to system default, enabling the software 
to select the language automatically depending on your operating 
system language settings. However, you can also select the 
language specifically. For example, this can be useful if you are 
working on an international project where English is the project 
language, but your personal computer is otherwise configured to 
use a non-English language.  

Metric distances If you want distances to be displayed using U.S. measurement 
units then you can turn this option off, otherwise distances are 
displayed in metric units. 

Cache If Model Bank caching is enabled then frequently used models 
load faster as copies of the models are read from the local hard 
drive, rather than transferred over the network, each time the 
model is loaded. The effect of this depends on the speed of the 
network and the size of the models. The greatest benefit of using 
caching is achieved when frequently accessing models over a 
slow connection to a server. Since the model cache is stored on 
the local disk, it is important that there is sufficient disk space (a 
few megabytes is usually sufficient) and that you are not using an 
insecure computer and an insecure user account to access the 
models (from which the cached models could be copied). 

 Pressing “Empty Cache” deletes the data in your local cache, 
freeing up disk space. 

 Caveat: If you are using a computer where your home directory is 
on a server (rather than stored locally on the computer that you are 
using) then turning on the cache may actually slow down the 
loading of Model Bank data, if the network connection to the 
CREATE Server is not significantly slower than the connection to 
your home directory. We do not recommend turning on the 
cache if your home directory is on a network server. 
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10.1.2 3D View Preferences 

 
The 3D View Preferences section of the Preferences Window 

The 3D View Preferences are only applicable to the tools that display 3D graphics, and offer control 
over the way in which the 3D graphics are rendered. These options generally have no effect until the 
application has been restarted as the affect the way in which the 3D view is initialised. 

The 3D View options are described below. 

Enable texture mip-mapping Enable generation of multi-resolution textures when textured 
models are loaded. This option improves the appearance and 
performance of textures, however some older graphics cards may 
not support this feature and the loading of textured models may be 
significantly slower if this option is enabled.  

Enable implicit anti-aliasing Allow the display driver to control full-screen anti-aliasing 
settings. If you have a graphics card with support for anti-aliased 
rendering then this option enables will cause the tool to 
acknowledge your anti-aliasing set-up. This option can greatly 
improve the visual appearance of the 3D view but there may be a 
performance impact, and some older graphics cards may not 
support this feature. 

Enable stereoscopic rendering Enable initialisation of 3D views in stereo mode. This option will 
only have an effect if you have a graphics card that supports 
active stereoscopic rendering. Unless you are actually using 
stereoscopic hardware, you should not enable this option as 
stereoscopic rendering will decrease the overall performance of 
the 3D view as it requires more effort of the graphics card. 
Default off. 

Enable render lock Controls rendering execution. Try changing this if you have driver 
problems. In general, you should leave it off. This option is 
offered only because it can resolve graphics driver problems in 
some special cases. Default off. 

Optimize for space Optimize 3D geometry to use less memory at the expense of 
slower performance. Disable this if you need to squeeze out a 
little more performance. In most cases the difference is 
unperceivable so we recommend leaving it on. Default on. 
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Texture Quality If your layouts contain many high-resolution image surface 
parametric objects then you may reach a point where the 
rendering performance degrades significantly as you run out of 
memory on the GPU. You can improve performance by reducing 
the maximum quality used for texture rendering. Note that the 
images themselves are always stored at high resolution within 
CREATE so this only affects their appearance (both in the 3D 
view and when exporting 2D images). You can safely work with 
this set to Low if you want to maximise performance while 
working on a design, and increase it when you are ready to output 
high quality images. Default is High. 

10.1.3 Proxy Preferences 

 
The Proxy Preferences section of the Preferences Window 

If you are behind a firewall and are using a web proxy server to access the Internet then you will need 
to configure the CREATE tools to use a proxy server if you wish to access a CREATE server that is not 
on your local network (e.g. to access the demonstration server on create.ife.no). 

To enable proxy support, check the Use HTTP Proxy Server option, enter the server address (without 
entering http:// in front of it and without any trailing slashes) in the Proxy Server field and the port 
number in the Port field. If you leave the port field blank then the default port (80) will be used. 

To disable proxy support, uncheck the Use HTTP Proxy Server option. 

If necessary, select Proxy Server Requires Authentication and enter your network (i.e. not CREATE) 
user name and password. 

Note that changing these items while in the middle of doing work with a CREATE tool is not 
recommended. Change these settings immediately after starting up a tool or after saving any 
unfinished work to avoid any risk of data loss. 
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Example of a filled-in Proxy Preferences section of the Preferences Window 

10.1.4 Expert Preferences 

 
The Expert Preferences section of the Preferences Window 

The Expert preferences provide access to additional options, described below. 

Automatic version check Turn off the automatic daily checking for a new release of the 
HVRC CREATE Tools. If you turn this off then you will not be 
informed automatically of new updates, but can still check for 
updates manually via the Help-menu (Help > Check for 
Update). Default on. 

Restrict report image dimensions In versions of CREATE up to 4.0, snapshots of the 3D view 
added to reports in the Verification Tool were exact duplicates 
of the image in the 3D view, with the same resolution and 
aspect. From CREATE 4.0, the snapshots are taken with a 
consistent aspect to always fit neatly into a report page, with 
landscape or portrait format depending on the current 3D view 
aspect. Default on. 

Use larger font for review comments When using a non-Latin character set for entering review 
comments or procedures, some users may find the text easier to 
read if a large font is used than the system default size. Default 
off. 

Watermark exported 2D graphics If this option is enabled then “HVRC CREATE” and the name 
of the licensee is inserted at the top left on exported images. In 
the demo version of CREATE then this cannot be turned off. 
Default off. 
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Detailed technical log in About box Select to enable detailed technical logging of system behaviour 
in the log in the About box. This is useful for troubleshooting if 
you experience technical issues with the software, and you need 
to contact CREATE support for assistance. Enabling this option 
has a small negative effect on the system performance. Default 
off. 

Enable optional 3D loaders Select to enable optional 3D loaders, to support importing 3D 
models in LWO, OBJ, PLY, and SCENE (Ogre3D) formats. 
These are termed experimental as they are not guaranteed to 
load all files in those formats correctly but may still be useful as 
they can load most files. Default on. 

Clip plane ratio If you experience tearing effects in the 3D view then this may be 
because your graphics processor is unable to draw surfaces that 
are close together with sufficient accuracy. Reducing this 
number may minimise that effect, although at the cost of not 
being able to view near surfaces as closely. Similarly, if you are 
not having any problems with tearing then you might want to try 
increasing this number in order to be able to move even closer to 
surfaces before they disappear from view. A ratio of 1000 is a 
good choice for most modern discrete graphics cards. Default is 
500. 

Ignore project model filter if standalone server If you are using a standalone CREATE Server (as 
opposed to a networked server), on the same machine 
that you are running the CREATE Tools on, then you 
can opt to ignore any project level model filters set for 
the Model Bank. This makes all categories and models 
visible in the Layout Tool regardless of any filters that 
have been specified using the Project Management 
Tool. If you are the only user of the server then this can 
be useful as you will see all new categories added to the 
Model Bank without having to update the project 
context using the Project Management Tool. Default is 
off. 

Disable snapshot generation Enable a partial workaround to enable CREATE 3D tools to run 
on hardware that does not fully support the 3D hardware 
minimum requirements. Default is off. 
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