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HVRC CREATE: Verification Tool User Guide. 

This document contains information proprietary to IFE Digital Systems. Information contained herein 
may not be copied, reproduced, disclosed or used without the express written permission of IFE Digital 
Systems. This document may be copied for use internally at the licensed site only. 

IFE Digital Systems makes no warranties with respect to the contents or use of this document, 
including but not limited to the implied warranties of merchantability and fitness for a particular 
purpose. 

The information contained in this document is subject to change without notice. 

Java™ is a trademark of Oracle Corp. 
OpenGL® is a registered trademark of Hewlett Packard Enterprise. 
Apple®, MacOS X® and macOS® are registered trademarks of Apple, Inc. 
Microsoft® and Windows® are registered trademarks of Microsoft Corp. 

All other trademarks used within this document are the properties of their respective trademark holders.  

Comments about this document are welcome and may be sent to <create-support@ife.no>. 

 

© Halden Virtual Reality Centre, IFE Digital Systems 2002-2024. All rights reserved.
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1 Overview 

1.1 HVRC CREATE 
HVRC CREATE 4 is the fourth generation of the CREATE tool suite, and builds on the technical 
platform and functionality established during the implementation of earlier versions of the software, as 
well as valuable feedback gained from usability evaluations and research work by the development 
team. 

The CREATE control room design tools combine advanced interactive 3D technology with server-
based user, project, and file management, providing an integrated package that supports and traces the 
various stages of a human-centred design process. 

The software has been designed to support a flexible, iterative, design methodology, where a control 
room design is refined and tested many times before a final design is reached. This contrasts with 
traditional control room design methods where the design process only goes through one or two human 
factors review iterations, and where it is necessary to build a costly physical control room mock-up. 
Design iterations are tracked by the system.  

When these virtual reality tools are used, it is not necessary to wait until a physical mock-up has been 
constructed before commencing design verification and validation against human factors guidelines, so 
greater emphasis can be placed on finding an optimal design solution for safe and efficient control 
room operation. Users with a variety of technical skills can operate the software, so control room 
operators, designers, human factors specialists, engineers and managers can all participate to some 
degree in the design process. 

CREATE provides features designed to support and enhance communication between the various 
interest groups involved in a design project. Support for communication between the layout designers 
and reviewers is integrated into the system, while it is possible to extract electronic documents such as 
models, designs and reports for distribution to other interested parties. 

The CREATE tools support the management of a reusable database of 3D objects, the interactive 
construction of control room layouts, and the validation of control room layouts against guidelines. 

The CREATE tools are based on cross-platform Internet and Java technology and open standards such 
as ISO VRML, DAE/COLLADA, XML, and HTML. 

1.2 Verification Tool 
When a control room prototype has been constructed using the Layout Tool and has been "published", 
the Verification Tool can access the 3D layout scene so that verification of the control room layout can 
be performed. 

The Verification Tool is used to verify control rooms with reference to review guidelines. It provides 
functionality for testing the control room prototype using a 3D model against the guidelines. This can 
be done interactively through manual measurements and inspections of the layout. This can be assisted 
by an automated analysis system that tests the 3D model using a knowledge based system that analyses 
the layout and evaluates it based on rule represantations of the guidelines. Verification Tool also 
provides functionality for documenting the review process through storing illustrative snapshots of the 
3D model, entering reviewer comments, and generating reports. 

The user can move freely around the 3D model of the control room to view the model from all angles, 
check site lines, position manikins, and measure distances between objects and between manikins and 
objects. 

The system architecture supports multiple users so that several reviewers can test the same control 
room design in parallel without disturbing each other's work. 

The user can access data about the layout and can read and input comments about the layout. 
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2 Getting Started 

2.1 System Requirements 
The minimum requirements for the HVRC CREATE Tools are: 

• Intel Core i5 (8th gen) x64 processor or similar 
• 8GB RAM 
• 64-bit Microsoft Windows 10 or Apple macOS 11 
• Discrete 3D graphics accelerator with at least 2GB memory and OpenGL 3.3 driver support  
• For Microsoft Windows: 250MB free disk space for the complete tool suite. 

For macOS: 1GB. 
• A three-button mouse (or a two-button mouse with scroll-wheel "button") 

The software can be used on less powerful hardware configurations and with two-button mice, but this 
is not recommended for serious work. Use the option or alt-key on your keyboard in combination with 
the left mouse button to simulate the middle mouse button if you do not have three mouse buttons. 

2.2 Installation 
Important: See System Requirements above before installing. 

On Windows, the installer called “CREATE Tools Installer” installs whole set of CREATE tools. 
Double-click on the installer and follow the instructions. 

On macOS, simply drag the Verification Tool (or the whole folder enclosing it) from the installation 
image into your Applications folder. 

2.3 Starting the Verification Tool 
To run the Verification Tool, open the CREATE directory, which was created when you installed the 
tools, and double-click on the Verification Tool icon. 

Depending on what options you selected when running the installer, you may also be able to start the 
tool by double clicking on an icon on the MS Windows desktop or by selecting it from the MS 
Windows Start menu (in the " HVRC CREATE" group). 

Important: The first time you run a CREATE tool, a wizard will appear that guides you through 
configuring your connection to a CREATE Server. After the wizard has completed, you can change 
your settings via the Preferences Window (see The Preferences Window). Ask your system 
administrator or project manager for assistance if you do not know what to enter. 

The information above assumes that you are using Microsoft Windows. On other platforms, the 
installation follows the platform conventions to provide easy access to the installed software. 

2.4 Support 
Please send questions, bug reports, or requests for new features to: create-support@ife.no 

When submitting bug reports, please include the following information: 

• A description of the result and how it differed from what you expected 
• The conditions or circumstances under which the problem occurred 
• Any other information that could be useful to isolate the problem, including the version of 

CREATE you are using, the version of the operating system of your computer, and the type of 
graphics card you are using. An overview of useful technical information is displayed in the 
tool’s About dialog, located in the Help menu, and can be copied into an email or saved to 
disk in a text file. 

mailto:create-support@ife.no
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2.5 User Identification 
Before you can use the Verification Tool to do any work, the server administrator or your project 
manager must have assigned a login name and password to you. If you do not have a login name and 
password then contact the server administrator or your project manager for assistance. 

When the Verification Tool starts up and needs to retrieve data from the server, it will usually request 
that you enter your login name and password. If this does not occur then you should check that the 
CREATE server address has been correctly set (See The Preferences Window). If the server address is 
correct then you should verify with your system administrator or project manager that the host is 
currently operating and accessible on your network. 

You will not be able to use the Verification Tool to do anything other than access items in the Help 
menu and specify the server address in the Preferences Window if you are not logged on to a CREATE 
server. 

Important: If you enter an incorrect username and/or password then you may have to restart the 
Verification Tool in order to log onto the server. After a successful login, you can enable an auto-login 
feature via the Preferences Window so that you do not need to enter your username and password each 
time. 

2.6 Changing Your Password 
You can change your password via the Edit > Set Password… menu item. For security reasons, you 
should change your password regularly and use a password that is difficult for other people to guess. 

You must be logged on to a CREATE server in order to change your password. 

To change your password: 

1. Select Edit > Set Password… 

2. The Change Password dialog will appear: 

 
The Change Password Dialog 

3. Enter a new password into the Password field 

4. Enter the new password again in the Confirm Password field 

5. Click on OK to commit the change or Cancel to abort 
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2.7 Overview of the User Interface 

 
The Verification Tool 

The primary user interface of the Verification Tool consists of a large window with the main features 
of the Tool easily accessible. 

At the top of the window is the main menu bar (See Menus). 

The left side of the window contains the Guideline Panel. This panel displays either an index page 
containing the available guidelines for a verification context, or an individual guideline (see Browsing 
Review Guidelines). In the image above the index page is shown. When a specific guideline is shown 
the panel will display the guideline in addition to various tools used for reviewing, such as a comments 
panel, snapshot overview, list of procedures and the result from the automated tests. At the top of the 
guideline panel is a toolbar that is used for navigation between guidelines. The review process is 
covered in more detail in Reviewing a Layout.  

The panel to the right consists of the 3D scene in which layouts are displayed and two toolbars. The 
upper toolbar holds mainly toolsets for working with the 3D scene, like measurement and manikin 
tools, while the lower toolbar provides support for navigation in the 3D scene. 

The dividing bars between these panels can be used to adjust the relative size of the panels. 
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3 Reviewing a Layout 
Each reviewer assigned to a project has an individual review context per layout, so several reviewers 
can make independent reviews of the same layout. 

You, the reviewer, can access any published layout within a project in for which you have been 
assigned a reviewer role. Once a published layout has been opened, you can step through the review 
guidelines, testing the layout against each guideline. The system will also perform automated analysis 
of the layout, checking it against each guideline. Review comments can be entered for each guideline 
and the review status of each guideline is set before proceeding. Review comments can be supported 
with snapshot images of the layout, with whichever 3D testing tools are active shown. Thus a snapshot 
of a room layout with various measurements shown, or a manikin with a view cone, for example, can 
be stored together with the review text. 

At any time, you can view a report where guidelines can be listed with comments and snapshots 
depending on their review status. 

The result of your review work can be viewed by you, the project manager and the designer of the 
layout reviewed. Thus, the layout designer can create and improved design, if necessary, based on your 
review comments. 

You can create and save reports, as well as snapshots and a plan view of the layout. These can be 
distributed to other people who are not users of the system. 

You can communicate with other designers, reviewers, and the project manager using a messaging 
system built into the Verification Tool. 

3.1 How to review a layout 
Once a published layout has been opened in the Verification Tool, you have access to your personal 
review context, within which you perform your review work. 

Normally you would start with the first guideline in the guideline set that is loaded by the Verification 
Tool when you access a published layout. You test the layout against the recommendations of the 
guideline using the 3D model and various test tools that support typical testing tasks. The system will 
also perform automatic analysis of the 3D model for the guideline, and suggest a status for the 
guideline. You then enter any comments related to the guideline and set the status (e.g OK) of the 
guideline before proceeding to the next guideline until all guidelines have been checked. The guideline 
set index page lists all of the guidelines in the guideline set that the project manager has selected for 
use in the project, and also indicates the review status so that you can easily see which guidelines you 
have checked should you choose to review them out of order or over the course of several sessions. 

Review comments can be supported with snapshot images of the layout, with whichever 3D testing 
tools are active shown. Thus a snapshot of a room layout with various measurements shown, or a 
manikin with a view cone, for example, can be stored together with the review text. 

All review comments and snapshots you enter are stored and can be used to generate reports. 

3.2 Creating a review context 
The first time you access a published layout for review, a new review context is created automatically 
for you to work in. Each reviewer has an independent work context so the work you do will not affect 
any reviews done by other reviewers. The project manager is permitted to view all contexts and thus 
compare reviewers however, unless you are also the project manager, you can only access your own 
work. 

To create a new review context: 

1. Select File > Open… 

2. If a login window appears, enter your user name and password for accessing the CREATE 
server. If you are successfully logged in then the Project Browser will appear: 
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Project Browser, with a layout selected. 

3. Using the tree on the left side of the Project Browser, select the layout that you wish to review. 
You may need to click on one of the handles next to the project name to see all of the layouts 
associated with a project in order to find the layout that you intend to work with. Information 
about projects or layouts can be viewed by selecting them, and appears on the right side of the 
Project Browser. 

4. Press OK to open the layout and start working, or Cancel to close the Project Browser without 
opening a layout.  

3.2.1 Viewing information about a project or layout 
You can view information, such as the project name, designer, and creation date for a layout or the 
name and manager of a project using the Project Browser as described in Creating a New Review 
Context. Select the item you want to view information about, but press Cancel to dismiss the Project 
Browser rather than OK to open a different layout. 

The information provided includes details about the name of the project, name of the version, who the 
designer is and when the design was last modified. 

To view information about a project or layout: 

1. Open the Project Browser using File > Open… or use the shortcut keys command-O 

2. Select the project or layout you want to view information about 

3. Information, including a snapshot for layouts, appears on the right-hand side of the Project 
Browser window. 

Press Cancel when you have finished browsing (or OK if you want to open a selected layout or create a 
new one). 

3.3 Opening an existing review context 
Opening an existing review context that you have previously worked on is done in the same way as 
creating a new context, except that when you open the Project Browser and browse the project-layout 
tree, it is possible to select either the layout or your review, which is available under the layout in the 
tree.  

If you select the layout rather than your review then it is assumed that your review is the one you wish 
to open. This is important for project managers that are also reviewers as, unlike ordinary reviewers, 
they can open review contexts created by other user for layouts created for projects they manage, 
however they cannot modify the reviews of other reviewers. See Project Manager Privileges for more 
information about this. 

To open an existing review context: 
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1. Select File > Open… or use the shortcut keys command-O 

2. If a login window appears, enter your user name and password for accessing the CREATE 
server. If you are successfully logged in then the Project Browser will appear: 

 
Project Browser, with a review selected. 

3. Using the tree on the left side of the Project Browser, select the layout that you wish to review. 
You may need to click on one of the handles next to the project name to see all of the layouts 
associated with a project in order to find the layout that you intend to work with. Information 
about projects or layouts can be viewed by selecting them, and appears on the right side of the 
Project Browser. 

4. Press OK to open the layout and start working, or Cancel to close the Project Browser without 
opening a layout. 

3.4 Saving a review context 
Use the save function to save the current work you have done on the review context. It is important to 
save regularly in order to prevent data loss. Anything that has not been saved when exiting will be lost. 

Saving a review context: 

1. Select File > Save in the menu or use the shortcut keys command-S 

3.5 Viewing information about the current project 
Information about the project that the layout you are working on belongs to is available to you and can 
be viewed, saved to file or printed. 

The information available includes the name of the project, the name of the project manager, the date 
that the project was created as well as an overview of project team members and their roles. 

To view information about the project that the layout you are reviewing belongs to: 

1. Select the Window > Project Details 

2. The Project Details window appears: 
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Project Details 

3. Press Save… to save a copy of the details to disk in HTML format or Dismiss to close the 
window. 

3.6 Viewing information about the current review 
Information about the current review is available to you. The information includes the name of the 
project, name of the layout, name of the review guideline set, name of the reviewer, when the review 
was initiated and when the review was last saved. 

To view information about the current review: 

1. Select Window > Review Info 
2. The Review Info window appears: 

 

3.7 Browsing Review Guidelines 
When you first open a review context, the 3D model of the layout is loaded and the guideline set index 
page is shown. You can access individual guidelines by clicking on the hypertext links on the index 
page.  

Once you are viewing an individual guideline, you can use the toolbar above the Guideline Panel to 
return to the index, browse between guidelines, reload a guideline or index. Shortcuts are provided in 
the Guideline Menu.  

Note that only the Reload and Info button in the toolbar are active while you are viewing the index 
page. 

When you access an individual guideline, any existing review comments and snapshots associated with 
the guideline are loaded and displayed in the Reviewer’s Comments and Snapshots panels. 
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Verification Tool with guideline set index shown with Reload button active 

To go to an individual guideline from the index page: 

1. Click on the hyperlink representing the guideline that you want to access 

To go to the index page from an individual guideline: 

1. Click on the Home button 

To go to the previous or next guideline from an individual guideline: 

1. Click on either the Previous or Next buttons 

To reload an index page or individual guideline with associate procedure: 

1. Click on the Reload button  
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Verification Tool with review guideline 

3.8 Viewing a review procedure for a guideline 
If a procedure, explaining how to test an individual guideline is available then it is displayed 
automatically in a panel below the Guideline Panel. 

You cannot modify text in the Procedure panel. The Guideline Tool is used to write procedures. 

3.9 Entering reviewer comments for a guideline 
When checking a layout against a guideline it is normally appropriate to enter some commentary, in 
addition to setting the review status. Comments are entered in the Reviewer Comments Panel.  

Comments can be modified by editing existing comments and saving the changes.  

You can cut, copy and paste text in this panel using the usual keyboard shortcuts for this (typically, 
control-X, control-C, and control-V). Control-Z can be used to undo changes, before saving them. A 
pop-up menu with cut, copy and paste function which can be accessed by clicking in the text area with 
the right mouse button pressed down. 

To clear all text from a comment, select the text, press delete (or backspace) on your keyboard and then 
save the empty text. 

 To enter a comment for a guideline: 

1. Click in the text area of the Reviewer Comments Panel and enter your text. 

2. Select File > Save in the menu or use the shortcut keys command-S to save 

3.10 Automated Testing of the Virtual Layout against Review 
Guidelines 

Verification Tool features a rule based knowledge system that can perform automatic analysis on the 
layout. Based on the analysis it can give a suggested verification status for the review guideline. This is 
meant as an assisting tool for the reviewer to help the reviewer perform the verification with more 
efficiency by having the system automatically perform tedious measurements with greater accuracy. 

The automated analysis of the virtual layout uses a rule based knowledge system. For each review 
guideline it breaks down the guideline into steps that needs to be verified in order to suggest a status for 
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the guideline. This is expressed through rules, which typically are very simple and specific. A rule can 
for example be a distance check between the user and a monitor to determine the viewing distance. 
Other examples include checking objects are within the users field of view, whether certain objects 
exists in the layout (i.e. escape signs), manoeuvring space etc. By combining these simple atomic rules 
they can together be used to check a much more complex review guideline. 

The system will suggest a status for the review guideline (see Status Result from Automated Testing), 
but the reviewer is required to manually set the status. In addition to the suggested status a detailed 
result can be shown, which is presented in the form of a tree structure of the rules. This shows what has 
been tested, which objects have been tested, and the status for each test at various levels (see Rule 
Result Tree).  

Most of the rule results have an associated visualisation that can be shown in the 3D view. The 
visualisation is shown by simply selecting the desired result in the result tree. Multiple items can be 
selected at once by holding down the command or control modifier. 

If the review guideline is supported by the automated testing system a panel will be shown below the 
navigation toolbar in the guideline panel, just above the actual guideline description. If the review 
guideline is not supported by the system the panel will be hidden. 

 
Verification Tool with automated test results shown for a review guideline, visual representation of test 

is shown in the 3D view 

3.10.1 Status Result from Automated Testing 
The status bar displays how the automated system evaluated the layout against the review guideline. 
The status bar is colour coded to reflect the status of the analysis, and also contains a text description of 
the status. There are three different statuses that the system can conclude with, these are: 

• Green – everything is ok 
• Red – there were identified some issues, needs to be investigated 
• Grey – insufficient information in the layout to perform the test 

If the status is Grey this is usually because the layout has not been enhanced with enough meta data for 
the automated analysis to be able to test it. Consult with the Layout Tool user documentation for more 
information on associated meta data through tags. 
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The status bar also contains an arrow to the left of the text description that can be clicked to hide/show 
the rule result tree. By default the result tree will only be shown if the result from the analysis indicate 
issues with the virtual layout. 

3.10.2 Rule Result Tree 
The rule result tree contains a tree structure with all the information from the automatic analysis for the 
review guideline. The result tree can be shown or hidden by selecting the arrow icon in the status bar. 

Show/hide rule result tree: 

1. Press the hide/show arrow to the left in the status bar 

 
2. The result tree panel will be shown or hidden depending on if it was visible or not 

 
The result from the automatic analysis is presented in a tree structure. Items in the structure can be 
selected by clicking on them, and the children of each item can be shown or hidden by pressing the “+” 
and “-“ icon to the left of the item. The tree is structured with more general information higher up in 
the tree. Usually at the top level the name of the guideline set will be displayed, followed by the review 
guideline in question. The result tree can also be navigated using the arrow keys on keyboard. 

To the left of each item is a status indication that displays the evaluation status for that element. For 
elements with child elements this will display the aggregate of the status from the children. This is 
prioritized based on status type, where red errors have top priority. If at least one child is an error then 
the sum status showed for the parent will be red, even though all the other children were evaluated to 
green. This is because the most important goal of the automated analysis is to identify potential issues, 
so this behaviour is to prevent potential issues from being hidden from the reviewer by always 
defaulting to the worst case result. 

When an item is selected in the result tree a visualisation corresponding to the element will be shown in 
the 3D view. This is a visual representation of the test. If a group element is selected (i.e. an element 
with children) then it will display an aggregate visualisation describing the sum of the child element 
visualisations, or in some cases just all the child visualisations. It is possible to set the 3D view to 
automatically follow the selection in the rule result tree, so that the camera will automatically transition 
to a position that guarantees that the selected visualisation is visible in the 3D view (see Customizing 
behaviour of Rule Result Tree). 

3.10.3 Customizing behaviour of Rule Result Tree 
The behaviour of the Rule Result Tree can be configured by accessing a popup menu. The popup menu 
is opened by right clicking anywhere in the rule result tree panel. 
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Rule Result Tree popup text 

The available actions are: 

• Automatically move to selection: This will automatically transition the camera to look at the 
visualisation in the 3D scene of the currently selected result in the tree structure 

• Hide all visualisations: This will toggle if visualisations of the rule results should be visible or 
not. If set to hide then no visualisation will be shown if you select a result in the tree structure 

• Show only visualisation of Errors when selecting groups: This will toggle if only error 
visualisations should be shown when you select group nodes in the result tree. This can be 
useful for not cluttering the 3D scene with visualisations that are not of interest (i.e. you are 
generally only interested in what is not ok) 

• Show only Errors In Tree: This will filter the entire rule result tree to only contain the error 
results, effectively hiding everything that is ok. This is useful if you only want to navigate the 
errors and not have the structure cluttered by the elements that are ok 

• Annotate visualisations: This will show a text label pinned to the objects and in some cases the 
visualisations in a result to make it more explicit which objects are involved 

3.11 Working with snapshots 
Snapshots are images associated with reviewer comments and are used to explain and illustrate the 
comments. They are normally snapshot images of the 3D view, but can also be other image files added 
to a review, such as photographs, diagrams, or screen shots. The snapshot panel is located at the bottom 
of the Guideline Panel. Snapshots are only available when a Review Guideline is opened. 

 
Overview of the Snapshot panel 

3.11.1 Adding a snapshot to a review 
You should normally add one or more snapshots to your review comments in order to illustrate your 
review. Snapshots are shown as thumbnails in the Snapshots panel when you access a guideline. You 
can enter labels for the snapshots that you can refer to from your review comments text. 

The snapshot functionality is only available when you are viewing a review guideline. You can 
however still take screenshots of the 3D view that you save on the local file system (see Creating a 
snapshot of the virtual layout), but you cannot store any snapshot to the server when you are not 
working directly on a specific review guideline. 
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Note that review snapshots are not saved to the server until you save the Review Context (see Saving a 
review context). 

When a report is generated, the snapshots with labels appear below your review text. Snapshots are 
automatically labelled with the name of the guideline they are associated with. To change the label 
double click on the image, and change the text directly in the window that is opened. See Viewing 
snapshots associated with a review for information about viewing, saving to disk, and modifying its 
label. 

To add a snapshot image of the current 3D view to a review: 

1. Press the Snapshot button in the snapshot panel while viewing a review guideline. 

 
The snapshot button is located to the upper right of the snapshot panel 

2. Alternatively to 1. a snapshot can be created using the menu Guideline > Add Snapshot or the 
shortcut keys command-T 

3. A thumbnail representing the snapshot will appear in the Snapshots panel. 

 
A newly-created snapshot in the Snapshots panel 

To add a JPEG image from the local file system to a review: 

1. Press the JPEG button in the snapshot panel while viewing a review guideline, or drag a JEPG 
image file (with extension “.jpg”) from the local file system onto the Snapshots panel, and 
drop it on the panel, while viewing a review guideline.  

 
The JPEG button is located to the upper right of the snapshot panel 

2. If the JPEG button was clicked then a file open dialog is shown where you have to choose the 
JPEG file to add. 

3. A thumbnail representing the image will appear in the Snapshots panel. 

3.11.2 Viewing a snapshot associated with a review 
Snapshots associated with reviews are represented as thumbnail images in the Snapshots panel. 

To view a snapshot at full size: 

1. Double click on the thumbnail of the snapshot you want to view in the Snapshots panel. 

2. The Snapshot window appears: 
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Snapshot Window 

3. The text below the snapshot is editable, and can be changed simply by selecting it and 
replacing it with the desired text 

4. To delete or export the snapshot right click anywhere on the snapshot 

5. The popup menu appears:  

 
Snapshot Window 

6. Select Delete to delete the snapshot, or select Export to save the image to the local file system. 
Export will display a save file dialog. 

3.11.3 Changing the label for a snapshot 
Snapshots are shown as thumbnails in the Snapshots panel when you access a guideline. You can enter 
labels for the snapshots that you can refer to from your review comments text. 

When a report is generated the snapshots, with labels, will appear below your review text. Snapshots 
are automatically labelled with the name of the guideline they are associated with. To change the label 
double click on the image, and change the text directly in the window that is opened. See Viewing 
snapshots associated with a review for information about viewing, saving to disk, and printing a 
snapshot, or modifying its label. 

To set or change a snapshot label: 

1. Open the Snapshot window (See Viewing snapshots associated with a review) 
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2. Edit the text in the text input field below the image. 

3. Close the Snapshot Window to store the new label. 

3.11.4 Deleting a snapshot 
Should you wish to delete a snapshot from a review then you can do so by either selecting it and 
pressing the delete button, or viewing the snapshot in the Snapshot Window. 

When you delete an image, it is permanently removed from the server. 

Deleting a snapshot cannot be undone. 

To delete a snapshot from a review using the snapshot panel: 

1. Select the snapshot you want to delete in the snapshot panel by clicking on it once: 

 
Snapshot Panel with the snapshot to delete selected 

2. Press the Delete button in the snapshot panel: 

 
The Delete button is located to the lower right of the snapshot panel 

To delete a snapshot from a review when viewing the snapshot in the snapshot window: 

3. Open the Snapshot window by double clicking on the snapshot in the snapshot panel (See 
Viewing snapshots associated with a review) 

4. Right click anywhere on the snapshot in the window 

5. Select Delete from the popup menu 

3.12 Setting review status for a guideline 
Once the testing of a layout against a guideline has been completed, you should set the guideline status. 
The guideline status indicates the extent to which the layout meets the guideline. 

The guideline status is set using a drop-down menu that is located in the Reviewer’s Comments panel, 
just above the field where the review comments can be entered. 

The guideline status is indicated graphically in the guideline set index and is used to control the 
generation of reports. 

To set the review status of a guideline: 

1. Select the appropriate status label from the Guideline Status drop-down menu above the 
Guideline Panel. Click on the menu to open it and then click on the required label. 

 
The guideline status drop-down menu 
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2. It is important to save the review context after finishing reviewing a guideline to prevent data 
loss (see Saving a review context) 

3.13 Communicating with other project team members 

 
The Project Messages window with Review level active 

The Project Messages functionality provides a simple way of communicating. Messages can be read by 
Project Management Tool, Layout Tool, and Verification Tool users. All messages are logged by the 
system and stored as part of the project data. 

• Project level messages can be read by everyone in the project team. This would typically be 
used by the project manager to provide information to everyone. 

• Layout level messages can be read by designers and reviewers while working with a specific 
layout. For example, a reviewer can write comments to the layout designer here, and the 
designer can reply. 

• Review level messages can only be seen by reviewers of a layout and is useful if there is more 
than one reviewer that needs to communicate with each other. 

To communicate with other project team members: 

1. Select Window > Project Messages to display the project message window. 

2. Select the level you want to discuss on by pressing a tab in the top of the window. 

3. Write your message. 

4. Press Submit to enter the comment. 

5. If you would like a local copy of the messages in HTML format, press Save to save the 
messages to file. 

6. Press Refresh to reload the messages and view any new messages that may have been entered 
by other team members. 

3.14 Printing the current guideline data 
The Verification Tool supports printing of the current guideline and review, or the guideline set index, 
to any printer configured on your computer. Note that the dialog windows shown by the Verification 
Tool will depend on the operating systems you are using, so the actual dialog window on a computer 
running Mac OSX will differ from the equivalent dialog window on a computer running Windows. 

To set up the page: 

1. Select File > Page Setup… 

2. Choose the required settings and confirm or reject your changes 

To print the current guideline and review or the guideline set index: 

1. While viewing the item you wish to print in the Guideline Panel, Select File > Print… 
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2. Choose the required settings. To ensure correct results, do not select orientation using the print 
dialog (Use File > Page Setup… instead) 

3. Continue (typically, click on OK) or abort (typically, click on Cancel) 
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4 Working with a virtual layout 
Once a review context for a published layout has been created or opened, the 3D view displays a virtual 
layout that you can use to test the layout against design review guidelines. The layout is an interactive 
three-dimensional model of the room. You can move around the model using a mouse and a selection 
of useful 3D tools are available to you to assist you in reviewing the layout. However, you cannot 
modify the contents of the room or move items in the room around. 

4.1 Overview of the 3D view user interface 

 
The 3D view with toolbars and a room layout loaded 

The screenshot above shows the 3D view part of the Verification Tool user interface, with upper and 
lower toolbars and a virtual layout. The upper toolbar contains a selection of tools that are useful for 
testing the model and retrieving information about it. 

The tool sets available include: 

• Manikin Tools – which are used to place virtual humans in the layout to test lines of sight, 
reach, human access, and so forth. There is normally a variety of manikins available from the 
server that can be used to test the layout, including standing and sitting manikins of various 
heights. See Using the Manikin Tools for more details. 

• Measurement Tools – which enable you to make multiple measurements in the layout to 
check distances and angles, but also to visualise areas of readability for labels and areas within 
a specific point can be seen. See Using the Measurement Tools for more details. 

The lower toolbar contains navigation controls (on the left) and direct access to the room configuration 
(on the right). See Interaction and Navigation in a virtual layout and Snapshot and Room Configuration 
for details. 
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4.2 Interaction and Navigation in a virtual layout 
There are primarily two different categories of modes that affect how you interact with the virtual 
layout; these are Interaction modes and Navigation modes. The interaction modes change how you 
interact with the 3D objects in the layout, while the navigation modes change how you navigate the 
camera around in the layout (i.e. moving around). 

The different navigation modes are Orbit, Fly, and Pan.  

The different interaction modes are Pick and Rotate. 

The navigation toolbar contains buttons for the most commonly used functions and provide useful 
information when working in the virtual layout. The toolbar contains four buttons (from the left): Pick, 
Rotate, Navigation mode (currently: Orbit), and Seek. This gives you quick access to changing 
between the two interaction modes and the navigation mode. It is also useful for keeping track of which 
mode is active. The navigation mode button changes icon depending on which navigation mode is 
active. To quickly switch between various navigation modes there are keyboard shortcuts, which will 
be covered in the following sections. Lastly the seek button allows the camera to quickly move to a 
location that the user selects in the 3D scene. 

 
The main Navigation Controls in the 3D View lower toolbar 

The Camera menu contains additional functionality used when navigating the camera in the 3D view, 
these will be covered in the following sections. 

4.2.1 Navigation Modes  
The three different navigation types are Orbit, Fly and Pan. You can switch between these types by 
accessing the Camera menu, and selecting the desired mode. The currently active mode is indicated 
both in the Camera menu and in the navigation controls in the lower toolbar. In the lower toolbar the 
navigation icon will change depending on which mode is active.  

 
Orbit is the currently active navigation mode (second from the right)  

The active navigation mode can be changed through shortcut keys, these are only available in the 3D 
view. Orbit is activated with 'W' and Fly with 'E'. 

 
Navigation type can be changed through the Camera menu  
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4.2.2 Using the Orbit Navigation 
The orbit navigation mode moves the camera in relation to a point in space, also referred to as the pivot 
point. This is the default navigation type used in the 3D tools in the HVRC CREATE suite.  

Orbit mode can be activated by pressing the shortcut key 'W' in the 3D view or through the menu 
Camera > Orbit. 

 
Orbit mode is active 

If you have a three-button mouse, the buttons are mapped as follows: 

• Left button: rotate  

 
Mouse cursor changes to orbit icon  

• Right button: pan 

 
Mouse cursor changes to pan icon  

• Middle button (or left & right button): zoom 

 
Mouse cursor changes to zoom icon  

When rotating the camera with the left mouse button you change the position and orientation of the 
camera in relation to the pivot point. The pivot point will stay stationary and the camera will rotate 
(orbit) around the point by changing the horizontal and vertical rotation of the camera.  

The direction the camera is moved when either rotating or panning is inverted, meaning that when i.e. 
dragging left, the camera will rotate to the right and vice versa.  

Panning will move the camera without changing its orientation. As the camera moves, the pivot point 
moves with the camera, maintaining the same distance and orientation from the camera.  

Zooming will move the camera closer or further from the pivot point. The pivot point will stay 
stationary while zooming. 

The distance that the camera is actually moved when either panning or zooming is relative to how far 
the camera is from the pivot point. The closer the camera is to the pivot point, the smaller is the 
distance that the camera is moved. The camera is prevented from moving past the pivot point, so the 
zooming distance will approach zero the closer the camera is to the point. 

If the ctrl key is pressed while zooming, both the camera and the pivot point can be moved back and 
forth maintaining the same distance between the camera and the pivot point. 

The pivot point can be shown in the 3D view temporarily while navigating. The point is visualised as 
three coloured lines that intersect at the point, where each lines corresponds to an axis (x, y, and z). To 
toggle the visibility of the pivot point select View > Show Camera Pivot Point (Orbit). 

 
Pivot point visualisation, red, green, blue corresponds to x, y, z axis 
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4.2.3 Using the Fly Navigation 
The fly navigation mode features free camera movement, enabling the camera to turn and tilt freely 
while moving. This gives full control over the movement. 

Fly mode can be activated by pressing the shortcut key 'E' in the 3D view or through the menu Camera 
> Fly. 

 
Fly mode is active 

If you have a three-button mouse, the buttons are mapped as follows: 

• Left button: fly  

 
Mouse cursor changes to fly icon 

• Right button: pan 

 
Mouse cursor changes to pan icon  

• Middle button: tilt 

 
Mouse cursor changes to tilt icon  

Holding down the left button will fly the camera. This will move the camera forwards or backwards 
depending on the way you drag the mouse from the point you clicked. The camera will move in the 
direction the camera is currently facing. Moving the mouse to either side will also turn the camera 
towards that direction. Note that the turning is reversed when moving backwards. 

Pressing the tilt button will tilt, or rotate, the camera in the direction you drag the mouse. This enables 
you to change the direction you are looking, and also the direction you will fly towards. 

Panning will move the camera without changing its orientation. The camera will move in the direction 
the mouse is dragged. 

The speed of the camera when using fly can be changed through Camera > Travel Speed… 

4.2.4 Using the Pan Navigation 
The pan navigation mode differs from the two other modes in that it does not allow you to change the 
orientation of the camera manually. This makes it a more specialized mode that you typically only want 
to use in some specific cases. Pan mode allows moving the camera location in any direction while 
maintaining the cameras current orientation, this effectively means that you can only pan and zoom. 

A typical use case of the pan mode would be to align the camera with an axis, i.e. the y-axis, giving 
you a top-down view. Combining this with an orthographic view projection (see Changing Perspective 
Projection) will give a nice overview of the 3D scene. Typically when navigating like this you do not 
want to orient the camera, but rather want it to stay fixed. This navigation mode is tailored for this, 
preventing the user from making accidental changes to the camera orientation.  

Although the mode itself does not offer any interactive way to change the cameras orientation, it is 
possible to use other tools to orient the camera. For example the Align Tool (see Aligning camera to 
selection) can be used to i.e. align the camera with a surface, such as a computer monitor.  

Pan mode can be activated the menu Camera > Pan. 

 
Pan mode is active 

If you have a three-button mouse, the buttons are mapped as follows: 

• Left button: pan  
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Mouse cursor changes to pan icon  

• Right button: pan 

 
Mouse cursor changes to pan icon  

• Middle button (or left & right button): zoom 

 
Mouse cursor changes to zoom icon  

Panning will move the camera without changing its orientation. The camera will move in the direction 
the mouse is dragged. The direction the camera is moved when panning is inverted, meaning that when 
i.e. dragging left, the camera will move to the right and vice versa. 

Zoom will move the camera forwards or backwards without changing its orientation.  

4.2.5 Using the Pick Mode 
The Pick mode is used to select and interact with objects in the 3D scene. 

Pick mode can be activated by pressing the shortcut key 'Q' in the 3D view or the Pick button in the 
toolbar. 

 
Pick mode is active 

The pick mode is automatically activated when using some of the tools or interactions in the 
application, such as creating a measurement (see Using the Measurement Tools).  

4.2.6 Using the Rotate Mode 
The Rotate mode is used to rotate objects in the 3D scene.  

To rotate an object: 

1. Activate the rotate mode by either pressing the Rotate button in the navigation toolbar, 
selecting Rotate in the Object menu or by pressing the shortcut key 'R'. Note that the picking 
button will also be marked as active when in Rotate mode, this is to indicate that selection of 
objects, which is a feature of the Pick mode is also active. 

2. When selecting an object with the mouse, the selected object will be rotated when moving the 
mouse while holding down the left mouse button. 

 
Rotate mode is active 

4.2.7 Temporary switching between Interaction and Navigation 
Mode 

It is possible to temporarily switch between the current active mode and the previously used mode, 
allowing you to perform some actions using the other mode, before then first mode is resumed. This is 
useful when you only need to quickly switch to another mode to do a quick action, such as when you 
are i.e. performing measurements in the scene, and you need to reposition the camera for a better 
viewing angle, before you continue the measurements. 

Note that this switching is only allowed between the last used interaction mode (pick or rotation) and 
the last used navigation mode (orbit, fly, or pan). 

The shortcut key 'shift' is used for this. For as long as the key is pressed, the previous mode will be 
active. When the key is released, the other mode will be reactivated. 
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4.2.8 Viewpoints 
When viewing the 3D scene the camera is attached to a viewpoint. As the camera, and thus the 
viewpoint is moved around in the scene its position and orientation is modified. This is stored in the 
currently active viewpoint. By changing viewpoints you can quickly switch between different locations 
in the scene, and you are also able to store locations that you might wish to jump back to at a later time. 

There are always seven predefined viewpoints available, these are referred to as System Viewpoints. 
These are automatically created when a new layout is created, and are positioned at various predefined 
locations commonly used when working with a layout. The positions adapt to the dimensions of the 3D 
scene.  

System Viewpoints: 

• Top – view from above (looking down) 

• Front – view from front 

• Left – view from left side 

• Right – view from right side 

• Back – view from rear 

• Bottom – view from below (looking up) 

• Explore – view from front, tilted 

It is also possible to create your own viewpoints, called Custom Viewpoints. There is no real 
difference between the system and the custom viewpoints, except that the system viewpoints are 
locked, meaning they cannot be renamed or deleted. Verification Tool does not support creating your 
own viewpoints, but it does have access to the viewpoints that were created in Layout Tool before the 
Layout was published.  

Select viewpoint: 

1. Select Camera > Viewpoints 

 
2. Choose the viewpoint you want to select. The currently selected viewpoint is marked in the 

list. 
Note that the system viewpoints are always listed first. The shortcut keys command-[1-7] will 
select the associated viewpoint. There is no associated shortcut available for custom 
viewpoints. 

3. When a viewpoint has been selected the camera will automatically be moved to the location 
and orientation specified by the newly selected viewpoint. 

Reset current viewpoint: 

It is possible to reset the viewpoint back to its original position and orientation.  

1. Select Camera > Reset Current Viewpoint 

For the system viewpoints this will set the viewpoints back to the correctly fitted location calculated 
based on the size of the 3D scene and which viewpoint it is (i.e. top is different from front). The custom 
viewpoints have no relation to the size of the 3D scene, and will thus be reset to the position and 
orientation they had initially, which will either be what they had when the layout was loaded. 
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Quickly switch to next viewpoint: 

It is possible to quickly select the next viewpoint in the list of viewpoints. This is done by either 
selecting Camera > Next Viewpoint or using the shortcut key command-alt-2. This cycles through all 
the viewpoints, including custom viewpoints. 

Quickly switch to previous viewpoint: 

It is possible to quickly select the previous viewpoint in the list of viewpoints. This is done by either 
selecting Camera > Previous Viewpoint or using the shortcut key command-alt-1. This cycles through 
all the viewpoints, including custom viewpoints. 

4.2.9 Using Straighten 
The Straighten feature is used to level the user view relative to the ground when moving around in the 
Explore navigation mode. It resets any tilt movement that might have been made. 

To straighten your view: 

1. Press the Straighten menu entry in the Camera menu, or use the shortcut key 'spacebar' when 
in the 3D view. 

4.2.10 Using the Seek Button 
The Seek button is used to move the view closer to a point clicked on in the scene. After activating 
Seek, you can click on the scene for the view to move automatically towards that point. This can be 
useful for quickly moving around a 3D scene. The mouse cursor will change as long as Seek is active. 

 
The Seek Button 

To use Seek navigation to move the camera towards a point in the scene: 

1. To active Seek either press the Seek Button in the navigation toolbar, or select Seek in the 
Camera menu, or press the shortcut key 'T' in the 3D view. 

2. The mouse cursor will change to the same icon as the Seek button. This will remain active 
until step 3. is completed or Seek is cancelled by either pressing the button again, or pressing 
the 'escape' key. 

3. Click on a surface in the 3D view 

4. The view will move rapidly towards the point clicked, stopping immediately in front of the 
point 

4.2.11 Using the Virtual Compass 
The virtual compass indicates the cameras position and orientation in the virtual layout in relation to 
the direction of the X, Y, and Z axis. This can be useful to help you maintain your bearings while 
moving around. 

If the camera is placed on the floor and the camera is looking straight ahead, then the x-axis is towards 
the right, y-axis is upwards, and z-axis is towards you. 

To use the compass: 

1. Select View > Show Compass 

2. A virtual compass will appear in the upper right corner of the 3D view: 

 
3. Press the menu entry again to turn the 3D compass off 
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The virtual compass is interactive. If you place your mouse above any of the elements that compose the 
compass you will see that they change colour indicating that the current element is interactive. Clicking 
on any of the cones will transition the camera to the position and orientation represented by the 
compass. The box can be pressed to switch between the different projection modes, Perspective and 
Orthographic (see Changing Perspective Projection). 

4.2.12 Setting the Background Colour 
The background colour of the 3D view can be configured to a colour that provides an appropriate 
background to the layout in use. 

To toggle between a plain white background and a user-defined background for the 3D view: 

1. Select View > Show Background 

To change the background colour of the 3D view: 

1. Select View > Set Background Colour… 

2. A colour chooser dialog will appear 

3. Select a colour and press OK or Cancel to abort 

4.2.13 Using the Visual Grid 
A user-configurable visual grid is available that can be useful as an aid to judging distances.  

To toggle the visual grid: 

1. Select View > Show Grid or press the shortcut key 'G' in the 3D View 

To configure the visual grid: 

1. Select View > Grid Options… 

2. A dialog will appear in which you can adjust the grid spacing and colour 

Press OK to accept the changes or cancel to dismiss the dialog 

4.2.14 Changing Perspective Projection 
The default 3D projection in the 3D view is perspective projection. This is similar to what the human 
eye perceives when viewing the real world, where objects in the distance appear smaller than objects 
close by. Alternatively perspective projection can be turned off, in which case orthographic 
projection will be used instead. Orthographic projection will ignore the distance between the eye and 
the objects, effectively rendering all objects at the same scale. 

To toggle perspective project: 

1. Select Camera > Perspective  

This will turn perspective projection on or off 

4.2.15 Changing the Field of View 
The field of view defines how much of the 3D scene is observable from the 3D view. Increasing the 
field of view will let you see more of the 3D scene, but objects may appear smaller. If the field of view 
value is set too high the image can look distorted. Generally values between 60 and 90 are 
recommended, depending on how large the monitor is, and how far away from the monitor the user is 
seated. 

To change the field of view: 

1. Select Camera > Field of View… 
2. A dialog will appear in which you can set the field of view 

Press OK to apply the new value or Cancel to abort 
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4.2.16 Aligning camera to selection 
The Align to Selection function positions the camera so that it is placed perpendicular to the selection. 
This is especially useful when used in combination with the zoom to selection function if you want to 
fit and align a 2D surface, such as a control panel, to your view. 

To align the camera perpendicular to the current selection: 

1. Select Camera > Align to Selection, or use the shortcut keys command-alt-F 

4.2.17 Centring camera on selection 
The current camera view of the 3D layout can be centred on the current selection. This is very useful 
for aligning the view with objects selected by name, in the Object Overview, or directly in the 3D view. 

If no objects are selected then the camera will centre on the room. 

To reposition the camera at the centre of the current selection: 

1. Select Camera > Pan to Selection, or use the shortcut keys command-shift-F 

4.2.18 Zooming camera to selection 
The Zoom to Selection function adjusts the view to fit the current selection into it. 

If nothing is selected then the room itself will be fitted into the view. 

To zoom the camera to fit the current selection into the current view: 

1. Select Camera > Zoom to Selection, or use the shortcut keys command-F or simply press 'F' in 
the 3D view 
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4.3 Snapshot and Room Configuration 

4.3.1 Creating a snapshot of the virtual layout 
Screenshots can be created by selecting File > Export 2D Graphic from the File menu.  

To create a snapshot: 

1. Select File > Export 2D Graphic from the File menu.  

2. This will prompt you with the following dialog. 

 
The Snapshot button in the centre 

3. Select the appropriate options for the image to save. 

Screen: This will export the image using the resolution of the current screen. 

Current: This will export the image using the current size of the 3D view on the screen at 
the moment the dialog was opened. 

Other: This lets you export the image using a custom resolution. 

Format can be set to either JPEG or PNG. 

4. Press Save or Cancel to abort. Upon pressing save you will be prompted to choose a filename 
and a location to save the image. 

4.3.2 Controlling visibility of parts of the virtual room 
While working with a layout you may find that parts of the room obscure your view and that it would 
be convenient to temporarily hide them. For example, it is very often useful to temporarily hide the 
ceiling of a room in order to get a good overview of the layout and work with it from above. 

Toggling the visibility of parts of the room is done using the Room Configuration window. Note that 
this is purely a visual aid for controlling visibility so no changes are actually made to the room model 
itself that would affect other users or modify the design. 

What you can toggle depends on how the room model itself has been created. In some cases, you may 
not be able to toggle anything, whereas in others there may be many parts that can be toggled. In any 
case, this functionality only toggles parts of the room model and not the contents, which remain in 
place. 

To hide/show parts of the room: 

1. Press the Room Configuration button 

 
The Room Configuration Button to the far right on the Navigation Toolbar 

2. The Room Configuration window will appear:  
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Room Configuration window 

3. Toggle the visibility of parts of the room by selecting or deselecting the checkbox next to the 
named room part. In most cases rooms are organised hierarchically, in which case a handle is 
shown to the left of the check box. Clicking on the handle reveals/hides the next level of the 
room hierarchy. 
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4.4 Annotations 
The designer can add annotations for specific objects in the scene or for the virtual layout. This enables 
the layout designer to associate information to specific virtual objects in the scene or the layout in 
general. These annotations are also available for the reviewer using Verification Tool, so they can be 
used to communicate information to the reviewer. As these are the designer’s notes, intended to 
provide information about the design to you, you are not permitted to modify them. 

4.4.1 Annotation User Interface Overview 
Selecting Window > Annotation Manager opens the Annotation Manager window.  

This window consists of two parts: 

1. The panel to the left holds a list of all current annotations for the current layout. 

2. The panel to the right holds all the information about the specific annotation.  

At the bottom right there is a button that navigates the view to the current selected target. This can be 
used to transition the camera to a specific place or object in the virtual layout that is relevant to the 
annotation.  

Note that annotations are read only in Verification Tool, meaning that they cannot be edited. 

 

4.4.2 Navigating to an annotation target 
When working with annotations, it is possible for the designer to navigate the view to a specific 
annotation target. Selecting the go to annotation target button can do this. 

To move the view to a specific annotation: 

1. Open the annotation window by selecting Window > Annotation Manager  

2. Press the Go to Target button at the bottom right in the edit panel: 
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3. The view is moved to the annotation target 

4.4.3 Show Annotations 
It is possible to visualise all the currently added annotations in the scene. When showing annotations 
the title of the annotations is visualised as 3D text in the scene. If the visualised annotation has an 
associated target, there is a connecting line between the text and the target.  

 
Visualisation of an annotation 

To show/hide annotations: 

1. Select View > Show Annotations 
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4.5 Using the Manikin Tools 
The Manikin Tools enable you position virtual humans in the layout to test lines of sight, reach, access, 
and so forth. There is normally a variety of manikins available from the server that can be used to test 
the layout, including standing and sitting manikins of various heights. 

 
The Manikin Tool toolset 

The Manikin Tools toolset consists of Add Manikin and Remove Manikin buttons to the left, the 
Manikin Selector controls in the middle and the Manikin Control Buttons to the right. 

The Manikin Control Buttons provide access to Go To, Reach, Reach Distance, View, View Cone, and 
View Cone Options functions. 

4.5.1 Inserting a manikin into a Virtual Layout 
The first step when working with a manikin is to add it to the virtual layout. Manikins can be added to a 
layout by pressing the Add Manikin Button, located to the far left of the Manikins Tool toolset. 

Once a manikin has been added to the layout, the Manikin Selector and the Manikin Control Buttons 
(Reach, View and View Cone Buttons) are activated in the Manikin Tool toolset. 

To add a manikin to the virtual layout: 

1. Press the Add Manikin button in the Manikin toolbar 

2. The Manikin Chooser window appears: 

 
The Manikin Chooser window 

3. Select the manikin you want to use from the drop-down menu. A thumbnail image of the 
selected manikin is shown below the menu as well as some information about the manikin. 

4. Press OK to add the manikin to the virtual layout, or Cancel to abort the operation 

5. The Manikin Chooser window will close. 

6. With the left mouse button, click the location in the layout where you want the manikin to be 
positioned 

7. Repeat this procedure to add more manikins to the layout 

4.5.2 Selecting a manikin in a layout 
If the virtual layout contains more the one manikin, you can select the manikin that you want to use 
using the Manikin Selector in the Manikin Tools toolset. The Manikin Selector consists of a drop-down 
menu that lists all manikins in the layout and previous and next buttons that can be used to cycle 
between manikins. 

The current manikin is always indicated by a red cone that points down at its head. 
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To select a manikin using the Manikin Selector drop-down menu: 

1. Click on the Manikin Selector drop-down menu with the left mouse button 

2. Select the manikin that you want to select from the manikins listed in the menu by clicking on 
it with the left mouse button 

3. The selected manikin will have a red cone over its head to indicate that it is selected: 

 
A selected manikin (one of several manikins in the layout) with the Manikin Selector menu shown  

To select a manikin using the Manikin Selector cycle buttons: 

1. Press the Previous or Next buttons on either side of the drop-down menu in the Manikin 
Selector to select the previous or next manikin in the list 

2. The Manikin Selector menu is updated to show the name of the selected manikin and the 
selected manikin is highlighted 

4.5.3 Positioning a manikin 
Manikins can be freely positioned in the virtual layout. You can change both the location and direction 
of a manikin. 

Manikins are always located in an upright position. 

To position the current manikin: 

1. Use the left mouse button to click on the location that you want to move the manikin to. For 
standing manikins, this is the location of the bottom of their feet, whereas for sitting manikins 
it is normally the point you want the manikin to sit on. This can vary depending on how the 
manikin has been designed. 

2. To change the direction that the manikin’s body faces in, switch to rotation mode and rotate by 
dragging the mouse (see Using the Rotate Mode). 

4.5.4 Visualising a manikin’s field of view and line of sight 
The View Cone function enables you to display a view cone for a manikin, indicating the field of view 
and line of sight. A transparent white cone depicts the field of view and a green line indicates the direct 
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line of sight. If the line of sight is broken by an object or surface then it turns red from the point at 
which the line of sight is broken. 

A View Cone Properties window can be accessed that enables you to fine-tune the view cone to suit 
your requirements. 

Each manikin you add to a layout has an independent set of view cone properties, so adjustments that 
you make to a manikin’s view cone affect that manikin only.  

 
The Manikin Control Buttons — View Cone Button selected 

To see a manikin’s view cone: 

1. Select a manikin 

2. Press the View Cone Button in the Manikin Tools toolset to turn on the view cone 
visualisation 

3. Press the View Cone Button again to turn off the view cone visualisation 

 
A manikin with view cone visualisation turned on 

To modify the view cone settings: 

1. Select a manikin and turn on its view cone 

2. Press the View Cone Options button next to the View Cone Button in the Manikin Tools 
toolset 

3. The View Cone Properties dialog window will appear: 

 
The View Cone Properties dialog window 
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4. Adjust the values as indicated in the diagrams by either directly entering a value or using the 
increment/decrement buttons. The buttons adjust the value by 5-degree intervals 

5. Press Dismiss/OK to close the dialog window 

4.5.5 Viewing a manikin’s reach envelope 
The reach envelope visualisation function enables you to see the reach envelope for a manikin. It 
indicates the maximum distance a manikin can reach. 

 
The Manikin Control Buttons – Reach Button selected 

To see a manikin’s reach envelope: 

1. Select a manikin 

2. Press the Reach Button in the Manikin Tools toolset to turn on the reach envelope 
visualisation 

3. The button to the right of the Reach button is the Reach Distance button, which toggles a 
visualisation that depicts the actual distance of the manikins reach in units. This is only 
enabled when the reach envelope has been toggled on. 

4. Press the Reach Button again to turn off the reach envelope visualisation 

 
The selected manikin with reach envelope visualisation turned on 

4.5.6 Seeing through a manikin’s eyes  
It is often useful to be able to see the virtual layout through the eyes of the manikin. By selecting the 
manikin view function from the Manikin Control buttons, you can switch your view location so it 
follows the direction line of sight (as configured using the view cone properties – See Visualising a 
manikin’s field of view and line of sight) from the location of the manikin’s eyes. 
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The Manikin Control Buttons – View Button selected 

To see the layout through a manikin’s eyes: 

1. Select a manikin 

2. Press the View Button in the Manikin Tools toolset to switch view location 

3. To turn the manikin while looking through its eyes, click and hold either the left or right 
mouse button down, while moving the mouse cursor in the direction the manikin should turn. 
The further you drag the mouse to either side from the point you originally clicked in the 3D 
view, the faster the manikin will turn. Release the mouse button, or move the mouse cursor to 
the point you first clicked to stop the manikin from rotating. 

4. Press the View Button again to revert to your previous view location 

4.5.7 Removing a manikin from a Virtual Layout 
When a manikin is no longer needed, it can be removed from the layout by selecting it and pressing the 
Remove Manikin Button, located to the far left of the Manikins Tool toolset, next to the Add Manikin 
Button. 

Removing manikin from virtual layout: 

1. Select the manikin to be removed  

2. Press the Remove Manikin Button in the Manikin Tools 
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4.6 Using the Measurement Tools 
The Measurement Tools enable you to verify the virtual layout against standards and guidelines where 
measurements of various kinds need to be taken. 

The Measurement Tools toolset includes a Distance, Perpendicular Distance, Angle, Label Size, View 
Angle and Volume tools. 

Only one measurement tool can be active at any time, but multiple measurements can be displayed 
simultaneously for each tool. 

Selecting a tool enables it and will also switch the navigation mode to picking. Deselecting a tool turns 
it off and disables interaction with any existing measurements of that tool type. 

When a tool is selected, “+” and “–“ buttons can be used to add and remove measurements. A drop-
down menu with previous and next buttons enables you to select a measurement to adjust it if you are 
working with more than one measurement. If a measurement has been completed (e.g. a distance has 
been measured) then the active measurement is highlighted to help you identify which measurement is 
active when more than one measurement has been created. 

When you add a measurement, picking is enabled and you can perform the measurement by clicking in 
the model. See the sections about the individual measurement tools for exact details on the mouse 
interaction possibilities available for each tool. 

When working with measurements you will typically be in picking mode. If you need to move to a new 
position before continuing or adapting measurements, a quick way to switch between navigation modes 
can be to use the shortcut key 'shift'. This enables you to temporarily toggle between movement and 
picking.  

Note that all measurements are in relation to surfaces in the model, including manikins added to it. You 
cannot measure the distance between, say, the ground and an arbitrary location in the air. 

The button to the far left in the measurement toolbar will remove all measurements of all types placed 
by the user. Note that this is not undoable. 

 
The Measurement Tool toolset with Distance, Perpendicular Distance, Angle, Label Size, View Angle, 
and Volume tool buttons. The button to the far left removes all measurements that have been created. 

4.6.1 Measuring Distances 
The Distance Tool and the Perpendicular Distance Tool in the Measurement Tool toolset are used to 
measure the distance between two surfaces. The Distance Tool displays the distance between two 
arbitrary points, while the Perpendicular Distance Tool displays the perpendicular distance from a point 
on a surface to the first surface hit. The Perpendicular Distance Tool is useful for measuring the 
distance between the floor and the bottom of a desktop or between two facing walls, for example. 

 
The Measurement Tool toolset with Distance Tool enabled 

 

 
The Measurement Tool toolset with Perpendicular Distance Tool enabled 



Release 4.2 (rev: 03/01/2024) 43 Verification Tool User Guide 

To measure arbitrary distances between surfaces: 

1. Activate the Distance Tool in the Measurement Toolset by pressing the Distance Tool button 

2. Use the left mouse button to click in the virtual layout on the point from which you wish to 
measure 

3. Use the left mouse button to click again in the virtual layout at the point to which you want to 
measure from the previously clicked point 

4. A measurement in the form of an elastic ruler will appear showing the distance in metres 
between the two points: 

 
The Distance Tool ruler with distance shown 

5. To adjust the ruler, pick and drag at a new location with the left mouse button. The closest 
measurement point will then move to the new point updating the ruler. The end of the ruler 
will follow the surface that the mouse is pointing at as you drag. 

6. To move the ruler to a new location, repeat from step 2 (temporarily deselect the pick button, 
or hold down the 'shift' key, to navigate, if necessary) 

7. To add a new measurement, press the plus button in the measurement toolbar and proceed 
from point 2 as before to work with the new measurement. 

8. You can add as many measurements as you like. Use the drop-down menu to select the 
measurement you want to work with or use the previous and next buttons to cycle through 
measurements. The currently active measurement will be highlighted. 

9. To remove a measurement, press the minus button while the measurement is active. 

To measure perpendicular distance from a point on a surface to the first surface hit: 

1. Activate the Perpendicular Distance Tool in the Measurement Toolset by pressing the 
Perpendicular Distance Tool button 

2. Use the left mouse button to click in the virtual layout on the point from which you wish to 
measure 

10. The perpendicular distance from the point clicked to the first surface hit is shown, similar to a 
distance measurement created using the Distance Tool. If nothing appears then there may be 
no surfaces between the point and the out boundary of the layout, so click elsewhere to try 
again. The distance in meters is shown: 
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The Perpendicular Distance Tool ruler with distance shown 

3. To add a new measurement, press the plus button in the measurement toolbar and proceed 
from point 2 as before to work with the new measurement. 

4. You can add as many measurements as you like. Use the drop-down menu to select the 
measurement you want to work with or use the previous and next buttons to cycle through 
measurements. The currently active measurement will be highlighted. 

5. To remove a measurement, press the minus button while the measurement is active. 

4.6.2 Measuring angles 
The Angle Tool is used to measure angles between locations and is similar to the Distance Tool to 
operate except that there are three points rather than two to take into account.  

Once three locations have been selected, a visualisation of the angle between the points, and a label 
indicating the size of the angle, is displayed. The points can then be adjusted at will. 

 
The Measurement Tool toolset with Angle Tool enabled 

To measure the angle between three points: 

1. Activate the Angle Tool in the Measurement Toolset by pressing the Angle Tool button 

2. Use the left mouse button to click on three locations in the model. The first location should be 
the first end point, the second is the point at which the angle should be measured, and third 
location is the final end point. 

3. A visual representation of the angle between the first and last points at the second point will 
appear with the size of the angle shown in a label. 

4. To move one of the points in the measurement pick a new point in the virtual layout with the 
left mouse button. The closest measurement point will then move to the new point. 

5. Repeat from step 2 to measure a different angle (temporarily deselect the pick button, or hold 
down the 'shift' key, to navigate, if necessary) 

6. To add a new measurement, press the plus button in the measurement toolbar and proceed 
from point 2 as before to work with the new ruler. 

7. You can add as many measurements as you like. Use the drop-down menu to select the 
measurement you want to work with or use the previous and next buttons to cycle through 
measurements. The currently active measurement will be highlighted. 

8. To remove a measurement, press the minus button while the measurement is active. 
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An angle measured using the Angle Tool. 

4.6.3 Visualising legible distance and area for text labels 
The Label Size Tool enables you to measure the distance within which text labels in a room are legible. 
This measurement tools indicates the height of the text, which you measure, and the distance from the 
measurement point within which the text is legible. This distance is visualised as a sphere that encloses 
the legibility area. While this sphere can help you to test whether text is large enough to be read at a 
certain distance, it does not indicate visibility. You can check visibility by navigating in the model, 
using the manikin tools, and/or using the View Angle Tool. 

 
The Measurement Tool toolset with Label Size Tool enabled 

To visualise the maximum distance within text of a measured height is legible: 

1. Activate the Label Size Tool in the Measurement Toolset by pressing the Label Size Tool 
button 

2. Click on the lowest point of the character of text in a label with the left mouse 

3. Click on the highest point of the character of text in the label with the left mouse button 

 
The Label Size Tool in action – the user has clicked at the bottom and top of the first digit in the 

label 

4. A rectangular area will appear highlighting the space between the two points, and a sphere 
appears indicating the area within which text of the height measured is normally legible. You 
may need to move away from the location where you made the measurement in order to see 
the sphere: 
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A Label Size Tool measurement showing the area (a 5.1m radius from the text) within which a 

label with text of height 23.75mm can be read. Note that the sphere indicates distance and not the 
visibility 

5.  The character height is displayed together with the maximum reading distance for this 
character. 

6. To adjust the height, click and drag with the left button near the end of the label you wish to 
adjust 

7. To move the measurement entirely, pick two new points using the left mouse button 

8. To add a new measurement, press the plus button in the measurement toolbar and proceed 
from point 2 as before to work with the new measurement. 

9. You can add as many measurements as you like. Use the drop-down menu to select the 
measurement you want to work with or use the previous and next buttons to cycle through 
measurements. The currently active measurement will be highlighted. 

10. To remove a measurement, press the minus button while the measurement is active. 

4.6.4 Visualising the area within which a location can be seen 
The View Angle Tool enables you to determine whether a location in a layout can be seen, providing a 
visual representation of the viewing angle for the location you select. This is particularly relevant for 
checking the extent of the area in which it is possible to see a sign (text label) or indicator and is 
typically used in combination with the manikin tools and/or in addition to the Label Size Tool. 

 
The Measurement Tool toolset with View Angle Tool enabled 

To visualise the viewing area for a location: 

1. Activate the View Angle Tool in the Measurement Toolset by pressing the View Angle Tool 
button 

2. Use the left mouse button to click in the virtual layout at the point from which you wish to 
measure 

3. A visualisation cone appears for the selected point. You may need to navigate to a new 
position in order to get a better view of the extent of the visualisation (temporarily deselect the 
pick button, or hold down the 'shift' key, to navigate, if necessary): 
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A View Angle Tool measurement seen from above 

4. To move the measurement point, pick a new point in the virtual layout with the left mouse 
button. 

5. To add a new measurement, press the plus button in the measurement toolbar and proceed 
from point 2 as before to work with the new measurement. 

6. You can add as many measurements as you like. Use the drop-down menu to select the 
measurement you want to work with or use the previous and next buttons to cycle through 
measurements. The currently active measurement will be highlighted. 

7. You can configure the viewing angle by clicking on the Viewing Angle Options button that 
appears next to the tools selector when this tool is active. 

8. To remove a measurement, press the minus button while the measurement is active. 

4.6.5 Measuring rectangular volumes 
The Rectangular Volume Tool enables you to measure volumes and distances.  

Once three locations have been selected, a visualisation of the angle between the points, and a label 
indicating the size of the angle, is displayed. The points can then be adjusted at will. 

 
The Measurement Tool toolset with Rectangular Volume Tool enabled 

To measure the rectangular volume: 

1. Activate the Rectangular Volume Tool in the Measurement Toolset by pressing the Volume 
Tool button 

2. Use the left mouse button to click on two locations in the model. These two points represents 
the lower and upper points in the volume, excluding height. Alternatively the mouse can be 
pressed and dragged, showing a visual rectangle as you drag the mouse, where the first point 
pressed, and the point when the mouse is released represents the lower and upper points of the 
volume. The height is always initialized default to 1 meter. 

3. A visual representation of the rectangular volume will be shown. The visualisation consists of 
a rectangular box representing the volume, with the distances for each axis’ depicted.  

4. There are three spheres in the lower corners that can be dragged to resize either the width or 
the depth of the volume.  
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5. There is one sphere on the top of the volume that can be dragged to increase or decrease the 
height of the volume. 

6. To move the volume around in the Layout press anywhere on the volume visualisation (except 
the sphere) and simply drag the volume around. 

7. To rotate the volume switch to rotate mode (see Using the Rotate Mode), and drag anywhere 
on the volume to rotate. 

8. To add a new measurement, press the plus button in the measurement toolbar and proceed 
from point 2 as before to work with the new volume. 

9. You can add as many measurements as you like. Use the drop-down menu to select the 
measurement you want to work with or use the previous and next buttons to cycle through 
measurements. The currently active measurement will be highlighted. 

10. To remove a measurement, press the minus button while the measurement is active. 

 
A volume measured using the Rectangular Volume Tool. 
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4.7 Plan View 
A plan view of the Layout can be created using different styles. The types can be customized by 
changing both the projection and the position and orientation of the view, as well as other properties 
that dictate how the 3D objects in the layout are drawn. 

 
Plan view of a room in a layout 

To display a plan view of a layout: 

1. Position the camera at a viewpoint with an overview of the whole 3D scene, or the parts you 
wish a view of. There are two ways to do this: 

a. Select one of the system viewpoints, i.e. Top (see Viewpoints) and select Camera > 
Reset Current Viewpoint. Optionally adjust position by zooming in/out if necessary. 

b. Manually position the camera at the location 

Pan mode navigation is very suited for navigating when taking a plan view, because it 
prevents you from accidently changing the orientation of the camera (see Using the Pan 
Navigation). 

2. Optional: Turn off perspective projection by deselecting Camera > Perspective (see Using the 
Pan Navigation) 

3. Optional: Turn on the distance grid by selecting View > Show Grid (see Using the Visual 
Grid) 

4. To save the plan view see Creating a snapshot of the virtual layout 

When you are finished just reverse the features optional steps you performed 
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5 Review Reports 
All the data collected in the review process can be viewed in a report. This report can be used as a 
design document for the designer, in an iterative process or as a verification document to the proper 
authorities.    

5.1 Generating reports 
Reports can be created that contain guideline and review text with associated snapshots 

Reports are generated depending on the status of the guidelines in the review context. When you 
request a report, a Report Specification window is shown in which you can select between a set of 
different styles for the report. 

If you are not using Microsoft Windows or Apple Mac OS X then the View Report option in the Report 
Specification window is replaced with a Save Report option. You can save the report as HTML to your 
local disk and then view it using a Web browser. 

You can print your report via your Web browser. 

Project managers have additional options. See Project Manager Privileges for details. 

To view or save a report: 

1. Select File > Export Report… 

2. The Report specification window appears: 

 
The Report Specification window used to generate a report 

3. The Report Style contains a dropdown with a list of different styles that change what the 
report contains, and how the data is presented. The text displayed below describes the 
currently selected style. 

4. Press View Report (Microsoft Windows and Apple Mac OS X only) or Save. 

5. Press View Report (Microsoft Windows Only) or Save. 

6. If you select View Report then the report will be displayed in your default web browser. 

If you select Save then a file dialog will appear requesting that you enter a name for the 
report. Enter a name and press save to store a copy of the report on your local disk. 
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6 Project Manager Privileges 
The project manager for a project can view the review contexts of any reviewer, however making 
changes is not permitted if the context was created by a user other than the manager.  See Opening an 
existing review context for additional details about accessing review contexts. 

By opening the review context of any reviewer the project manager can choose to generate a report 
based on that review context. See Generating reports or additional details about report generation. 

Project managers are not permitted to make changes to reviews made by other reviewers. 

To open any available review context while project manager: 

 
Project Browser with layout WorkstationsDraft01 shown, with three review contexts 

1. Select File > Open… to access the Project Browser. 

2. Locate the project and layout you wish to examine. 

3. Select a review context for the layout (selecting the layout itself will open your own context, if 
you are a reviewer also). 

4. Press OK, or Cancel. 

To view or save a report while project manager: 

See Generating reports. 
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7 Menus 

7.1 File Menu 

 
The File menu provides functionality for managing and printing guideline sets. All of the available 
items in the File menu have keyboard shortcuts (shown to the right of the menu items above). 

Open… is used to opens a review context (see Opening an Existing 
Review Context). 

Save is used to save the current review context (see Saving a review 
context) 

Export 2D Graphic... Exports a screen shot of the 3D view from the current viewpoint 
(see Creating a snapshot of the virtual layout) 

Export Report… is used to view reports generated by the verification tool (See 
Generating reports). 

Page Setup… is used to set the page orientation and paper size (See Printing the 
current guideline data). 

Print… is used to print the currently displayed guideline (or index) and 
procedure (See Printing the current guideline data). 

Exit is used to quit the Verification Tool. If you choose this menu item 
then you will be requested to confirm that you want to quit. 

7.2 Edit Menu 

 
The Edit menu provides functionality for editing text as well as access to functionality for changing 
your password and preferences. Most of the available items in the Edit menu have keyboard shortcuts 
(shown to the right of the menu items above). 

Undo is not generally available directly from the Edit menu, however 
the shortcut (control-z) can be used when editing text in the 
procedure panel. 

Cut is used to cut any selected text to the system clipboard. 

Copy is used to copy any selected text to the system clipboard. 

Paste is used to paste the text contents of the system clipboard. 
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Set Password… is used to change your password (see Changing Your Password). 

Preferences… are used to open the Preferences Window (see The Preferences 
Window for usage information). 

7.3 View Menu 

 
Show Background is used to toggle between a user-defined background colour for 

the 3D view and a plain white background (see Setting the 
Background Colour) 

Set Background Colour… is used to set the user-defined background colour for the 3D view 
(see Setting the Background Colour) 

Show Grid is used to toggle a visual grid (see Using the Visual Grid) 

Grid Options… is used to configure the visual grid (see Using the Visual Grid) 

Show Annotations is used to show/hide the visualisation of the annotations (see 
Show Annotations) 

Show Name of Selection is used to show/hide the name of the selected object 

Show Compass is used to show/hide the virtual compass (see Using the Virtual 
Compass) 

Show Camera Pivot Point (Orbit) is used to show/hide the pivot point when using orbit mode (see 
Using the Orbit Navigation) 

Default Lighting is used to enable/disable default lighting in the 3D scene. Turn 
this off if your scene is lit by objects from the Model Bank or by 
lights in the room itself 
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7.4 Camera Menu 

 
The Camera menu consists of features for aiding navigation as well as management of viewpoints and 
other camera related properties such as perspective projection and field of view. 

Zoom To Selection  is used to fit the view to the currently selected objects (see 
Zooming camera to selection) 

Pan To Selection is used to centre the camera over the currently selected objects 
(see Centring camera on selection). 

Align to Selection is used to align the camera to the current selected objects (see 
Aligning camera to selection). 

Viewpoints is used to select which viewpoint should be active (see 
Viewpoints) 

Next Viewpoint is used to switch to the next viewpoint in the viewpoint list (see 
Viewpoints) 

Previous Viewpoint is used to switch to the previous viewpoint in the viewpoint list 
(see Viewpoints) 

Reset Current Viewpoint is used to reset the current viewpoint back to the position and 
orientation it had when the layout was opened (see Viewpoints) 

Perspective is used to change perspective projection of the camera between 
perspective and orthographic (see Changing Perspective 
Projection) 

Fly is used to select Fly mode (see Using the Fly Navigation) 

Orbit is used to select Orbit mode (see Using the Orbit Navigation) 

Pan is used to select Pan mode (see Using the Pan Navigation) 

Travel Speed… is used to change the movement speed when using Fly mode (see 
Using the Fly Navigation) 

Straighten is used to level the camera relative to the ground (see Using 
Straighten) 

Seek is used to move the view closer to a point clicked on in the scene 
(see Using the Seek Button) 

Field of View… is used to change the field of view of the camera (see Changing 
the Field of View) 
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7.5 Guideline Menu  

 
The Guideline menu provides functionality for navigating within guideline sets as well as forcing a 
reload of the currently displayed data. All of the available items in the Guideline menu have keyboard 
shortcuts (shown to the right of the menu items above). See Browsing Review Guidelines for details. 

Home is used to go the guideline set index page. 

Previous is used to go the previous guideline in a set. This item is only 
available if you are not viewing the index page and the current 
guideline is not the first guideline in the set. 

Next is used to go the next guideline in a set. This item is only available 
if you are not viewing the index page and the current guideline is 
not the last guideline in the set. 

Reload is used to force the Verification Tool to reload the guideline data 
for the current guideline. It can be useful if the guideline failed to 
load successfully for some reason. You can also force a reload by 
going to the previous or next guideline and then going back to 
where you were. Serious problems loading and displaying 
guidelines may be the result of errors in the HTML code in which 
case you should consider exporting the guideline set and checking 
the HTML code for errors. 

Add Snapshot is used to add a snapshot to the current review guideline (see 
Adding a snapshot to a review) 

Remove Snapshots is used to remove all snapshots for the current review guideline 
(see Deleting a snapshot) 

Remove Manikins is used to clear all manikins placed in the 3D scene by the user 
(see Using the Manikin Tools) 

Remove Measurements is used to clear all measurements placed in the 3D scene by the 
user (see Using the Measurement Tools) 
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7.6 Window Menu 

 
Annotation Manager is used to edit or add annotations for this layout (see Annotations) 

Review Info is used to display information about the current review (see 
Viewing information about the current review) 

Project Details is used to view information about the project (see Viewing 
information about the project). 

Project Messages is used to communicate back and forth in the project or design 
(see Communicating with other project team members). 

7.7 Help Menu 

 
The Help menu provides access to copyright information about this software and to online help. 

About HVRC CREATE… is used to display copyright information about the CREATE tool 
suite. 

About Verification Tool… Display technical information about this tool. This also provides 
access to the log file. 
If you are using Mac OS X then this menu item is located in the 
application menu ("Verification Tool") 

Check for Update is used to check if the latest version of this tool is being used. 

Verification Tool Help is used to access the online user guide for the Verification Tool. 
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8 Configuration  

8.1 The Preferences Window 
 

 
The Preferences Window 

The first time you use one of the CREATE tools you will normally be presented with a wizard that 
assists you in setting the configuration options that you need to get started using HVRC CREATE. 
Subsequently, you can adjust your personal configuration via the options in the Preferences Window. 

The Preferences Window can be accessed from the main menu bar's Edit > Preferences… menu item. 
The keyboard shortcut to open the Preferences Window is ctrl-comma (or command-comma). 

Changes to preferences are global and therefore affect all CREATE tools that you use, however they 
are also personal and will not affect any other users of CREATE that share a computer as long as you 
are not sharing a computer user account. 

There are four sets of preferences in the Preferences Window, the most important of which is the 
“General” set, which is used to enter the address of the CREATE server that will be used. The 
individual sets and the options they contain are described in the subsections below. 

The Preferences Window has three buttons: 

• OK is used to update the preferences and close the window 

• Apply is used to set the update the preferences but not close the window 

• Cancel is used to dismiss the window without making any changes 

Clicking Apply followed by Cancel is equivalent to clicking OK. 

A configuration file containing your preferences is created in your home directory and will be applied 
the next time you run a CREATE tool. 

Closing the window by clicking on the close box (top right of the window) is equivalent to clicking on 
the Cancel button. Hitting the escape key is also equivalent to clicking on the Cancel button. 
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8.1.1 General Preferences 

 
The General Preferences section of the Preferences Window with server create.ife.no set 

The General Preferences section of the Preference Window is used to set the CREATE server URL, to 
specify the appearance of the CREATE tools, and to toggle caching to local disk of 3D models in the 
Model Bank. 

Important information about changing the server URL: 

• In general, it is recommended that you change the server URL setting either immediately after 
starting up a tool or immediately after saving any unfinished work to the current server, to 
avoid any risk of data loss before switching to a different server. 

• If you are behind a firewall and are using a proxy server to access the internet then you should 
also refer to Proxy Preferences – section 8.1.3 if you need to access a CREATE server that is 
not on your local network (e.g. to access the demonstration server on create.ife.no). 

If some features of the tool are not working correctly and the software is reporting server access 
errors then the reason may be that the server is incorrectly configured, in which case you should 
report this to your CREATE server administrator. 

The General options are described below: 

CREATE Server URL The server URL is the Web address of the CREATE server where 
all CREATE system and project data is stored. It is shared by all 
of the tools. If you attempt to modify the server URL then you 
will be asked to confirm the change. 

Changing the server URL to a non-existent host will render the 
tools unusable until a valid host URL has been entered. Changing 
the server URL before saving any work that has been done during 
the current work session will result in any unsaved data being lost. 

 Important: See notes above regarding changing the URL. 

Auto-login If you are logged onto a CREATE Server then this option will be 
enabled. Once enabled, you can select it to indicate that you 
would like the tools to remember your user name and password 
for the current server and use it to automatically log on to the 
server at any time where you would otherwise be prompted to 
enter user name and password. The password is stored in 
encrypted form in the create preferences file for security reasons. 



Release 4.2 (rev: 03/01/2024) 59 Verification Tool User Guide 

Appearance The default Appearance is that of the host operating system. The 
host operating system appearance normally gives the CREATE 
Tools a look similar to that of other applications on your 
computer. The cross-platform setting provides a consistent user 
interface look and feel regardless of whether you are running the 
software on Windows, Linux, Mac OS X, or some other operating 
system. 

Docked Catalogue and Editors This option (currently only used by the Layout Tool) causes the 
Model Bank Catalogue and Editors side panels to be detached 
from the main application window. When detached, the panels 
appear as floating windows that can be moved freely around your 
computer screen. This is especially useful if you have multiple 
displays attached to your computer as you can then move the 
Catalogue and Editor panels to a different display, giving more 
space to work with the 3D view on your main display.  

 This option takes effect the next time the Layout Tool is started. 

Language The text of the HVRC CREATE tools user interfaces can be 
displayed in English, US English, French or Norwegian. By 
default this option is set to system default, enabling the software 
to select the language automatically depending on your operating 
system language settings. However, you can also select the 
language specifically. For example, this can be useful if you are 
working on an international project where English is the project 
language, but your personal computer is otherwise configured to 
use a non-English language.  

Metric distances If you want distances to be displayed using U.S. measurement 
units then you can turn this option off, otherwise distances are 
displayed in metric units. 

Cache If Model Bank caching is enabled then frequently used models 
load faster as copies of the models are read from the local hard 
drive, rather than transferred over the network, each time the 
model is loaded. The effect of this depends on the speed of the 
network and the size of the models. The greatest benefit of using 
caching is achieved when frequently accessing models over a 
slow connection to a server. Since the model cache is stored on 
the local disk, it is important that there is sufficient disk space (a 
few megabytes is usually sufficient) and that you are not using an 
insecure computer and an insecure user account to access the 
models (from which the cached models could be copied). 

 Pressing “Empty Cache” deletes the data in your local cache, 
freeing up disk space. 

 Caveat: If you are using a computer where your home directory is 
on a server (rather than stored locally on the computer that you are 
using) then turning on the cache may actually slow down the 
loading of Model Bank data, if the network connection to the 
CREATE Server is not significantly slower than the connection to 
your home directory. We do not recommend turning on the 
cache if your home directory is on a network server. 
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8.1.2 3D View Preferences 

 
The 3D View Preferences section of the Preferences Window 

The 3D View Preferences are only applicable to the tools that display 3D graphics, and offer control 
over the way in which the 3D graphics are rendered. These options generally have no effect until the 
application has been restarted as the affect the way in which the 3D view is initialised. 

The 3D View options are described below. 

Enable texture mip-mapping Enable generation of multi-resolution textures when textured 
models are loaded. This option improves the appearance and 
performance of textures, however some older graphics cards may 
not support this feature and the loading of textured models may be 
significantly slower if this option is enabled.  

Enable implicit anti-aliasing Allow the display driver to control full-screen anti-aliasing 
settings. If you have a graphics card with support for anti-aliased 
rendering then this option enables will cause the tool to 
acknowledge your anti-aliasing set-up. This option can greatly 
improve the visual appearance of the 3D view but there may be a 
performance impact, and some older graphics cards may not 
support this feature. 

Enable stereoscopic rendering Enable initialisation of 3D views in stereo mode. This option will 
only have an effect if you have a graphics card that supports 
active stereoscopic rendering. Unless you are actually using 
stereoscopic hardware, you should not enable this option as 
stereoscopic rendering will decrease the overall performance of 
the 3D view as it requires more effort of the graphics card. 
Default off. 

Enable render lock Controls rendering execution. Try changing this if you have driver 
problems. In general, you should leave it off. This option is 
offered only because it can resolve graphics driver problems in 
some special cases. Default off. 

Optimize for space Optimize 3D geometry to use less memory at the expense of 
slower performance. Disable this if you need to squeeze out a 
little more performance. In most cases the difference is 
unperceivable so we recommend leaving it on. Default on. 
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Texture Quality If your layouts contain many high-resolution image surface 
parametric objects then you may reach a point where the 
rendering performance degrades significantly as you run out of 
memory on the GPU. You can improve performance by reducing 
the maximum quality used for texture rendering. Note that the 
images themselves are always stored at high resolution within 
CREATE so this only affects their appearance (both in the 3D 
view and when exporting 2D images). You can safely work with 
this set to Low if you want to maximise performance while 
working on a design, and increase it when you are ready to output 
high quality images. Default is High. 

8.1.3 Proxy Preferences 

 
The Proxy Preferences section of the Preferences Window 

If you are behind a firewall and are using a web proxy server to access the Internet then you will need 
to configure the CREATE tools to use a proxy server if you wish to access a CREATE server that is not 
on your local network (e.g. to access the demonstration server on create.ife.no). 

To enable proxy support, check the Use HTTP Proxy Server option, enter the server address (without 
entering http:// in front of it and without any trailing slashes) in the Proxy Server field and the port 
number in the Port field. If you leave the port field blank then the default port (80) will be used. 

To disable proxy support, uncheck the Use HTTP Proxy Server option. 

If necessary, select Proxy Server Requires Authentication and enter your network (i.e. not CREATE) 
user name and password. 

Note that changing these items while in the middle of doing work with a CREATE tool is not 
recommended. Change these settings immediately after starting up a tool or after saving any 
unfinished work to avoid any risk of data loss. 
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Example of a filled-in Proxy Preferences section of the Preferences Window 

8.1.4 Expert Preferences 

 
The Expert Preferences section of the Preferences Window 

The Expert preferences provide access to additional options, described below. 

Automatic version check Turn off the automatic daily checking for a new release of the 
HVRC CREATE Tools. If you turn this off then you will not be 
informed automatically of new updates, but can still check for 
updates manually via the Help-menu (Help > Check for 
Update). Default on. 

Restrict report image dimensions In versions of CREATE up to 4.0, snapshots of the 3D view 
added to reports in the Verification Tool were exact duplicates 
of the image in the 3D view, with the same resolution and 
aspect. From CREATE 4.0, the snapshots are taken with a 
consistent aspect to always fit neatly into a report page, with 
landscape or portrait format depending on the current 3D view 
aspect. Default on. 

Use larger font for review comments When using a non-Latin character set for entering review 
comments or procedures, some users may find the text easier to 
read if a large font is used than the system default size. Default 
off. 

Watermark exported 2D graphics If this option is enabled then “HVRC CREATE” and the name 
of the licensee is inserted at the top left on exported images. In 
the demo version of CREATE then this cannot be turned off. 
Default off. 
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Detailed technical log in About box Select to enable detailed technical logging of system behaviour 
in the log in the About box. This is useful for troubleshooting if 
you experience technical issues with the software, and you need 
to contact CREATE support for assistance. Enabling this option 
has a small negative effect on the system performance. Default 
off. 

Enable optional 3D loaders Select to enable 3D loaders, to support importing 3D models in 
glTF, LWO, OBJ, PLY, and SCENE (Ogre3D) formats. These 
are described as optional as they are not guaranteed to load all 
files in those formats correctly but are useful as they can load 
most files in those formats. Saving your work before attempting 
to import a model for the first time in one of these formats is 
recommend. Default on. 

Clip plane ratio If you experience tearing effects in the 3D view then this may be 
because your graphics processor is unable to draw surfaces that 
are close together with sufficient accuracy. Reducing this 
number may minimise that effect, although at the cost of not 
being able to view near surfaces as closely. Similarly, if you are 
not having any problems with tearing then you might want to try 
increasing this number in order to be able to move even closer to 
surfaces before they disappear from view. A ratio of 1000 is a 
good choice for most modern discrete graphics cards. Default is 
500. 

Ignore project model filter if standalone server If you are using a standalone CREATE Server (as 
opposed to a networked server), on the same machine 
that you are running the CREATE Tools on, then you 
can opt to ignore any project level model filters set for 
the Model Bank. This makes all categories and models 
visible in the Layout Tool regardless of any filters that 
have been specified using the Project Management 
Tool. If you are the only user of the server then this can 
be useful as you will see all new categories added to the 
Model Bank without having to update the project 
context using the Project Management Tool. Default is 
off. 

Disable snapshot generation Enable a partial workaround to enable CREATE 3D tools to run 
on hardware that does not fully support the 3D hardware 
minimum requirements. Default is off. 
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